Jump to content
Eternal Lands Official Forums
Roja

Sky Client Test #1

Recommended Posts

Read ALL & follow the instructions below before downloading or doing anything!

 

We need some people to test out the new sky client. Please post bugs here on it.

 

**If you do not know how to unzip files then don't try this unless you have someone to help you!**

 

1. Download this zip file(windows client only): http://www.eternal-lands.com/misc/EL_skytest01.zip

And unzip it into your Eternal Lands directory. It will overwrite some files.

 

2. Run the new el_sky01.exe file. This file can only be found in your EL directory, it won't automatically appear on your desktop or replace the icons currently on your desktop.

 

 

 

 

Once you have the client running...

 

1. Under the Adv. Video settings adjust the Near & Far plane distance. The Near plane should be something very small, I have mine set at the minimum value: 0.10. The Far plane can be as large as your computer can handle. So just use whatever works for you and adjust it as needed.

 

2. Under Sky&Cam tab click on Extended Camera-this allows you to see the sky.

 

3. Under the Details tab, make sure you have Render Fog turned on. The fog has been changed quite a lot and it's now a part of the sky atmosphere. If you experience any problems or can't run the client with the fog on then turn it off.

 

4. Feel free to play with the settings under the Sky&Cam tab, and try out the Follow cam.

 

5. Pressing alt+f puts you into first person view. Pressing alt+g puts you in "Grab Mode".

 

6. With the sky, having a lower perspective set, around 40, will look better than having it very high. Having it high is no longer needed to see far in the distance.

 

 

Troubleshooting:

1. Do you log in and it's all black? Do #1 above.

2. Does your camera go undergound and get "stuck"? Press alt+f, then alt+f again to go back to normal 3rd person view.

3. Do you see no sky? Go to Sky&Cam tab and press Extended Camera.

4. The water probably looks awkward because the clouds don't match the reflection in the water. That'll be fixed.

Share this post


Link to post
Share on other sites

Client crashed everytime I attempted to change the plane distance, and all I can see is the stars (no Draia, characters, or anything. Just stars)

 

Oh well, seems my laptop wasn't built for such requirements. Thanks anyway, I'm sure others will enjoy it :ph34r:

Share this post


Link to post
Share on other sites

Client crashes now and then. I have some flickering textures from certain angles. But features works well (until it crashes). However, my error_log remains empty, so I cannot provide any informations unfortunately.

Share this post


Link to post
Share on other sites

May I assume this is for Perspective view only (doesn't work with Isometric which is what I tend to use)?

Share this post


Link to post
Share on other sites

I like it a lot but seems my video card isn't up to snuff... It drops my usual 80-100 FPS down to 2-10 FPS. Here are my stats in case it's helpful.

 

[Display]

Processor: AMD Athlon 64 X2 Dual Core Processor 4200+ (2207 MHz)

Operating System: Microsoft Windows Vista

DirectX version: 10.0

GPU processor: GeForce 8500 GT

ForceWare version: 169.25

Total available graphics memory: 1279 MB

Dedicated video memory: 256 MB

System video memory: 0 MB

Shared system memory: 1023 MB

Video BIOS version: 60.86.34.00.75

IRQ: 16

Bus: PCI Express x16

 

EDIT:

On a whim (or a hunch I guess) I rebooted. Seems to be back up to normal framerates. Perhaps something else I was running didn't unload from memory right or some such...

Edited by DogBreath

Share this post


Link to post
Share on other sites

Great, it looks very nice.

 

Not sure if its just me but PGE up & PGE down dont zoom the camera in and out ,only the mouse wheel does

 

Edit:

 

When you have Extended camera turned on during combat, and the character does that new jump kick animation you get bad camera wobble

Edited by conavar

Share this post


Link to post
Share on other sites

This is so awesome! Theres only problem I see so far is that in the isometric view the camera is more likely to go through the floor or other things.

Share this post


Link to post
Share on other sites
May I assume this is for Perspective view only (doesn't work with Isometric which is what I tend to use)?

 

 

This is so awesome! Theres only problem I see so far is that in the isometric view the camera is more likely to go through the floor or other things.

 

Isometric view is pretty much contradictory to what is seen in the "sky view", perspective is a natural part of seeing things. So using it in the extended camera view shouldn't even be an option really.

Share this post


Link to post
Share on other sites

I'm having zoom-in issues, first screenshot is zoomed out fully, second is zoomed in, third fully zoomed in having turned the camera a bit. (Note: I followed roja's steps in her post and used her exact numbers)

gallery_941_20_201415.jpg

 

gallery_941_20_59775.jpg

 

gallery_941_20_28120.jpg

Share this post


Link to post
Share on other sites

Recent (today) pull of cvs, fresh make.conf file, enabling sky_fpv as the only non-default option gives:

 

gallery_18100_30_1194604.png

 

Note I have been playing with skybox enabled for months without issue, I changed no other settings in my ctrl-o or anywhere else. I can flip back to my older cvs client and have a working skybox without any changes. Disabling that compile option fixes this error, but of course I dont then have skybox.

 

S.

 

EDIT, I disabled SIMPLE_LOD and still get the same effect:

 

gallery_18100_30_1010370.png

 

Nice to be able to see the waterfall from here but still :)

Edited by Spleenfeeder

Share this post


Link to post
Share on other sites

Initially, I saw nothing but a black screen.

I adjusted Near Plane to "0.10" and perspective "0.40" log in and out 2 times and

it worked fine.

 

I love it, adds a whole new atmosphere to el.

I find myself starting all over, roaming like I just began. :)

Share this post


Link to post
Share on other sites

Minor bug:

If you place the camera as low as you can and then you sit down, the camera falls under the surface of the ground.

Share this post


Link to post
Share on other sites

Well I just found a bug. If it is one that is.....

I was sitting in Tarsengard storage, and using the Mouse wheel spun the room around and got

"Eternal-Lands Client has encountered a problem and needs to close. We are sorry for the inconvenience."

 

Just tried it outside storage and no crash.

Share this post


Link to post
Share on other sites

Probably not a bug, and not very important either(anyone else get this?), but it seems to me the harvesting effect has a much taller range and spin now, if its intentional, i think its pr0 :D

Anyway, I love the skycam ^^ , pity i missed it at night :P

 

Harvest Effect

 

oh and the right click menus=great too

 

Edit: also unchecking harvest effect doesnt turn it off :S

Edited by Dago

Share this post


Link to post
Share on other sites
Not sure if its just me but PGE up & PGE down dont zoom the camera in and out ,only the mouse wheel does

Was a bug, it's fixed in CVS now.

 

@Aislinn and Spleen: are you sure to have correct numbers for near and far clip planes? The near clip plane should be lower than 1.0 (0.1 is good) and the far clip plane should be over the near clip plane value and a number between 50.0 and 100.0 is good.

 

If you place the camera as low as you can and then you sit down, the camera falls under the surface of the ground.

Is it without the auto zoom option?

 

EDIT: For the people who are experiencing crashes, were you using the 'no cluster' client before? Are you using reflections and does it resolves your problem when you turn them off?

Edited by Schmurk

Share this post


Link to post
Share on other sites
If you place the camera as low as you can and then you sit down, the camera falls under the surface of the ground.

Is it without the auto zoom option?

 

EDIT: For the people who are experiencing crashes, were you using the 'no cluster' client before? Are you using reflections and does it resolves your problem when you turn them off?

 

it happens with me as well, without the autozoom on,standing or alt f fixes

Share this post


Link to post
Share on other sites

Works great, but there are two issues:

 

-- When entering the first person view the "follow camera" option deactivates automatically

 

-- In perspective view pressing the left key makes the camera move to the left, so you can see things that are to the right (as it happened before). However, in first person view pressing the left key makes the camera rotate left, so you can see things that are to the left. IMO this should be changed so the same key has the same effects in both views

Share this post


Link to post
Share on other sites
@Aislinn and Spleen: are you sure to have correct numbers for near and far clip planes? The near clip plane should be lower than 1.0 (0.1 is good) and the far clip plane should be over the near clip plane value and a number between 50.0 and 100.0 is good.

 

Thankyou Schmurk (and Roja in #mod, even though it was directed at Aisy :P ) setting those near and far clips was it. I guess I didn't look there because I have been running skybox for a few months now with the values I had. :D

 

S.

Share this post


Link to post
Share on other sites
@Aislinn and Spleen: are you sure to have correct numbers for near and far clip planes? The near clip plane should be lower than 1.0 (0.1 is good) and the far clip plane should be over the near clip plane value and a number between 50.0 and 100.0 is good.

Settings:

Perspective: .40

Near Plane Distance: .10

Far Plane Distance: 100.00

Share this post


Link to post
Share on other sites
Probably not a bug, and not very important either(anyone else get this?), but it seems to me the harvesting effect has a much taller range and spin now, if its intentional, i think its pr0 :)

Well, I overdid it a bit with the particle life span, should be corrected in CVS now.

The spin is intentional, of course :)

Share this post


Link to post
Share on other sites

One thing I noticed, in 1st Person view (alt+f) the camera seems to be located

in the waist\groin area. Maybe I'm wrong, or this is in fact, groin cam :)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×