Jump to content
Eternal Lands Official Forums
Entropy

Windows and Linux version 1.9.3 full download

Recommended Posts

I uploaded the Window sand Linux full downloads of the client, I would like someone to test them and see if they work properly.

Download the files:

Windows: http://www.eternal-lands.com/el_193_install.exe

Linux: http://www.eternal-lands.com/el_linux_193.zip

Delete or move your EL directory.

Launch the exe or unpack the zip.

Start the game, see if there are any issues. If so, post here.

Share this post


Link to post
Share on other sites

I have the same sound problem as bluap's previous Linux test, with pulse audio.

 

As I mentioned I would try in in that thread, I have created a static build that does not need pulse. This is a 64bit build. Can people that have pulse (most but not all distros have it now) test it and verify if it still works for them? If it does, I will make a 32 bit version as well on my older comp.

 

el.x86_64.linux.bin

Share this post


Link to post
Share on other sites

I tried the Linux version.

I could not make the binary an executable. Nothing happened. No errors, nothing, like I never ran the command.

Just for kicks I tried to run it and got an error of "Illegal instruction".

(Note for bluap: blackchook downloaded it and it worked for him. He suggested I change the name of the binary from el.x86.linux.bin to el and run the chmod, as that worked for him. It did not work for me. Interesting note, the permissions did show it as being executable but it still didn't work, just like above.)

 

 

I tried to compile my own, pulled a fresh gitpull, and got this error:

  LINK el.x86.linux.bin
/usr/bin/ld: paste.o: undefined reference to symbol 'XConvertSelection'
/usr/bin/ld: note: 'XConvertSelection' is defined in DSO /usr/lib/libX11.so.6 so try adding it to the linker command line
/usr/lib/libX11.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make: *** [el.x86.linux.bin] Error 1
[sb@precision330 Eternal-Lands]$ 

 

So right now I am on an old client with the new data in the new directory from this new download, and will try again in the morning.

Share this post


Link to post
Share on other sites

I tried the Linux version.

I could not make the binary an executable. Nothing happened. No errors, nothing, like I never ran the command.

Just for kicks I tried to run it and got an error of "Illegal instruction".

(Note for bluap: blackchook downloaded it and it worked for him. He suggested I change the name of the binary from el.x86.linux.bin to el and run the chmod, as that worked for him. It did not work for me. Interesting note, the permissions did show it as being executable but it still didn't work, just like above.)

 

 

I tried to compile my own, pulled a fresh gitpull, and got this error:

  LINK el.x86.linux.bin
/usr/bin/ld: paste.o: undefined reference to symbol 'XConvertSelection'
/usr/bin/ld: note: 'XConvertSelection' is defined in DSO /usr/lib/libX11.so.6 so try adding it to the linker command line
/usr/lib/libX11.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make: *** [el.x86.linux.bin] Error 1
[sb@precision330 Eternal-Lands]$ 

 

So right now I am on an old client with the new data in the new directory from this new download, and will try again in the morning.

you need to add

EXTRA_LIBS=-lstdc++ -lX11

to make.conf

Edited by hussam

Share this post


Link to post
Share on other sites

I have the same sound problem as bluap's previous Linux test, with pulse audio.

 

As I mentioned I would try in in that thread, I have created a static build that does not need pulse. This is a 64bit build. Can people that have pulse (most but not all distros have it now) test it and verify if it still works for them? If it does, I will make a 32 bit version as well on my older comp.

 

el.x86_64.linux.bin

That works fine for me on Ubuntu 11.10.

 

I tried the Linux version.

I could not make the binary an executable. Nothing happened. No errors, nothing, like I never ran the command.

Just for kicks I tried to run it and got an error of "Illegal instruction".

(Note for bluap: blackchook downloaded it and it worked for him. He suggested I change the name of the binary from el.x86.linux.bin to el and run the chmod, as that worked for him. It did not work for me. Interesting note, the permissions did show it as being executable but it still didn't work, just like above.)

 

Renaming the file will have no effect, not sure why you could not make it executable. Are you sure you had permissions to change it?

 

As for the "Illegal instruction" problem. That could be my fault. I built both the binaries from completely clean source. But I forgot to remove the PLATFORM line in make.defaults which means the code will have been optimized for my CPU. Sorry about that, particularly for Radu and his slow upload rate:( I have put new versions on my web site: 32 and 64 bit builds.

Edited by bluap

Share this post


Link to post
Share on other sites

Renaming the file will have no effect, not sure why you could not make it executable. Are you sure you had permissions to change it?

Yeah, well I was willing to try anything. I have never seen that happen before. And yes, I had permissions.

 

 

As for the "Illegal instruction" problem. That could be my fault. I built both the binaries from completely clean source. But I forgot to remove the PLATFORM line in make.defaults which means the code will have been optimized for my CPU. Sorry about that, particularly for Radu and his slow upload rate:( I have put new versions on my web site: 32 and 64 bit builds.

This one works like a charm! 32

Thank you so much.

 

 

you need to add

EXTRA_LIBS=-lstdc++ -lX11

to make.conf

And this works now perfectly as well with the new data. Thank you!

Share this post


Link to post
Share on other sites

maybe get rid of some unused settings in the default el.ini to get rid of some confusing warnings in the logs:

 

[14:52:12, elconfig.c:1483] Warning: Can't find var 'server_address = game.eternal-lands.com
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'server_port = 2001
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_vertex_array = 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_mipmaps = 0
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'text_filter_replace = smeg
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'compass_north = 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'near_plane= 0.1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'transparency_resolution_fix= 0
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'dim_sounds_on_rain= 0
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'anisotropic_filter= 2
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'render_skeleton= 0
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'render_mesh= 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_display_actors= 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_actor_bbox_check= 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_render_mesh_shader= 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_set_transformation_buffers= 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_build_actor_bounding_box= 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_model_attach_and_detach_mesh= 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_render_attached_meshs= 1
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'use_ext_gpu_program_parameters= 0
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'skybox_update_every_frame= 0
', type 2
[14:52:12, elconfig.c:1483] Warning: Can't find var 'seconds_between_shadows_updates= 10
', type 2

 

on Vista the compatibility assistant asks if the installation was successful (google translation):

 

[Window Title] Program Compatibility Assistant

[Main Instruction] This program might not have installed correctly.

When this program was not installed properly, then repeat the process using settings that are compatible with this version of Windows.

1.[install again with recommended settings]

2.[The program has been installed correctly.]

3.[Cancel]

[Footer] What settings?

Even if you say it's installed correctly it doesn't show in the list of installed programs.

Share this post


Link to post
Share on other sites

I have the same sound problem as bluap's previous Linux test, with pulse audio.

 

Same here in ubuntu 11.10 and ubuntu 12.04 alpha 2

Share this post


Link to post
Share on other sites

I have the same sound problem as bluap's previous Linux test, with pulse audio.

 

As I mentioned I would try in in that thread, I have created a static build that does not need pulse. This is a 64bit build. Can people that have pulse (most but not all distros have it now) test it and verify if it still works for them? If it does, I will make a 32 bit version as well on my older comp.

 

el.x86_64.linux.bin

I now have a 32bit static build without pulse too.

 

32bit 1.9.3 client:

el.x86.linux.bin

 

64bit 1.9.3 client:

el.x86_64.linux.bin

 

If this build works for people, I think these binaries should be the official ones. They have fewer dependencies than the previously released ones did, and should work for more people.

 

edit: binaries replaced with a newer version after a bugfix. See post below.

Edited by Quesar

Share this post


Link to post
Share on other sites

Confirmed on Windows also.

Workaround to get the stats/clock/compass back: F6 to disable transparency, 2xTAB or 2xF1

 

Edit: a bugfix is now available in git

Edited by Sir_Odie

Share this post


Link to post
Share on other sites

Bluap, can you update the hardy heron repository? I know hardy is old, but it's what I use.

I presume you know that hardy dekstop is no longer supported. Anyhow, the packages are building now and should be ready within the hour.

Share this post


Link to post
Share on other sites

Bluap, can you update the hardy heron repository? I know hardy is old, but it's what I use.

I presume you know that hardy dekstop is no longer supported. Anyhow, the packages are building now and should be ready within the hour.

tyvm, bluap. Your ubuntu packages are much appreciated.

Share this post


Link to post
Share on other sites

New problem in Linux version I'd not done any ranging until yesterday there is a render glitch that puts a white rectangle on the bow and arm when the bow is drawn. I have seen this reported earlier but thought it was fixed. Using the 2012-02-12 client. Maybe I'm missing a graphic element??? I have had a bit of problems with ownership of files in some situation but thought I got that all sorted. Not sure if the problem was in earlier version since I don't do too much ranging at the moment.

Share this post


Link to post
Share on other sites

I have reproduced this bug on an older system with a Geforce 7300 card, but my newer system with a GT240 does not have the problem. Cordor has the same problem, and he has an old 5900XT (also nvidia). On the system with the 7300, the driver version was originally 260.something, but I updated to 290.10 and still had the problem.

 

What is your graphics card and driver?

 

Here is what it looks like on my sys:

It looks normal standing up without the bow drawn, just walking around, but has problems with the bow drawn, and when sitting with the bow.

 

bow-drawn.jpg

 

bow-sitting.jpg

You can see the string looks extra thick here.

 

If any of the client devs have any ideas on this, I can easily test patches.

Share this post


Link to post
Share on other sites

The problem goes away with the animation program turned off.

 

 

I'll try that I see the first pic not the second, it only shows here when the bow is drawn I have not seen it any where else.

 

NVIDIA 6800 card. I know it is ancient but normally it has been very very good.

Share this post


Link to post
Share on other sites

On the notepad, if there are more note sections than will fit without scrolling, you will not get the note you were clicking on when you are scrolled down any. If you click the 3rd row of the 1st column (when you look at it) when it is the 5th from the top scroll wise, you will get the 3rd from the top scroll wise. Not sure if I am describing this well enough for people to know what I am saying, but try clicking on something when you have a bunch of notes and the scroll bar is not all the way up to the top.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×