Jump to content
Eternal Lands Official Forums
Entropy

Client patch for Windows and Linux data

Recommended Posts

We have an experimental patch that can dramatically decrease the time needed to load new player textures, so the game will be much faster around storage or map changes.

If you have a modern video card (DX11) it will make little difference, as those cards do not suffer from this particular issue.

This is ONLY FOR PEOPLE WHO CAN COPY, OVERWRITE AND EXTRACT FILES PROPERLY. If you do not know how to do those things, DO NOT INSTALL IT.

 

Here are the instructions for Windows:

Make a copy of the EL folder.

It seems that the web server mime type is wrong, so right click on the link and chose "save as"

Download the file from here: http://www.eternal-lands.com/new_actor_update.rar

Close the game.

Extract it in the EL folder so that you OVERWRITE the existing files.

Launch the game normally (and enjoy).

 

For Linux, download the data file, extract it in the EL directory, get the newest CVS, and compile it with NEW_TEXTURES.

 

If it doesn't work, it is most likely because you did not follow the instructions, so please follow them.

 

If you are 100% sure you followed the instructions, and there are some problems, please post here (preferably with a screenshot of the problem).

 

Also, please post observations regarding to this patch here.

 

Disable Custom Clothing- it will not work

Share this post


Link to post
Share on other sites

Linux: Fedora 12 i686

 

Using the NEW_TEXTURES seems to break custom clothing. I even wiped out the old custom folder. It re-downloaded fine, but I don't see the custom meshes.

 

If I compile without NEW_TEXTURES in an attempt to get custom clothing back, the client segfaults. (Might just be some ifdefs missing.)

Let me know if it's an easy fix, or if it needs further investigation on my end.

 

 

Program received signal SIGSEGV, Segmentation fault.

0x0813b179 in copy_bmp8_to_coordinates (tex=0xbfffc5dc, texture_space=0xa94ff008 "", x_pos=316, y_pos=298) at textures.c:3059

3059 texture_space[(texture_y+x)*4] = texture_mem[texture_offset];

Missing separate debuginfos, use: debuginfo-install glibc-2.11.2-3.i686

(gdb) where

#0 0x0813b179 in copy_bmp8_to_coordinates (tex=0xbfffc5dc, texture_space=0xa94ff008 "", x_pos=316, y_pos=298) at textures.c:3059

#1 0x0813b302 in load_bmp8_to_coordinates (filename=0x16e49c64 "./meshes/torso1_yellow.dds", texture_space=0xa94ff008 "", x_pos=316, y_pos=298, alpha=255 '\377')

at textures.c:3099

#2 0x0813b381 in load_bmp8_to_coordinates_mask2 (filename=0x16e49c64 "./meshes/torso1_yellow.dds", basename=0x16e4a0e4 "./meshes/torso_skinem_tan.dds", maskname=0x16e49d64 "",

texture_space=0xa94ff008 "", x_pos=316, y_pos=298, alpha=255 '\377') at textures.c:3120

#3 0x0813b622 in load_bmp8_enhanced_actor (this_actor=0x16e49a38, a=255 '\377') at textures.c:3180

#4 0x080ef5cb in add_enhanced_actor (this_actor=0x16e49a38, x_pos=116.5, y_pos=197.5, z_pos=0, z_rot=45, scale=1, actor_id=237) at new_actors.c:87

#5 0x080f2491 in add_enhanced_actor_from_server (in_data=0xa9600b43 <incomplete sequence \355>, len=44) at new_actors.c:1018

#6 0x080eccad in process_message_from_server (in_data=0xa9600b40 "3-", data_length=47) at multiplayer.c:575

#7 0x080df2f0 in start_rendering () at main.c:169

#8 0x080df79a in main (argc=1, argv=0xbffff134) at main.c:342

Share this post


Link to post
Share on other sites

Please post no errors or questions about custom clothing in this thread as custom clothing is UNOFFICIAL and these posts are likely to be deleted.

The sizes of some clothes have changed. So you can't use the new data (provided in this thread) with the old client and vice versa. That's why your client crashes if you use the new data files with a client compiled without NEW_TEXTURES.

If you want to test the new client with custom clothing, delete the 'custom' folder and change the server in 'custom_mirrors.lst' to 'advs1.gm.fh-koeln.de' (this is a temporary server for testing the new client).

 

edit:

Disable Custom Clothing- it will not work
Edited by Sir_Odie

Share this post


Link to post
Share on other sites

Works nice on a new Acer latop.

 

On old Compaq EvoN410c, patch causes that both text and graphics get severly blurred.

 

Video card: RADEON 7000 SW TCL x86/SSE

Vendor ID: ATI Technologies Inc.

OpenGL Version: 1.3.4276 WinXP Release

Supported extensions: GL_ARB_multitexture GL_EXT_texture_env_add GL_EXT_compiled_vertex_array GL_S3_s3tc GL_ARB_occlusion_query GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_blend GL_ARB_window_pos GL_ATI_envmap_bumpmap GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATI_vertex_streams GL_ATIX_texture_env_combine3 GL_ATIX_texture_env_route GL_EXT_abgr GL_EXT_bgra GL_EXT_clip_volume_hint GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_wrap GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_HP_occlusion_test GL_NV_texgen_reflection GL_NV_blend_square GL_NV_occlusion_query GL_SGI_color_matrix GL_SGIS_texture_edge_clamp GL_SGIS_texture_border_clamp GL_SGIS_texture_lod GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SUN_multi_draw_arrays GL_WIN_swap_hint WGL_EXT_extensions_string WGL_EXT_swap_control

 

med_gallery_42755_88_47111.jpg

 

 

After restoring minimized EL window, the screen looks as follows:

 

med_gallery_42755_88_38240.jpg

Edited by Cruella

Share this post


Link to post
Share on other sites

On old Compaq EvoN410c, patch causes that both text and graphics get severly blurred.

 

Are you in poor man mode? It will blur in poor man.

Share this post


Link to post
Share on other sites

On old Compaq EvoN410c, patch causes that both text and graphics get severly blurred.

 

Are you in poor man mode? It will blur in poor man.

 

Yes, on this laptop I use poor man mode. I'll try to turn it off tomorrow and see what happens.

Share this post


Link to post
Share on other sites

After restoring minimized EL window, the screen looks as follows:

 

med_gallery_42755_88_38240.jpg

 

By restoring the minimized window, what exactly do you mean?

 

I mean minimizing EL window to the task bar, then restoring it to its original size.

 

Turning Poor Man mode off / on doesn't change anything.

Share this post


Link to post
Share on other sites

just to say incredible change - so much faster to login/load maps and approach busy places like votd. The true test will be in a busy invasion - but soo much faster. Thank you!

 

I use 7zip to process rar files and it failed on this one for some reason - just incase anyone else has this issue - download winrar.

Share this post


Link to post
Share on other sites

agreed, unbelievably nice update (Raz - 7zip under winXP extracted it just fine for me)

 

By any chance could this have made loading map image slower?

the map changing (going indoors/outdoors, going to another map) is a lot faster but opening the map view (TAB key) for the first time on a map then the client hangs for (quit) a while before showing the map. Although seems to load map to memory or something to because the second time viewing the map is instant. But just wanted to know if first time opening went slower than before for anyone else too or is there something i need to work on :)?

 

EDIT:

would gziping my maps help? currently there bmp

Edited by zalic

Share this post


Link to post
Share on other sites

elscreen177.png

Phantom warriors used to be semi transparent before this patch.

 

Yes, some wrong files were included with this update, it will be fixed at the next patch.

Share this post


Link to post
Share on other sites

agreed, unbelievably nice update (Raz - 7zip under winXP extracted it just fine for me)

 

By any chance could this have made loading map image slower?

the map changing (going indoors/outdoors, going to another map) is a lot faster but opening the map view (TAB key) for the first time on a map then the client hangs for (quit) a while before showing the map. Although seems to load map to memory or something to because the second time viewing the map is instant. But just wanted to know if first time opening went slower than before for anyone else too or is there something i need to work on :)?

 

EDIT:

would gziping my maps help? currently there bmp

 

Using dds files with DXT1 compression would help. At the moment, the images are loaded an have to get compressed at load time, so it's slower. Using the dds files with DXT1 compression would make the loading faster.

And thanks to all who like this update. It was some work :)

Edited by Xaphier

Share this post


Link to post
Share on other sites

elscreen177.png

Phantom warriors used to be semi transparent before this patch.

 

Yes, some wrong files were included with this update, it will be fixed at the next patch.

Ok, thank you very much :) I'll make sure to update when next patch is release. Thanks again for the improvements to the game :)

Share this post


Link to post
Share on other sites

OK, first let me say that I really really love how much faster it is. It really worked well during Wizzy's attack at Haidir today (invasion). I only got 1-2 resynce while people around me grued like crazy :D, and i would normally have grued too.

 

However, the client does crash for me sometimes. The only pattern I have noticed is that the client have either been open for ages or the session have been intense, such as invasion/WTF-instance.

 

Error log below (I'll snip it since it's 800+ lines long) for my latest crash is below. I had only resynced like 2-3 times during that session which is a great improvment (despite the crash :P).

 

Log started at 2011-02-23 22:43:16 localtime (Västeuropa, normaltid)

 

[22:43:16] Error: Server profile not found in servers.lst for server: Lands\el.exe". Failover to server: main.

[22:43:16] Using the server profile: main

[22:43:16] Warning: Didn't find your data_dir, using the current directory instead. Please correct this in your el.ini . Given data_dir was: "d:\Eternal Lands". Using "D:\Program\Eternal Lands".

[22:43:16] Window size adjusted to 1018x706

[22:43:17] GL_ARB_multitexture extension found, using it.

[22:43:17] GL_EXT_compiled_vertex_array extension found, using it.

[22:43:17] GL_ARB_point_sprite extension found, using it.

[22:43:17] GL_ARB_texture_compression extension found, using it.

[22:43:17] GL_EXT_texture_compression_s3tc extension found, using it.

[22:43:17] GL_SGIS_generate_mipmap extension found, using it.

[22:43:17] GL_ARB_shadow extension found, using it.

[22:43:17] GL_ARB_vertex_buffer_object extension found, using it.

[22:43:17] GL_EXT_framebuffer_object extension found, using it.

[22:43:17] GL_EXT_draw_range_elements extension found, using it.

[22:43:17] GL_ARB_texture_non_power_of_two extension found, using it.

[22:43:17] GL_ARB_fragment_program extension found, using it.

[22:43:17] GL_ARB_vertex_program extension found, using it.

[22:43:17] GL_ARB_fragment_shader extension found, using it.

[22:43:17] GL_ARB_vertex_shader extension found, using it.

[22:43:17] GL_ARB_shader_objects extension found, using it.

[22:43:17] GL_ARB_shading_language_100 extension found, using it.

[22:43:17] GL_ARB_texture_mirrored_repeat extension found, NOT using it...

[22:43:17] GL_ARB_texture_rectangle extension found, NOT using it...

[22:43:17] GL_EXT_fog_coord extension found, NOT using it...

[22:43:17] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...

[22:43:17] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...

[22:43:28] * server www.eternal-lands.com filename http://www.eternal-lands.com/updates191/files.lst'>http://www.eternal-lands.com/updates191/files.lst'>http://www.eternal-lands.com/updates191/files.lst'>http://www.eternal-lands.com/updates191/files.lst'>http://www.eternal-lands.com/updates191/files.lst'>http://www.eternal-lands.com/updates191/files.lst'>http://www.eternal-lands.com/updates191/files.lst'>http://www.eternal-lands.com/updates191/files.lst'>http://www.eternal-lands.com/updates191/files.lst

[22:43:28] Downloading http://www.eternal-lands.com/updates191/files.lst from www.eternal-lands.com

[22:43:36] Finished downloading http://www.eternal-lands.com/updates191/files.lst

[22:43:37] * server www.eternal-lands.com filename http://www.eternal-lands.com/updates191/files.lst

[22:43:37] Downloading http://www.eternal-lands.com/updates191/files.lst from www.eternal-lands.com

[22:43:38] Finished downloading http://www.eternal-lands.com/updates191/files.lst

[22:43:38] * server www.eternal-lands.com filename http://www.eternal-lands.com/updates191/files.lst

[22:43:38] Downloading http://www.eternal-lands.com/updates191/files.lst from www.eternal-lands.com

[22:43:41] Finished downloading http://www.eternal-lands.com/updates191/files.lst

[22:43:42] Failed to download (files.lst) 3 times. Giving up.

[22:47:39] File '././meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>.

[22:47:39] Unkown error!

[22:48:16] Wrong actor state 4

[23:08:59] File '././meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>.

[23:08:59] Unkown error!

[23:09:22] File '././meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>.

[23:09:22] Unkown error!

[23:09:55] File '././meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>.

[23:09:55] Unkown error!

[23:11:33] Too much commands in the queue for actor 449 (groomsh ZeaL) => skip emotes!

[23:11:33] Unable to add command 61 - 610

 

~ 700 or so lines of Unable to add command xx - yy removed.

 

[23:41:29] load_image() error: [././meshes/shield1_iron.dds] [unsupported image format]

[23:41:29] Can't get image information for '././meshes/shield1_iron.dds'!

[23:41:29] Unkown error!

[23:41:29] load_image() error: [././meshes/medallion05.dds] [unsupported image format]

[23:41:29] Can't get image information for '././meshes/medallion05.dds'!

[23:41:29] Unkown error!

[23:41:29] load_image() error: [././meshes/cape1_orange.dds] [unsupported image format]

[23:41:29] Can't get image information for '././meshes/cape1_orange.dds'!

[23:41:29] Unkown error!

[23:41:31] load_image() error: [././meshes/arms11.dds] [unsupported image format]

[23:41:31] Can't get image information for '././meshes/arms11.dds'!

[23:41:31] Unkown error!

[23:41:31] load_image() error: [././meshes/hair_draegoniblue.dds] [unsupported image format]

[23:41:31] Can't get image information for '././meshes/hair_draegoniblue.dds'!

[23:41:31] Unkown error!

[23:41:31] load_image() error: [././meshes/helmet6.dds] [unsupported image format]

[23:41:31] Can't get image information for '././meshes/helmet6.dds'!

[23:41:31] Unkown error!

[23:41:31] load_image() error: [././meshes/medallion05.dds] [unsupported image format]

[23:41:31] Can't get image information for '././meshes/medallion05.dds'!

[23:41:31] Unkown error!

[23:41:31] load_image() error: [././meshes/cape1_purple.dds] [unsupported image format]

[23:41:31] Can't get image information for '././meshes/cape1_purple.dds'!

[23:41:31] Unkown error!

[23:41:33] load_image() error: [././meshes/pants4.dds] [unsupported image format]

[23:41:33] Can't get image information for '././meshes/pants4.dds'!

[23:41:33] Unkown error!

[23:41:33] load_image() error: [././meshes/boots5.dds] [unsupported image format]

[23:41:33] Can't get image information for '././meshes/boots5.dds'!

[23:41:33] Unkown error!

[23:41:33] load_image() error: [././meshes/torso7.dds] [unsupported image format]

[23:41:33] Can't get image information for '././meshes/torso7.dds'!

[23:41:33] Unkown error!

[23:41:33] load_image() error: [././meshes/arms7.dds] [unsupported image format]

[23:41:33] Can't get image information for '././meshes/arms7.dds'!

[23:41:33] Unkown error!

[23:41:33] load_image() error: [././meshes/head_draegonimred.dds] [unsupported image format]

[23:41:33] Can't get image information for '././meshes/head_draegonimred.dds'!

[23:41:33] Unkown error!

[23:41:34] load_image() error: [././meshes/hair_black.dds] [unsupported image format]

[23:41:34] Can't get image information for '././meshes/hair_black.dds'!

[23:41:34] Unkown error!

[23:41:34] load_image() error: [././meshes/sword6.dds] [unsupported image format]

[23:41:34] Can't get image information for '././meshes/sword6.dds'!

[23:41:34] Unkown error!

[23:41:34] load_image() error: [././meshes/shield1_steel.dds] [unsupported image format]

[23:41:34] Can't get image information for '././meshes/shield1_steel.dds'!

[23:41:34] Unkown error!

[23:41:34] load_image() error: [././meshes/crown1.dds] [unsupported image format]

[23:41:34] Can't get image information for '././meshes/crown1.dds'!

[23:41:34] Unkown error!

[23:41:34] load_image() error: [././meshes/cape1_orange.dds] [unsupported image format]

[23:41:34] Can't get image information for '././meshes/cape1_orange.dds'!

[23:41:34] Unkown error!

[23:41:39] load_image() error: [././meshes/pants3.dds] [unsupported image format]

[23:41:39] Can't get image information for '././meshes/pants3.dds'!

[23:41:39] Unkown error!

[23:41:39] load_image() error: [././meshes/boots4.dds] [unsupported image format]

[23:41:39] Can't get image information for '././meshes/boots4.dds'!

[23:41:39] Unkown error!

[23:41:39] load_image() error: [././meshes/torso12.dds] [unsupported image format]

[23:41:39] Can't get image information for '././meshes/torso12.dds'!

[23:41:39] Unkown error!

[23:41:39] load_image() error: [././meshes/arms12.dds] [unsupported image format]

[23:41:39] Can't get image information for '././meshes/arms12.dds'!

[23:41:39] Unkown error!

[23:41:39] load_image() error: [././meshes/head_gnomempeach.dds] [unsupported image format]

[23:41:39] Can't get image information for '././meshes/head_gnomempeach.dds'!

[23:41:39] Unkown error!

[23:41:39] load_image() error: [././meshes/hair_blondstrawberry.dds] [unsupported image format]

[23:41:39] Can't get image information for '././meshes/hair_blondstrawberry.dds'!

[23:41:39] Unkown error!

[23:41:39] load_image() error: [././meshes/scythe01.dds] [unsupported image format]

[23:41:39] Can't get image information for '././meshes/scythe01.dds'!

[23:41:39] Unkown error!

 

Here it crashed. For the record it was in C2-portal room while it was being invaded, so lots of players and monsters. If it is of any help the client used rhoughly 500-550 Mb of memory at the time but I still had like 500 Mb unused memory.

 

- Little

Share this post


Link to post
Share on other sites

I have just had a crash - and logging back in it immediately crashed.

 

Unfortunately windows does not give any helpful log/debug info - it just crashes the client and nothing helpful written to logs.

 

I have a laptop - video info as below.

 

Video card: Mobile Intel® 4 Series Express Chipset Family

Vendor ID: Intel

OpenGL Version: 2.1.0 - Build 8.15.10.1994

 

Let me know if there is any debug info i can find.

 

I also noticed that the minimap border is overwritten by the map with this patch

Share this post


Link to post
Share on other sites

Of course windows won't tell you anything about it. You must look at the error log generated by the game. You should find it in the settings folder, error_log.txt

Share this post


Link to post
Share on other sites

OK, i thought the client used a bit too much memory so i did a small test, hopefully it is of some help. By jumping in and out of Nordcarn storage (27 times) i got the client to use 400 Mb of memory (started at 200 Mb). Error-log is clean.

 

Using XP

Video card: GeForce 6200/AGP/SSE/3DNOW!

Vendor ID: NVIDIA Corporation

OpenGL Version: 2.1.2

 

-Little

Share this post


Link to post
Share on other sites

The patch is working nicely for me. I was using it during the invasion at haidir yesterday when there were uncountable monsters spawning. There is a noticeable improvement when you approach a crowd and when you enter a map for the first time. One minor thing I did notice that the quick spell icons look a little lost in the hud background now. Other than that, great work. :icon13:

 

Here's a screen shot, old on the left, new on the right:

gallery_14814_12_1598.jpg

Edited by bluap

Share this post


Link to post
Share on other sites

Ok, this is a 2-part bug.

 

Part 1. when you are full, and try to pick a bag with x items, it will repeat that message for x items that you can't carry.

bug1fu.png

 

Part 2. if you drop an item (in my case silver) in the bag, then pick it back up and try to grab the bag again, it does not give an overloaded message and/or does not try to pick the bag.

 

Edit. Part 2 happens if you do part 1 first.

Edited by Forgiven

Share this post


Link to post
Share on other sites

Of course windows won't tell you anything about it. You must look at the error log generated by the game. You should find it in the settings folder, error_log.txt

Sry did not realize it was in the main docs/eternal lands folder - I was looking in the /main subfolder.

 

Log contains..

[20:03:05] File 'C:\Program Files (x86)\Eternal Lands/./meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>.
[20:03:05] Unkown error!
[20:15:53] File 'C:\Program Files (x86)\Eternal Lands/./meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>.
[20:15:53] Unkown error!
[21:22:38] File 'C:\Program Files (x86)\Eternal Lands/./meshes/gloves_fur.dds' has wrong size <64, 64> instead of <156, 144>.
[21:22:38] Unkown error!
[21:40:21] File 'C:\Program Files (x86)\Eternal Lands/./meshes/gloves_fur.dds' has wrong size <64, 64> instead of <156, 144>.
[21:40:21] Unkown error!
[21:40:21] File 'C:\Program Files (x86)\Eternal Lands/./meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>.
[21:40:21] Unkown error!
[21:47:33] File 'C:\Program Files (x86)\Eternal Lands/./meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>.
[21:47:33] Unkown error!

Share this post


Link to post
Share on other sites

One minor thing I did notice that the quick spell icons look a little lost in the hud background now.

same thing with the poison indicator (sry, no screenshot atm)

Share this post


Link to post
Share on other sites

Had the same happen as Raz, a short quote from the error log:

[11:34:10] File '././meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>.

[11:34:10] Unkown error!

[11:42:02] File './3dobjects/tile237' not found!

[11:42:02] Error loading image './3dobjects/tile237'

[11:42:11] File '././meshes/gloves_fur.dds' has wrong size <64, 64> instead of <156, 144>.

[11:42:11] Unkown error!

Share this post


Link to post
Share on other sites

Thanks all for the testing.

Now about all the bugs:

  • The glove-bug (File '././meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>. ) was an old bug and the test client logged it. Is fixed in cvs
  • The bugs bluap (quick spell icons), zalic (poison indicator) and Roja (sky clouds) found is because the way the texture load changed. When all items, clouds etc. are converted to dds, it should look like before
  • The client had some old threading problems (race conditions that could produce buffer overruns). I hope I fix them, so there should be no crash under high system load now (cvs).
  • The crash Raz had should be fixed now (cvs). Sir_Odie had it too and helped a lot finding the problem. Thanks again.
  • The crash littlestar is something I was not able to locate, perhaps it was a combination of the other problems, so it could be fixed now in (cvs).

The increased memory usage littlestar mentioned is something to look at. I am not sure if it's a bug in the client. The cache increase memory usage of course. Does the Small actor texture cache option under Adv options affect this? What happens if you change the value for poor man when the memory usage is so high? Changing poor man should clear the actor texture cache.

 

The item problem Forgiven found is something I have to check, but thanks for reporting.

Share this post


Link to post
Share on other sites

Thanks all for the testing.

Now about all the bugs:

  • The glove-bug (File '././meshes/gloves_leather.dds' has wrong size <64, 64> instead of <156, 144>. ) was an old bug and the test client logged it. Is fixed in cvs
  • The bugs bluap (quick spell icons), zalic (poison indicator) and Roja (sky clouds) found is because the way the texture load changed. When all items, clouds etc. are converted to dds, it should look like before
  • The client had some old threading problems (race conditions that could produce buffer overruns). I hope I fix them, so there should be no crash under high system load now (cvs).
  • The crash Raz had should be fixed now (cvs). Sir_Odie had it too and helped a lot finding the problem. Thanks again.
  • The crash littlestar is something I was not able to locate, perhaps it was a combination of the other problems, so it could be fixed now in (cvs).

The increased memory usage littlestar mentioned is something to look at. I am not sure if it's a bug in the client. The cache increase memory usage of course. Does the Small actor texture cache option under Adv options affect this? What happens if you change the value for poor man when the memory usage is so high? Changing poor man should clear the actor texture cache.

 

The item problem Forgiven found is something I have to check, but thanks for reporting.

Great news and many thanks for all the work

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×