Jump to content


Photo

openSUSE 13.2 no sound


4 replies to this topic

#1 Gogalthorp

Gogalthorp

    White Rabbit

  • Members
  • 39 posts

Posted 06 May 2015 - 10:00 PM

New client has no sound throws error at start

 

Error Initializing sound: ALC_INVALID_DEVICE

 

Installed both music and sound from the website

 

This machine is running with Pulse Audio. Had no problem with previous version

 

 

Also have not yet figure the trick to use the eternalland.sh no mater what el.init file I find and modify to point to the new install directory no go. It looks like ths shell does not do all that much but it does scan the ~/.elc/main/el.ini file for the eternalland string and if not found  it chokes with the error message.

 

But all my personal stuff is still in ~/.elc

 

In any case I can't see anything in the shell kick starter to cause a problem with the sound???

 

Any thaughts?

 

 

 

 



#2 Gogalthorp

Gogalthorp

    White Rabbit

  • Members
  • 39 posts

Posted 06 May 2015 - 10:29 PM

Fixed it was the pathe need full path not ~/



#3 bluap

bluap

    Feran

  • Moderators
  • 2219 posts
  • Gender:Male
  • Location:UK

Posted 06 May 2015 - 10:55 PM

Now you have the path fixed, does the sound work if you run using the eternalland.sh?  If not, trying installing the pulseaudio-utils or suse equivalent package.  This will install padsp which if put before the client executable name on the command line will help with sound compatibility.  The script tries to do this



#4 Burn

Burn

    Goblin

  • Members
  • 958 posts
  • Gender:Male

Posted 07 May 2015 - 04:13 AM

Just noting: I'll be updating OpenSUSE RPMs to 1.9.4 as soon as the server update happens. Sound/Music packages are included. Maybe those will work better for you.

 

Sound seems to "just work" for me on them, though I actually had to just check since I never use it. (Disturbs my 80's hair metal...)

 

See my sig for installing those.



#5 Burn

Burn

    Goblin

  • Members
  • 958 posts
  • Gender:Male

Posted 08 May 2015 - 07:05 AM

I went ahead and updated the repo to 1.9.4 since we should be hopefully seeing the server update today.

 

Give my RPMs a try and see if they do any better.

 

Try with a clean install though. (Easiest way is to just rename your ~/.elc/ directory to ~/.elcOLD/ or such, then move the files back properly after you determine the working status of the client.) That'll guarantee avoiding any settings you have trying to access old data on your system.





Reply to this topic



  


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users