Jump to content
Eternal Lands Official Forums

Game data can't be downloaded

Recommended Posts

I tried to  install the game under linux mint 18.3.

All the packages have been installed but one, the game data package.

The twinmoon server is not responding following the download request.

It is either down or the address is wrong.(connection timed out on 10 consecutive attempts)

No idea what to do, other then removing the package, because i can't install/remove anything else.

Share this post

Link to post
Share on other sites

Did you try the official binary download for linux? (See instructions on the Eternal Lands downloads page)
As far as I know, this is a static build, and includes all the current datafiles.

From the various threads about compiling the client, it looks like this is the recommended first step, even if you
ant to (or have to) build the final client from sources. Once you have the new client compiled, you can replace
the provided binary with your own

Share this post

Link to post
Share on other sites

The twinmoons.org.uk server is mine, I was not aware that it had been unavailable but its certainly OK now.

If you do want to remove the packages, just use sudo apt purge <package name>.

It the data package installed but the data zip file failed, you can --reinstall or reconfigure the package.

Edited by bluap

Share this post

Link to post
Share on other sites

Thank you both for your answers.

It looked that the problem might have been from the network config GUI for pppoe internet connection.

(Not entirely sure about that, but setting it in terminal fixed the connection)

Reconfiguring the package worked but in the end I did a whole fresh game install.

(I could access the debian branch in browser but not the ubuntu this is why i asked if the server might have been down, and most likely wasn't)

Thank you very much once again and sorry for causing so much trouble for such a small unrelated problem.

Share this post

Link to post
Share on other sites

The Ubuntu packages are built and stored on the launchpad servers in my PPA, but the data package downloads the actual data ZIP file from my twinmoons server. I build the Debian packages on my own (Virtual) machines and host the package repository on my twinmoons server.  Again the data ZIP file is downloaded by the package from the twinmoons server.

Glad you resolved the problem.

Share this post

Link to post
Share on other sites
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.