Jump to content
Eternal Lands Official Forums
Mazur

Options Creatures/Other Players Health bars in el.ini?

Recommended Posts

Hello,

 

I prefer to have the options Creatures Health Bars and Other Players Health Bars on (they are under the HUD tab), so I've been trying to find how to include that into my el.ini. Following the pattern of other options, I found something that looked like those options already in el.ini and defined that in mine, (thought I've forgotten which they were and can't seem to find them again), but they were never saved by the client.

 

So the question is: is there a way to set those options default to on, without rewriting part of the client? If not, who do I have to pleasure to get these options included in el.ini?

 

Yours truly,

Mazur.

Share this post


Link to post
Share on other sites

Normally, such settings are persistent (i.e. kept as you set them between runs), just not stored in the el.ini file. There's also a (binary) file el.cfg, which probably holds such information (and that one is not supposed to be edited by hand!)

 

So you just select the options in the dialog as you want them, and you should be all set, no need to modify the client.

Share this post


Link to post
Share on other sites

Ah, then perhaps my client fails to save that file, and removing the current version will fix it. I'll see if that helps.

Share this post


Link to post
Share on other sites

If the client is failing to save the settings then there is something wrong on exit. We should try to fine out what but until then, you can save your setting using the #save command within the client.

Share this post


Link to post
Share on other sites

#save does not change the failure, though it does appear to write the files, or pretends to.

 

Next test is starting without the pertinent file, logging in and setting all options right, then #save. May take me a while to try it, as I'm quite busy (in game).

Share this post


Link to post
Share on other sites

If #save does not save then you have something fundamental wrong. Check the error log for information. Check the permissions on your config directories and files. I do not know for sure which OS you are using but on Linux, the files are $HOME/.elc/main/el.ini and $HOME/.elc/main/el.cfg

Edited by bluap

Share this post


Link to post
Share on other sites

#save does write $HOME/.elc/[server]/el.cfg , and other options I change keep the changed state, but those two health bar ones are not permanent, not saved, apparently.

Share this post


Link to post
Share on other sites

OK, I must apologise. There does appear to be a problem with just two of the instance mode optons. I'll hunt the problem down and fix it.

 

Edit:

OK fixed in git. The config code was doing a partial compare of the variable names, the two ending in _bar matched shorter versions and so appeared to not need saving.

Edited by bluap

Share this post


Link to post
Share on other sites

No apology necessary on my account, I never gave full information for you to act on until you asked. :whistle:

Anyway, glad you found and fixed it. :pirate:

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×