Jump to content
Eternal Lands Official Forums
littlebro2

Error: "failed to load external entity"

Recommended Posts

I have checked out the elc module and run "make".

 

The make completes successfully, however when I run the game I get:

 

./el.x86.linux.bin

 

I/O warning : failed to load external entity "mines.xml"

I/O warning : failed to load external entity "/emotes.xml"

I/O warning : failed to load external entity "./weather.xml"

I/O warning : failed to load external entity "knowledge.xml"

Segmentation fault

 

Anyone else have this problem? What am I missing?

 

I am running an older version of Fedora. It appears I can't use the default build of the linux client as I have an older version of glibc.

 

Thanks.

Share this post


Link to post
Share on other sites

Make sure the "#date_dir" line in your configuration file ~/.elc/main/el.ini" points to where you installed the data. You may also get it to work if you change to the directory to where you installed the data and run your built version of the client form there.

Share this post


Link to post
Share on other sites
Make sure the "#date_dir" line in your configuration file ~/.elc/main/el.ini" points to where you installed the data. You may also get it to work if you change to the directory to where you installed the data and run your built version of the client form there.

 

#datA_dir perhaps?

Share this post


Link to post
Share on other sites
Make sure the "#date_dir" line in your configuration file ~/.elc/main/el.ini" points to where you installed the data.

 

It's #data_dir, not #date_dir :o

 

Piper

Share this post


Link to post
Share on other sites

I don't have the date_dir in the el.ini file...

 

However, I got it to work based on your suggestion about where to execute the .bin file.

 

I moved the built executable back into the el_linux directory and replaced the existing and executed it from there.

 

Wahoo! Thanks for your help!

Share this post


Link to post
Share on other sites
It's #data_dir, not #date_dir :)

OK, yep, sorry. :o

 

I moved the built executable back into the el_linux directory and replaced the existing and executed it from there.

Wahoo! Thanks for your help!

Great. Have fun!

Share this post


Link to post
Share on other sites
Guest Gwinny

I have the same problem now and grow more and more desperared now.

 

i get these messages:

I/O warning : failed to load external entity "languages/en/strings/console.xml"

I/O warning : failed to load external entity "languages/en/strings/console.xml"

I/O warning : failed to load external entity "languages/en/strings/errors.xml"

I/O warning : failed to load external entity "languages/en/strings/errors.xml"

I/O warning : failed to load external entity "languages/en/strings/help.xml"

I/O warning : failed to load external entity "languages/en/strings/help.xml"

I/O warning : failed to load external entity "languages/en/strings/options.xml"

I/O warning : failed to load external entity "languages/en/strings/options.xml"

I/O warning : failed to load external entity "languages/en/strings/spells.xml"

I/O warning : failed to load external entity "languages/en/strings/spells.xml"

I/O warning : failed to load external entity "languages/en/strings/stats.xml"

I/O warning : failed to load external entity "languages/en/strings/stats.xml"

I/O warning : failed to load external entity "languages/en/strings/titles.xml"

I/O warning : failed to load external entity "languages/en/strings/titles.xml"

I/O warning : failed to load external entity "/my/games/el//actor_defs/actor_defs.xml"

el.x86.linux.bin io/cal3d_io_wrapper.cpp:224: int CalCoreModel_ELLoadCoreAnimation(CalCoreModel*, const char*. float): Assertion `self' failed.

canceled

 

 

i have 2 el.ini files. one in /.elc/main and one in /el_linux (where i unpacked the download zip). Which one must be edited? and is

#data_dir = „/home/ann/el_linux“ correct?

 

 

for more infos:

unanme -a:

Linux idefix 3.2.0-2-686-pae #1 SMP Mon Jun 11 18:27:04 UTC 2012 i686 GNU/Linux

lspci | grep -i vga:

00:02 VGA compatible controller: Intel Corparation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)

 

 

pls help me

Share this post


Link to post
Share on other sites

Change the one in ~/.elc/main/el.ini to

 

#data_dir = "/home/ann/el_linux"

 

assuming that is where el is installed.

 

Also try:

cd /home/ann/el_linux

./el.x86.linux.bin

in a terminal. I get better results running el from the directory where it is installed.

 

 

Edit: If you compiled your own el.x86.linux.bin, make sure to install it in /home/ann/el_linux/ too

(install -m755 el.x86.linux.bin /home/ann/el_linux/el.x86.linux.bin)

Edited by hussam

Share this post


Link to post
Share on other sites
Guest Gwinny

Changing it in ~/.elc/main is not working =(

 

i allways execute it in a terminal (know no other way tbh)

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×