Jump to content
Eternal Lands Official Forums
Aerowind

LInux

Recommended Posts

Okay I'm not EXACTLY sure where to put this but crusadingknight told me I need to install and/or compile DRI's Leeloo defined DRI's but neither one of them has told me how to compile and/or install them.

 

Can someone tell me how to do this or get me a version of Windows 2000 or XP for free??

Share this post


Link to post
Share on other sites
Okay I'm not EXACTLY sure where to put this but crusadingknight told me I need to install and/or compile DRI's Leeloo defined DRI's but neither one of them has told me how to compile and/or install them.

 

Can someone tell me how to do this or get me a version of Windows 2000 or XP for free??

Can you explain a little bit more, what do you wanna do?

 

Install Linux, compile DRI's (whatever this is), install Windoze?

 

You are using which OS, working with which brand of computer, where are you stuck?

 

Piper

Share this post


Link to post
Share on other sites

Blah...

 

I am using Linux Red Hat v. 9.0

 

I can run Eternal Lands but it is slow as hell. So crusadingknight told me to install DRI's if I don't have them and then compile them and if I do have them compile them. But he never told me how.

 

So I am wanting someone to finish what crusadingknight is telling me to do, OR have someone get me a free copy of Windows XP

Share this post


Link to post
Share on other sites
Blah...

 

I am using Linux Red Hat v. 9.0

 

I can run Eternal Lands but it is slow as hell.  So crusadingknight told me to install DRI's if I don't have them and then compile them and if I do have them compile them.  But he never told me how.

 

So I am wanting someone to finish what crusadingknight is telling me to do, OR have someone get me a free copy of Windows XP

Ugh,

 

i dont know RedHat, but for SuSE, when the client runs with exactly 0 fps, the problem was that 3d support was not enabled for the graphics adapter or the graphics adapter was not detected correctly.

 

If RedHat has something like a "control panel" or "system management", try to find out which kind of graphics adapter RedHat has detected.

 

Something like "Standard VGA" or so means, RedHat hasnt detected your graphics adapter and uses the slowest driver it knows. And that means NO 3D SUPPORT!

 

And 3d support is needed to play EL.

 

Piper

 

P.S.: Some RedHat user here who can help?

Edited by The_Piper

Share this post


Link to post
Share on other sites

I can tell you what video card I have but I can't find find my Graphics Adapter

Share this post


Link to post
Share on other sites
what does chmod to 775  mean ?    any hel p  using mandrake for the first time.

                ---------------------

chmod 775 changes the access rights of a file to:

 

7 = the owner of that file can read/write/execute it

7 = the group of that file can read/write/execute it

5 = all others can read/execute it

 

Piper

Share this post


Link to post
Share on other sites
I can tell you what video card I have but I can't find find my Graphics Adapter

Thats the same.

 

What you need is a RedHat user, i dont know how to configure video cards and switch on 3D support under RedHat.

 

But thats definetely your problem, the system doesnt detect your video card properly, or it does, but 3D support is turned off.

 

Maybe you can ask the guy who gave you those CD's if no RedHat user answers here?

 

Piper

Share this post


Link to post
Share on other sites

Yeah that's the problem.

 

There is a grayed out text that says Enable Hardware 3D Acceleration. And I can't enable it

 

But I don't think it's that... well I don't know I can see things just can't interact with them.

Share this post


Link to post
Share on other sites
Guest marko92

changed mode and executed the bin but all i get is a empty page thta opened with konqueror ... ty for help on the 775 mode but still not doing something right need help plz...

Share this post


Link to post
Share on other sites
changed mode and executed the bin but all i get is a empty page thta opened with konqueror ... ty for help on the 775 mode but still not doing something right need help plz...

erm, are you asking how to start the game under Linux?

 

Thats why you asked for chmod 777?

 

If you get an empty screen, press ENTER or click on it.

 

But normally i would expect that you see a green message too...

 

Piper

Share this post


Link to post
Share on other sites
Yeah that's the problem.

 

There is a grayed out text that says Enable Hardware 3D Acceleration.  And I can't enable it

 

But I don't think it's that... well I don't know I can see things just can't interact with them.

Listen. If you have the DRI source, just do the following:

user@localhost:home/#> cd dir_of_DRI_source
user@localhost:dir_of_DRI_source/#> ./configure --prefix=/usr/local
user@localhost:dir_of_DRI_source/#> su
Enter password: (type root password here)
root@localhost:dir_of_DRI_source/#> make && make install
root@localhost:dir_of_DRI_source/#> exit

 

 

Once that has finished, you should edit /etc/X11/Xorg.conf and look for anything that resembles your graphics section, and look for:

 

#> vi /etc/X11/Xorg.conf

 

LOAD "DRI" (or something similar)

Share this post


Link to post
Share on other sites

DRI is usually included with X, and AFAIR the DRI FAQ says "get the version that comes with X" or something like that to the question about compiling it yourself.

Share this post


Link to post
Share on other sites

Please send us the output of

lspci | grep VGA

or the exact chipset name of your video card. Some video cards do not have DRI support in X11 yet, some only have support in current CVS head. Please check out the DRI wiki for supported chipsets and the DRI Building guide for information on how to build X.org if X11 in your distribution is too outdated. If so, try a distribution update first. AFAIK Red Hat Linux is now obsoleted by Fedora Core.

 

Sincerely yours

Lachesis

Edited by Lachesis

Share this post


Link to post
Share on other sites

Video Card Type: RIVA TNT2

 

Memory Size: 32 megabytes

 

Driver: nv

 

 

and how do I know if I have the DRI source??

Share this post


Link to post
Share on other sites
Video Card Type: RIVA TNT2

Memory Size: 32 megabytes

Driver: nv

and how do I know if I have the DRI source??

You obviously dont.

 

Try visiting nvidia.com and downloading the relevant driver for your card. Install and run as explained in the given readme/help files.

Share this post


Link to post
Share on other sites

Ya I bet you I need to update my drivers I don't know the last time we've done that (like never since we got the video card (3 years ago))

 

Edit: Which Linux would I select

 

Linux IA32

Linux AMD64

or Linux IA64

 

Also plz try and have this all figured out by today (2morrow I say bye bye to cable modem and hello to Netzero High Speed (unless someone can find something faster for me that's only $15 a month)

Edited by Aerowind

Share this post


Link to post
Share on other sites
Ya I bet you I need to update my drivers I don't know the last time we've done that (like never since we got the video card (3 years ago))

I'd give that a good try before compiling DRI and messing around with Xorg. THAT, my friend, is a whole different ball-game.

Share this post


Link to post
Share on other sites

Don't believe I am

 

Okay I have the driver downloaded now what?

 

Edit: Nevermind this post

Edited by Aerowind

Share this post


Link to post
Share on other sites
Don't believe I am

 

Okay I have the driver downloaded now what?

Ok, do you remember where you downloaded it to? I hope so :)

 

Open a Konsole (from the KMenu [same position as the Windows start button]).

 

Type:

user@localhost#> su
Enter password: (root password here)
root@localhost#> telinit 3

 

Your computer will now boot down to a console, there will be no graphical screen from this point. DO NOT WORRY! :)

 

Now, you will need to login with your regular login, so enter the credentials.

Once logged in, do the following.

root@localhost#> su
Enter password: (root password here)
root@localhost#> ./nameOfInstallationFile (thats a fullstop, then a forwardslash, followed by the filename)

 

Follow the on-screen instructions.

Once its finished, you should type:

root@localhost#> telinit 0

Then start the machine up again.

Good luck.

Edited by Placid

Share this post


Link to post
Share on other sites

Yeargh...

 

In the terminal it won't let me enter the root password

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×