Jump to content


Photo

Hang up


4 replies to this topic

#1 Elke

Elke

    Racoon

  • Members
  • 180 posts
  • Gender:Female
  • Location:Germany

Posted 24 May 2012 - 09:09 AM

It often happens that my EL client hangs up mid-game (and only kill -9 will terminate it) where I can't exactly pin-point any ingame related reason.

I attached gdb to the running process and obtained the backtrace as below. It looks that the hang-up is here also somewhere in the sound modules - place where I also get frequently crashes (with frequently I mean that I usually experience at least one of these events per day). Two crash logs found at http://devs.openttd....es/el-crash.log and http://devs.openttd....s/el-crash2.log

Reading symbols for shared libraries .++++++++++++++++++++................................................................................................. done
0x9a5c5b42 in semaphore_wait_signal_trap ()
(gdb) bt
#0  0x9a5c5b42 in semaphore_wait_signal_trap ()
#1  0x9a5cb646 in pthread_mutex_lock ()
#2  0x01996ddc in SDL_mutexP ()
#3  0x00123cef in add_sound_object_gain ()
#4  0x001242fa in handle_walking_sound ()
#5  0x0002e153 in cal_actor_set_anim ()
#6  0x00013ffd in next_command ()
#7  0x000de344 in start_rendering ()
#8  0x000de83d in SDL_main ()
#9  0x000039e8 in -[SDLMain applicationDidFinishLaunching:] ()
#10 0x9358be5c in _nsnote_callback ()
#11 0x9013c763 in __CFXNotificationPost ()
#12 0x9013c16a in _CFXNotificationPostNotification ()
#13 0x93580c50 in -[NSNotificationCenter postNotificationName:object:userInfo:] ()
#14 0x9358e05d in -[NSNotificationCenter postNotificationName:object:] ()
#15 0x9555e216 in -[NSApplication _postDidFinishNotification] ()
#16 0x9555e126 in -[NSApplication _sendFinishLaunchingNotification] ()
#17 0x956b5339 in -[NSApplication(NSAppleEventHandling) _handleAEOpen:] ()
#18 0x956b4f59 in -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] ()
#19 0x935c11f8 in -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] ()
#20 0x935c0fbc in _NSAppleEventManagerGenericHandler ()
#21 0x9186af5c in aeDispatchAppleEvent ()
#22 0x9186ae5b in dispatchEventAndSendReply ()
#23 0x9186ad65 in aeProcessAppleEvent ()
#24 0x93a60197 in AEProcessAppleEvent ()
#25 0x9552e7d2 in _DPSNextEvent ()
#26 0x9552ddd6 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] ()
#27 0x954f01f3 in -[NSApplication run] ()
#28 0x0000397c in CustomApplicationMain ()
#29 0x00003be0 in main ()
#30 0x00002e42 in _start ()
#31 0x00002d69 in start ()


#2 Sir_Odie

Sir_Odie

    Brownie

  • Moderators
  • 246 posts
  • Gender:Male

Posted 24 May 2012 - 09:30 AM

Apparently all crashes are in the Apple sound system, so it's hard to track that down to a specific part of EL but maybe an EL sound developer can look into it, though i doubt it is a general EL problem. Hopefully there will be an update from Apple soon; until then, disable sound should avoid these crashes.

Edited by Sir_Odie, 24 May 2012 - 09:35 AM.


#3 Sulla

Sulla

    Rat

  • Members
  • 54 posts
  • Gender:Male

Posted 25 May 2012 - 12:34 PM

Which version of the OS are you running? I'm on LION and have no problems with sound on or off. To be honest I've had sound off for a good while but turned it on to test when I saw this post. No issues at all. Any info you can give us on software/hardware may help at least narrow it down.

EDIT: Also is this a new issue? Or are you a new to game and having these issues?

Edited by Sulla, 25 May 2012 - 12:35 PM.


#4 Elke

Elke

    Racoon

  • Members
  • 180 posts
  • Gender:Female
  • Location:Germany

Posted 26 May 2012 - 10:15 AM

Which version of the OS are you running?

EDIT: Also is this a new issue? Or are you a new to game and having these issues?

I'm running OSX 10.6.8 (SnowLeopard) on a macbook, model MacBook2,1. Thus the default onboard sound hardware is in use. I play the game since about January and the issue is present ever since; I can't judge the time before that.
Anyhow, the issue only appears with EL, other programmes don't quite have this issue like for video or audio playback or streaming nor do I see that when I play other games (mostly OpenTTD). Still, it may be some issue with the audio drivers per se as sometimes it has issues with video streaming; but it still doesn't crash the browser (FF) then but just leads to somewhat scrambled output.

#5 revi

revi

    Skeleton

  • Moderators
  • 1034 posts
  • Gender:Not Telling

Posted 26 May 2012 - 10:57 AM

Looks like it's an error in the threading code :
semaphore_wait_signal_trap ()
in pthread_mutex_lock ()
in SDL_mutexP ()
and the problem occurs while in the SDL library, so I'm not sure El developers can do anything about it. Most likely a problem in either SDL or below,
in the Apple system software (and not necessarily the hardware driver either :/). For the time being, the only solution I see is disabling sound
(and music) completely in EL (in game: options->audio->'disable sound and music system')

In more detail: it looks like the program hangs while trying to get exclusive acces to the sound system (SDL_mutexP and calls from there), while
something else holds on to the sound system ->
EL never gets the lock, and there seems to be no time-out provided -> hang
(NOTE: this is not a crash, EL keeps on running happily ever after, it just can't do anything; that should make for one happy grue ;) )



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users