Jump to content
Eternal Lands Official Forums
Sign in to follow this  
oldnight

disconnected from server?

Recommended Posts

right when i start the game it loads the program, but it says disconnected from the server. i can't figure out what is causing this.

i have disabled my firewall, and aloud port 2000 for eternal lands to not be blocked, even my router settings, i can't figure this out. could i please have some help with this reoccuring problem.

Share this post


Link to post
Share on other sites

Do you have any firewall software installed that may need "opening up"? XP will not stop any connections to external ports, but if you have a 3rd party firewall (e.g. Comodo, Zonealarm, Nortons patented "BlockEverything 360" etc.) it may need attention.

 

From a command window ("Start", "Run", type cmd and press <Enter>), type "ping game.eternal-lands.com"

 

If that works, then the server is accessible, but perhaps your port 2000 is being blocked by something. The trick is to track down that "something".

 

 

Edited a stupid typo ;^)

Edited by stewbaby

Share this post


Link to post
Share on other sites

i have done this but i do not quiet understand, it all here is what it shows me when i type it in.

 

reply from (server address) bytes=32 time 220ms TTl=55

packets: sent = 4, recieved = 3 lost = 1 25% loss

 

approximate round trip times in milli-seconds:

minimum=193ms maximum=246ms average=219ms

 

the test server works, but the main will not

Edited by oldnight

Share this post


Link to post
Share on other sites

This means that something on your end is blocking the game server at port 2000. The test server uses port 2001.

You can try and find out if this is something on your computer (local firewall) or something your service provider does (then you would not be able to play the game from any computer from your home). You can see if anyone you knows uses the same company for internet and if they can play the game.

If it is something on your own computer or network in your house (router blocking the port), then only you can turn it off. If it is your service provider, then you can try the proxy server Learner provides (for a fee) or try to convince your service provider to stop blocking port 2000.

Good luck.

Edited by Maxine

Share this post


Link to post
Share on other sites

i would suggest using telnet instead of ping in order to check that you can contact the server, from the command line in xp type:

 

telnet game.eternal-lands.com 2000

 

if you see the welcome message, you can communicate on port 2000.

 

I notice that you lost a packet doing the ping, you might want to try pinging other hosts to see if the same thing happens.

If packets are being lost, it could be an issue with your router, or possibly an issue with your dsl line (i'm assuming you're on dsl).

Share this post


Link to post
Share on other sites
blank cmd promt when it is typed in, ah well ill try contacting my service provider i supose =P

It could be AntiVirus, firewall, or ISP.

 

If you can't figure it out, one option is my proxy service since that puts EL on 443 instead of 2000. $5/mth or $30/yr for up to 5 chars from you and your family.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×