Jump to content
Eternal Lands Official Forums
snoops

Can't see console text...again

Recommended Posts

OK, i'm having this issue again:
http://www.eternal-lands.com/forum/index.php?showtopic=46756
Exactly the same problem, only this time it's on my eeepc-1025c running meego.
This time at least I sort of know why, and it's 100% reproducible

I added wins to this line in /etc/nsswitch.conf

hosts: files mdns4_minimal [NOTFOUND=return] wins dns

for hostname resolution on my LAN.

Then I go to play EL, and i'm missing text from the console.
Strange...so I remove the wins entry from nsswitch.conf, start up EL, and all is right again.

So basically the problem is, if I have this entry in my conf, then EL won't display certain text on the console, and wont log said text to the chat log.

Any ideas?

Share this post


Link to post
Share on other sites

Well, after playing around for a bit, it seems I had the order wrong

 

I changed this

hosts: files mdns4_minimal [NOTFOUND=return] wins dns

to this

hosts: files mdns4_minimal [NOTFOUND=return] dns wins

 

and everything works again. :D

 

Although I never touched the nsswitch.conf file 8 years ago when this originally ocurred...

 

Still, it's got me baffled why some things came through, and others didn't

 

Edit: Seems I spoke too soon

Problem still exists, but now only intermittently

More playing around is in order

Edited by snoops

Share this post


Link to post
Share on other sites

Weird. Looks like you see all text generated internally by the client such as the #know output and AFK changes, but only some messages from the server. Are all the sever messages you see the same colour in the console? Or are all server messages of a certain colour all missing? The fact that you see gaps in the console where text should be means you are getting messages, probably of the correct length. Do things like emotes work, does the harvest eye candy effect start even though you do not see the start harvesting console message? Could something on your network be messing with some of your network packets, perhaps interpreting some byte sequences hence the dependency on message colour. Consider what other network changes you made just before the issues started again.

 

Edit: Can you compile your own client to add some debug?

Edited by bluap

Share this post


Link to post
Share on other sites

So after editing the nsswitch.conf line to
hosts: files dns wins [NOTFOUND=continue]
the client is working correctly so far (for the last 2 days)

But in case you are still interested:

-The only network changes I made: adding a network printer using CUPS web interface, and editing /etc/nsswitch.conf
-Still happens with all other machines turned off, just me connected to the router.
-The gaps in the text seem to be only one line for each message
eg: #arm will output 1 blank line instead of about 20 lines
-Emotes work
-The harvest eye candy effect starts, just no start harvesting message
-Storage window->print items to console will output category name, item count, but no item name. When client is working, these last two fields appear to be the same colour. I am as yet unsure about the colour correlation

I am running the client compiled from git 01-07-2016
I tried gdb, but all I get is:
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.
My meego is broken, I am wary of trying to fix it, in case I break it beyond repair. I am yet to find another linux distro that plays nicely with my eeepc 1025c graphics (although I haven't looked for a little while).

Share this post


Link to post
Share on other sites

Well, the fact that things like the harvesting effect still starts even when you don't see the text means you are receiving the correct message text in the client. I have no idea how this could happen. Hmm.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×