Jump to content
Eternal Lands Official Forums

EL Lagging on Mint 17.1

Recommended Posts

Hey. :)

I was wondering if someone has any idea why EL would lag on Mint when it does not lag on Windows on the same PC and when nothing else on the Linux installation seems to be having a problem with the graphic card (an old Radeon).

I've tried using the windows version through Wine and (for the hell of it) I tried the (Mint) Test Server also - the result is always the same.


Share this post

Link to post
Share on other sites

I have noticed the lagged in Playonlinux - wine - with 1.94

I have used wine as syncing the linux ver and the windows version problematic..


EL 1.93 ran very well using wine...actually better than windows... not so with 1.94..

Havent tried 1.94 linux.. Having problems setting data directory... I use PCLinuxOS..


EL 1.94 says data directory invalid... although I changed el.ini... no problems with 1.93...

Share this post

Link to post
Share on other sites

Check your graphics drivers. On Linux Mint you are probably using the open source driver, there is a proprietary driver but it is not well supported. You can check which you are using from the "software & updates" tool, additional drivers tab (assuming you are using a Ubuntu Mint version). You can change the driver from there too. Be warned though, on my laptop running Ubuntu 15.10 dev release the latest AMD proprietary driver does not work.

There should be no performance difference between 1.93 and 1.9.4. IMHO, using wine on Linux for EL is the worst of all solutions. The released Linux binary should run fine though it was build for wide compatibility. However, it is relatively easy to build your own version from source too. Using purpose built packages for you system, (Suse, Ununtu/Mint, Debian packages are available) or building your own release version on your machine will give the best solution.

There is definitely no difference between 1.93 and 1.9.4 in the way the client handles the data_dir path. Check you are checking the correct el.ini file, its the one in $HOME/.elc/main assuming you are using the default from the servers list.

Share this post

Link to post
Share on other sites

Well, if it's a driver issue then I'm $#%$#%#...

Drivers were probably the first thing I checked. The system is running the open source ones and I soon read somewhere there would be no way of getting the proprietary ones to work. Old card, old drivers, new X.org (or whatever), seems to be the problem. Even "hacks" that still worked in 2010 no longer do (I think because the LTS ubuntu at the time was only supported until 2011).


I had been hoping the prob might be something else. :cry:



Anyway, thanks.

Share this post

Link to post
Share on other sites
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.