Jump to content
Eternal Lands Official Forums
Sign in to follow this  
Andysoldier

Sound Issue

Recommended Posts

Hi all, i've been playing the game for a couple of days on Ubuntu 10.10 - love it! Downloaded the sound and unzipped it into a folder called "sound".

 

Changed the settings in-game to enable sound and changed the el.ini file to read "sounds" - 1 but still no sound.

 

When i execute the bin file to start the game using a terminal the game starts but 1 line in terminal says "open /dev/[sound/]dsp: No such file or directory"

 

In the options, in-game under audio the sound device is empty (on another thread someone said this doesn't matter).

 

Any help is much appreciated.

Share this post


Link to post
Share on other sites

Hi all, i've been playing the game for a couple of days on Ubuntu 10.10 - love it! Downloaded the sound and unzipped it into a folder called "sound".

 

Changed the settings in-game to enable sound and changed the el.ini file to read "sounds" - 1 but still no sound.

 

First of all, make sure you have unzipped the file in the right location - it should be in the game INSTALL dir (not the logs/settings dir), in other words you should have a folder "sound" in the same directory as other folders "2dobjects", "3dobjects" ... "textures". And, "sound" should contain directly the various .ogg files, not another subdirectory. Once this is checked, ...

 

When i execute the bin file to start the game using a terminal the game starts but 1 line in terminal says "open /dev/[sound/]dsp: No such file or directory"

 

In the options, in-game under audio the sound device is empty (on another thread someone said this doesn't matter).

 

Any help is much appreciated.

This might be a problem with your audio subsystem. Traditionally, under Linux (and other Unices) you can just output audio data to /dev/dsp and have it played for you; however opening the audio device also locks it, so only one process at a time can access the audio. This has been solved in two ways: by providing a master daemon to mix audio from multiple sources (as in esd or alsa), or by offering a different kernel-level interface (as in oss). It is hard for me to tell what you have on your machine, since I am not on Ubuntu.

 

However, you can look for some compatibility layer. This could come either as a system-setting, or can be forced on the command-line. For example, running

aoss eternal-lands

ensures that eternal-lands is executed in an environment where the alsa-oss compatibility layer is activated. Another option is of course to see if you have another program locking the audio device and kill it, but this might make it impossible to mix audio from eternal-lands to that coming from other sources (say, your favourite battle music in the background :)). Let us know if you make any progress. Also, someone with Ubuntu 10.10 might be able to provide more precise help.

Share this post


Link to post
Share on other sites

Hi all, i've been playing the game for a couple of days on Ubuntu 10.10 - love it! Downloaded the sound and unzipped it into a folder called "sound".

 

Changed the settings in-game to enable sound and changed the el.ini file to read "sounds" - 1 but still no sound.

 

First of all, make sure you have unzipped the file in the right location - it should be in the game INSTALL dir (not the logs/settings dir), in other words you should have a folder "sound" in the same directory as other folders "2dobjects", "3dobjects" ... "textures". And, "sound" should contain directly the various .ogg files, not another subdirectory. Once this is checked, ...

 

When i execute the bin file to start the game using a terminal the game starts but 1 line in terminal says "open /dev/[sound/]dsp: No such file or directory"

 

In the options, in-game under audio the sound device is empty (on another thread someone said this doesn't matter).

 

Any help is much appreciated.

This might be a problem with your audio subsystem. Traditionally, under Linux (and other Unices) you can just output audio data to /dev/dsp and have it played for you; however opening the audio device also locks it, so only one process at a time can access the audio. This has been solved in two ways: by providing a master daemon to mix audio from multiple sources (as in esd or alsa), or by offering a different kernel-level interface (as in oss). It is hard for me to tell what you have on your machine, since I am not on Ubuntu.

 

However, you can look for some compatibility layer. This could come either as a system-setting, or can be forced on the command-line. For example, running

aoss eternal-lands

ensures that eternal-lands is executed in an environment where the alsa-oss compatibility layer is activated. Another option is of course to see if you have another program locking the audio device and kill it, but this might make it impossible to mix audio from eternal-lands to that coming from other sources (say, your favourite battle music in the background :)). Let us know if you make any progress. Also, someone with Ubuntu 10.10 might be able to provide more precise help.

 

I was having a similar problem with the sound, but after installing and running the game with the aoss command I have sound. Unfortunately, when I quit with alt-x or alt-q the .bin runs one of my cpu cores to 100% and the picture freezes. I have tried running the game without aoss and sound turned off and it exits cleanly. Is there a better way to exit the game or an option for the aoss command that will ensure a clean quit? Thanks!!

Share this post


Link to post
Share on other sites

Thanks for the replies. I've tried running the aoss command in a terminal but get "Eternal-Lands not found". I've also cd to the directory it is installed in but get the same.

 

Can anybody help please - i believe this is the most likely problem.

Share this post


Link to post
Share on other sites

"Eternal-Lands" is not the binary name, the binary name is "el.x86.linux.bin"

cd to the directory where it's installed and run: aoss el.x86.linux.bin

Share this post


Link to post
Share on other sites

Ok i can't quite believe this - i now can't start the game!

 

When typing in aoss /el.x86.linux.bin or aoss el.x86.linux.bin (i've tried both after cd to the correct directory) i get "exec: 14: el.x86.linux.bin: not found".

 

When trying to start the game (and remembering that i'm scrolling through the commands that i have used for the past 2 months to start it) i'm getting "sudo: /el.x86.linux.bin: command not found"

 

I'm wondering whether i should just do an uninstall/clean install of the game again? How would i uninstall it?

 

Thanks.

 

edit: i've cd'd to the correct place and the bin file is executable!

Edited by Andysoldier

Share this post


Link to post
Share on other sites

If you cd to the installation directory and just do:

./el.x86.linux.bin

Does the game start? (you'll still have no sound, but does it start up?)

Share this post


Link to post
Share on other sites

Ok Korrode you've cracked it all for me!

 

Yes that started the game - i guess that's why it says newbie near my ID (i'm new to Ubuntu too).

 

I then tried the aoss el.x86.linux.bin - no luck.

 

So i tried aoss ./el.x86.linux.bin - jackpot!

 

Please tell me what ./ does.

 

Many thanks to all who have replied.

Share this post


Link to post
Share on other sites

Glad to hear it's working. :)

 

Please tell me what ./ does.

Detailed reasoning can be found here:

http://www.linfo.org/dot_slash.html

 

...but in short; it's a safety mechanism.

When you're running a binary that's not located in a directory within your PATH variable it's presumed to be less trustworthy. As a safety measure your shell will only execute such binaries when a full path to them is provided. "./" just explicitly points to the current directory you are in. (As a further example, "../" signifies the directory one level up from you current location.)

Share this post


Link to post
Share on other sites

aoss is used to wrap sound output of software that only supports OSS to the (as of 2.6) kernel supported ALSA.

 

ALSA also has kernel modules designed to do provide this functionality, and when they are loaded you should not need to start EL prefixed with aoss.

 

Try installing the package called oss-compat and then start EL without aoss and see if you have sound.

 

 

(For others reading this, the oss-compat package exists in Debian/Ubuntu and all it does is make sure the ALSA OSS-compatibility kernel modules get loaded. I don't know if other distros have such a package, if not you can just load the modules yourself, names of the modules are here.)

Edited by Korrode

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×