Jump to content
Eternal Lands Official Forums
Guest Tovin

Unable to connect to server

Recommended Posts

Guest Tovin

Fri 9-16-22, I was playing when my client closed unexpectidly. I tried to open the client and it was unable to connect to server. I re-downloaded  & re-installed the client with no avail. Today same thing.

Share this post


Link to post
Share on other sites

It is likely something that's changed your side.  Did you install updates around the time?  Have you changed your firewall setting?

Share this post


Link to post
Share on other sites
Guest Tovin

Nothing changed. Nothing was installed, the client just closed by it's self & from that point forward wouldn't connect to the server.

Share this post


Link to post
Share on other sites

In that case, more information might help: OS with version, and what kind of internet connection do you have?

If you use MS-Windows, are you sure there haven't been any updates?

Also, iirc the client can create an error.log and an info.log file, those might have useful info as well.

Same with the output from the client when started from a terminal window.

Share this post


Link to post
Share on other sites
Guest Tovin

I am running windows 8 & haven't updated anything. When the client closed & wouldn't connect, I downloaded the most current client from eternal lands web site & installed it with the same results. the error log, I am going to have to find it...By chance do you know what directory that would be in?

 

Share this post


Link to post
Share on other sites
Guest Tovin

Revi

 

By th eway, I am connected via DSL. When the el-client closed on it's own, no error/info log was generated (or wasn't put in any of the clients directories).  Since it couldn't connect to the server, the only thing that was updated (either by the system or myself) was the client itself. I downloaded the current client & then installed it, and same thing, couldn't connect to the server.

Everything else in my system, browser etc, everything else still has connectivity (before client issue & after issue).

 

This has me bewildered. I have looked through (directory by directory & file by file.) Either there isn't anything there, or (more than likely) I am not seeing any issues.

Share this post


Link to post
Share on other sites
Guest Tovin

Ok, this problem started on Friday & I posted on Sat in the am. Here it is Tuesday in the Pm. The still seems to be no resolution to this.

 

Just to be clear, I am still looking for possible fixes to this, since I am still unsure if it is on my end, or maybe elsewhere.

 

Any thoughts to resolve this, I am open to explore.

Share this post


Link to post
Share on other sites

Well, if as you say the client works normally, but can't connect to the server, the problem is not with the client.

 

Some possibilities:

- your firewall blocks the connection

- your ISP blocks port 2000 (either you switched ISP, or they changed their policy)

- or you are on an IP the server ignores completely (not likely).

- or ...

 

We don't have much to work with here, ...

Share this post


Link to post
Share on other sites
Guest Tovin

This has me baffled.. 1 sec, it was working & I was playing the game, then the client just closed & wouldn't connect after that. I didn' t block any ports, I didn't alter any firewall.

 

I wish I had more info for you, just like I said.....It was working...it closed (not by me)...it wouldn't connect.....That's it.

Share this post


Link to post
Share on other sites

But we are dealing with deterministic systems here. If "'nothing changes", behaviour won't change.

Behaviour changed, so something was changed. Not necessarily by you, though...

 

Try connecting to the test server, it uses a different port.

Or try a traceroute to the server at "game.eternal-land.com".

If both work, it looks like port 2000 has been blocked somewhere up the line.

Share this post


Link to post
Share on other sites
Guest Tovin

Ok, how do I connect to the test server? I open the program, it loads the files then it trys to connect to the server, it displays the msg "Cant connect to server"

Share this post


Link to post
Share on other sites

Open a console window, and (I hope, not being a windows user except under duress)

>C:\Program Files (x86)\Eternal Lands\el.exe test

Might also be useful to try a console run on main (as asked)

 

Btw, that command came up in less than 5 min searching this site.

Edited by revi

Share this post


Link to post
Share on other sites
Guest Tovin

I opened the command prompt & entered what you mentioned & got an error. Curious, I went to that directory (c:\programfiles<86>) & eternal lands isn't there.

 

On other spots, I have eternal lands. I just need to know which one to try this out on.

Share this post


Link to post
Share on other sites

Okay, make a shortcut of your Eternal Lands Client on your desktop. Open up the properties on that shortcut you made by right clicking it. You will see under the "Target" "C:\Program Files (x86)\Eternal Lands\el.exe" put a space after that last quotation mark and then type "test" but don't use the quotation marks around test. Hit apply and it should work

Edited by Dylann
thought i forgot something

Share this post


Link to post
Share on other sites
Guest Tovin

Again, under the directory of Program files, there is no directory for eternal lands.

 

Under c:\ & F:\, I have directorys for eternal lands....Which one do you need me to go into?

Share this post


Link to post
Share on other sites

Right...

 

If you have several el.exe, something went wrong somewhere (or there's an old version trailing around).

 

And could you try to give more than the absolute minimum of information when you post?

2 hours ago, Guest Tovin said:

I opened the command prompt & entered what you mentioned & got an error.

Which error message?

 

2 hours ago, Guest Tovin said:

On other spots, I have eternal lands. I just need to know which one to try this out on.

What exactly do you have as "eternal lands". Note that you are looking for an executable...

And keep in mind that we don't have access to your hard disk

 

Also, that command I gave you (ok, it didn't work in your case) came from these forums. You could have found that

with a simple search and a few minutes of effort. We want to help, but it would be nice to see some effort on your part...

Unfortunately, my crystal ball is still not working.

 

 

Edited by revi

Share this post


Link to post
Share on other sites
Guest Tovin

If it is the executable you mean, let me see which directory it is in. When I installed it, I told set up to load the program in a particular directory. With that in mind, I will check both directorys. Set up made both, even when I removed the program & re-istalled it, it created both each time.

 

I will check for the executable & let you know

Share this post


Link to post
Share on other sites
Guest Tovin

Ok, got it. I ran el.exe test . The client opened, loaded the files, conect to server.

Then the work "test server" came up & just sat there

Share this post


Link to post
Share on other sites

That sounds pretty normal, that's what I see until I click in the window. Then I get a login window.

 

So that looks as if something blocks port 2000 between your computer and the server.

There is absolutely nothing we can do about that.

 

You can try to get a VPN, but that's beyond the help EL can give you.

Share this post


Link to post
Share on other sites
Guest Tovin

I dont need a Virtual Private Network since I am on an actual private network. On my private network, the game has run fine without issue. Then, while playing the game, it randomnly closed & I couldn't get back in, even removing it & reloading it again.

 

Nothing changed on my end (either by myself or automatically).  The whole thing has me confussed.

 

So, In short, (if I understand this), when I want to go into the game, I have to use the command prompt to load it, then click the window & I'll be set.

Share this post


Link to post
Share on other sites

 

31 minutes ago, Guest Tovin said:

So, In short, (if I understand this), when I want to go into the game, I have to use the command prompt to load it, then click the window & I'll be set.

For test server, that seems to work. If you want to try that for the main server, just leave off the "test".

Probably won't work though...

 

Oh, and the game cannot run on your private network. A "client" implies a server, which I can guarantee is not on your private network

(or I and everyone else playing would have access to that "private" network).

If you want more details, pick up a good text about internet and networks (wikipedia might work, also look up the notion of "ports")

Share this post


Link to post
Share on other sites
Guest Tovin

If the game can not run on a private network, then answer me this..."Why has it been running on my private network until the 16th?"

 

Also, if "client" implies it is a server, then why call it a client, just call it a server.

Share this post


Link to post
Share on other sites

Tovin, what do you mean by your "private network"? 

 

Are you trying to log in from work maybe and they might have realized it and shut down port 2000?

Are you trying to log in from a proxy such as Tor, or vpn?

 

Wherever you try to log in from, you must connect from that network with the EL client you downloaded and installed to www.game.eternal-lands.com, which is the server that EL is hosted on, through port 2000.  If the route is blocked somehow, such as port 2000 blocked, that's out of our hands and something to do with the path your client is taking to reach www.game.eternal-lands.com. 

Share this post


Link to post
Share on other sites
Guest Toviin

I am logging in from home, on my own (Dsl) network, which I changed from the public 192.168.x.x To a completely pivate address. From that point, using a ddress which is private, I have been able to play el since until the 16th, when the client (oooops, according to them, the server) closed on it's own & wouldn't connect to the actual server. I even removed it completely from my system, downloaded it again, reinstalled & it continued to not connect.

 

Now, the solution seems to be, if I want to play El, I have to  open the command prompt, go to the directory then open "El.exe test" in-order to play

 

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×