Jump to content
Eternal Lands Official Forums

Unwalkable Tiles

Recommended Posts

With the new client update I am able to click on many (or nearly every) unwalkable tiles and get the green 'walk-to' X indicator. I don't actually walk to the spot, or near the spot, just get nothing. This particularly applies to partially covered tiles that are unwalkable as well as the black edges of insides that are unwalkable, however it seems like you can get the X indicator on most unwalkable tiles with a particular camera angle and mouse click location.


This includes, under walls, rocks, bushes, trees, mountains, outside of houses on insides maps, and basically every other place I have tried.


To repeat, just click on the map tile you know is unwalkable. If there's an item (crate, box, barrel, rock, etc.) on top of the tile you might need to zoom in/out or rotate the camera to get a spot where clicking gives you the green X indicator. It's quite easy to duplicate on walls of inside buildings.


In 1.9.5 you could click these places, but you would not get the green X unless it was a proper walkable tile.

Share this post

Link to post
Share on other sites



This is new at least from the 1.9.5 client I was using. (somewhere around p6 to p8 ish?).


Have also chatted with a few other fellow explorerers and they also experience the same issue. As far as everyone I've talked to can tell it's popped up with the change to 1.9.6.


It's nothing game breaking, but while exploring (or doing other stuff that requires a fair bit of walking around) it's more than a bit annoying to get a green X on a spot you actually cannot walk to.

Share this post

Link to post
Share on other sites

Still don't think it's new, though perhaps something changed to make it more noticeable. Doesn't really matter.


Regardless, there will be a non-obligatory client update soon (marked as "p1") that should fix it. If you're a self-compiler, you can compile the current git code now to try it in advance.




In the new code (or the coming p1 update): Options -> Controls -> "Less Strict Pathfinding" ... should be on by default, but this should solve the problem. "Extend the range of the walk cursor" a couple options above it has to be On to work, though that's probably already set.



Very basic description: This makes it so if you click an unwalkable tile with nearby walkable tiles, it'll take you to the nearest walkable tile.


Also fixed: You won't get an X mark if somewhere actually is unwalkable. (You get an X on the tile you'll walk to in the ^ above fix.)




*Fix done by grum and bluap, I'm just a mouthpiece ;)

Share this post

Link to post
Share on other sites

Thanks for the fix and update Grum, bluap & team. Sorry for taking so long to install the update, things have been busy.


Behavior with less strict pathfinding seems more similar to pre-1.9.6 behavior. Having toggleable button is also nice in case someone else liked it the post-1.9.6 way instead.


Seems good to me, can mark this one resolved as far as I'm concerned.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.