Jump to content
Eternal Lands Official Forums
bluap

Post 1.9.6 release - updates & issues

Recommended Posts

Please report bugs found in the 1.9.6 release in this topic.  Updated client that fix issues will be available here.

 

We are planning a 1.9.6.1 release soon that will  incorporate all the fixes and improvements.

 

The latest build is version is 1.9.6.0-20220226, these can be used on the main server:

  • Linux static executables 32-bit, 64-bit, armv7, aarch64 - replace your existing executable from the Linux installer and set executable.
  • Windows (only executable and DLLs) 32-bit and 64-bit - unpack into the installed data folder.
  • Android package (can be installed over the play store version).

 

A data patch that includes  just new or changed files, unpack into the installed data folder:

  • An updated version of item_extra_info.txt that fixes issues with equipment swap for the "Mod Cloak", "White Wizard Hat of Life and Mana" and "Tunic of the Ninja" as detailed elsewhere.  A server restart is needed for other, similar issues.
  • An updated version of sound/snds_client.xml that fixed some positional sounds.
  • An update version of the lion guild map maps/guildmap_lion.elm.gz.
  • The new shader files shaders/new_water.vert and shaders/new_water.frag that fix the water effects for some newer drivers.

 

These are the client changes since release:

2022-02-26

  • Fix trade issue where items would not be sent to storage as expected.
  • Reset number of enabled local lights on map change.

2022-02-22

  • Fixes for water effects on newer drivers that no longer support the older effects.  To use the new effects you need to install the new shader files that included in the data patch listed above. There is a new option on the video tab that is used to enabled the new shaders.  Grum has done a lot of work on the to fix the water effect in this and the 2022-01-21 update.  This updated should fixed all the reported issues.

2022-01-21

  • Less strict pathfinding" option (Controls tab): Allow the pathfinder to walk to a nearby location when clicking an unwalkable tile, discussed in part in this topic.
  • Fixes for water effects for some Intel, AMD and GPU graphics driver issues.  Setting "water shader quality" to 2 will now enable the nice ripple effect for more users.  It also fixes the non-working water and corrupt reflections some users were experiencing.
  • Provide an option (Controls tab) to turn off the click through action when focusing the main window.

2022-01-15

  • Add additional logging when saving user files. The explicit file close needed for the logging may possibly fix "problem with ..." issues.
  • Detect if loading a zero length user file, log to user but don't disable saving. Zero length files have been reported but required user action to resolve.
  • Fix showing #glow command output when indicator disabled.

2022-01-09

  • Add date to timestamp in chat log.
  • Provide and option (Video tab) to enable the desktop screen saver / monitor power management.
  • Set lower bound of chat lines from 5 to 1.
  • Issue #165: Re-validate ground bag window status on reconnect.
  • Issue #163: Fix storage access inconstancy, Store-All and ALT-click access for closed window.

2021-12-31

  • Fix mouse over issues for spells windows on Android (in 1.9.6.0-1 update).
  • Fix only initial spells window mode using default position (in 1.9.6.0-1 update).
  • Fix possible crash with #calc using L (in 1.9.6.0-1 update)
  • Fix possible crash in character creation window (in 1.9.6.0-1 update).
  • Fixed display of action point > 999 in the stats window.
  • Correct colour for login window version text when there is an error.
  • Ensure main window fits the available space and is on-screen.
  • Use the new (JSON) personal files format by default.
  • Enable the item use counter by default.
  • Channel colours window can be scaled and its position managed.
  • Change ground bag window default position to bottom centre.
  • Fix blank lines in console when wrapping text to fit width.
  • Add basic screen orientation options for Android (video tab).
  • Limit "You cannot access the storage from here" messages.
  • Add date to timestamps in log messages.
  • Fix trade bug where storage could not be used if the window was hidden then shown.
Edited by bluap

Share this post


Link to post
Share on other sites

item swap with Tunic of the ninja doesn't work.

Am on Mac, don't see update for that yet.

 

 

Edited by Maxine

Share this post


Link to post
Share on other sites

Updated build (2022-01-09) with additional small fixes and improvements list at the top of the thread.

Share this post


Link to post
Share on other sites

More new bug fix builds, see top of thread.

 

If you have had issues with settings and received the message "Problem with <file type>" then please install this update.

  • Someone helpfully reported that when they received the "Problem with <file type>" message the file was zero length.  This is now detected and logged to the console.  The error no longer prevents the file from being saved.
  • There is now additional logging (including console messages) if there is an issues when saving a file.  To do this, an explicit close of the file is now done and there is a possibility that this may fix the "Problem with <file type>" issue.  If it does, you may see the "zero length file" message once, but not a second time for the file.  If you do get the "closing file failed" message, please report the issue to the forums and include the contents of the last log file "<user settings>"/logs/main_XXX.log".

Share this post


Link to post
Share on other sites
49 minutes ago, Raz said:

Ty for this - sadly still not got working water texture :(

Which platform are you using.  I mistakenly posted the information a few minutes before I uploaded the windows zip files, the version number should be 1.9.6.0-20220121.  Grum did the fix and it works for the systems we tried it on that were experiencing the problems.  I'm sure Grum would like to hear from you.

Edited by bluap

Share this post


Link to post
Share on other sites
19 minutes ago, bluap said:

Which platform are you using.  I mistakenly posted the information a few minutes before I uploaded the windows zip files, the version number should be 1.9.6.0-20220121.  Grum did the fix and it works for the systems we tried it on that were experiencing the problems.  I'm sure Grum would like to hear from you.

Was the new version - just downloaded again to confirm. 

Still all flat blue and flickery :(

 

Windows 64 bit  - installed from the website - and overwritten with your excellent updates in this thread

@Grum please feel free to contact me directly!

elscreen119.png

Share this post


Link to post
Share on other sites

Do you have anything in the latest log file? ".../Eternal Lands/log/main_<random characters>.log"  There should be a line including "....reflection.c:..."

Edited by bluap

Share this post


Link to post
Share on other sites
9 hours ago, bluap said:

Do you have anything in the latest log file? ".../Eternal Lands/log/main_<random characters>.log"  There should be a line including "....reflection.c:..."

[2022-01-21 22:51:50, C:/msys64/home/paul/el-client/elc/reflection.c:111] Info: Frame buffer texture looks right, not flipping water reflection

Share this post


Link to post
Share on other sites

Looks like there are no reflections at all, which is a new issue for me. I'm sorry if you already mentioned this, but do you have reflections when water shader quality is set to 1?

Share this post


Link to post
Share on other sites

I never see any form of texture on the water surface - and never any indication of shadows.

 

I have tried all combinations of shader quality & reflections.

Seems with 1 & 2 and reflections on - the water flickers - with reflections off I get a smooth flat blue surface.

 

Also not sure if related - but the white / yellow dots in the minimap are square now (can just see in image above)

Edited by Raz

Share this post


Link to post
Share on other sites
8 hours ago, Raz said:

I never see any form of texture on the water surface - and never any indication of shadows.

 

I have tried all combinations of shader quality & reflections.

Seems with 1 & 2 and reflections on - the water flickers - with reflections off I get a smooth flat blue surface.

 

Also not sure if related - but the white / yellow dots in the minimap are square now (can just see in image above)

 

I have already solved three problems with the water reflections, but yours presents an entirely new one :) Given that you do not see any reflection at all, I suspect the reflection texture is not generated for some reason. If you're interested in helping us debug this, I have uploaded a debug build of the client here. This should generate a more extensive log file. Could you do a short run with this executable (just place it in your EL data directory and run it), and send me the log file afterwards? Just upload it somewhere, or contact me for an email address. Also, can you send me the output of #glinfo?

 

Thanks!

 

Share this post


Link to post
Share on other sites

Thanks, this is useful. Two things jump out:

Quote

[**** gamewin.c:1313] Error: OpenGL invalid enumerant
[**** shader/shader.c:271] Error: OpenGL invalid operation

I am going to try and track down what might cause these.

Share this post


Link to post
Share on other sites

Ok i post here 2 Bugs that i had ever since the new client is out that do me annoy, 

1st if i trade between 2 chars on teh same pc, now and then, one char does not get the trade.log, while the other does. only realized it for sure on trades when all chars where on same pc so.

Secondly there is the Tradebug where pretty regularly for me now trades do not go from storage to storage or from inventory to inventory as expected but from storage to inventory or other way around.  Best guess i had so far was the time needed between putting things into the trade window and accepting the trades. there

Share this post


Link to post
Share on other sites
On 03/02/2022 at 8:21 AM, vinoveritas said:

1st if i trade between 2 chars on teh same pc, now and then, one char does not get the trade.log, while the other does. only realized it for sure on trades when all chars where on same pc so.

I can't see why that would be, each character uses a separate file, and the clients are separate processes so there is no possibility of a clash.  The 2022-01-15 update on this thread includes explicit file closing in a number of places where previously this would to happen automatically.  One of those places was the trade log so, if there was a problem with the automatic close that will be fixed now.  If you are using the 2022-01-15 build or later and still see this problem please let is know.

 

On 03/02/2022 at 8:21 AM, vinoveritas said:

Secondly there is the Tradebug where pretty regularly for me now trades do not go from storage to storage or from inventory to inventory as expected but from storage to inventory or other way around.  Best guess i had so far was the time needed between putting things into the trade window and accepting the trades. there

Again, I've tied to reproduce this one but cannot.  One of the previous attempts to fix this introduced a new bug which is present in the 1.9.6.0 release, that new bug was fixed in the 2021-12-31 update - "Fix trade bug where storage could not be used if the window was hidden then shown."

Share this post


Link to post
Share on other sites

The build have been updated to 1.9.6.0-20220219 which includes the new water effects work Grum has done.  There is a data patch archive that includes the new shaders and other data files.

Edited by bluap

Share this post


Link to post
Share on other sites
11 hours ago, bluap said:

The build have been updated to 1.9.6.0-20220219 which includes the new water effects work Grum has done.  There is a data patch archive that includes the new shaders and other data files.

Just to say a huge thank you to Grum for is patience in building countless test clients for me - and bluap for making these builds available ..... for the first time ever I see ripples on water - and reflections!

 

To enable this - you need to turn on 'use new water shader' in video tab - and as always - enable frame buffer support and set the quality to 2!

Share this post


Link to post
Share on other sites

bluap to trading going to storage instead inventory bug,  i did do some testing and it only happens if on one side i do the accept from yellow to green very fast, and then fast accept on other side too, if i do it slowly it works every time as it should. Will make me a new git client compile for the other bug ty

Share this post


Link to post
Share on other sites
7 hours ago, vinoveritas said:

bluap to trading going to storage instead inventory bug,  i did do some testing and it only happens if on one side i do the accept from yellow to green very fast, and then fast accept on other side too, if i do it slowly it works every time as it should. Will make me a new git client compile for the other bug ty

Could you provide the exact steps that lead to the failure, including who trades what from where (storage or inventory), who starts, the order of who clicks what, including changing the destination.  Really as much detail as you can.  Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×