Jump to content


Photo

Ubuntu 14.04 (Trusty Tahr) missing /dev/dsp so no sound


12 replies to this topic

#1 r0wan

r0wan

    Rat

  • Members
  • 60 posts
  • Gender:Male
  • Location:Southern California, US

Posted 15 May 2014 - 04:00 PM

Brand new install of Ubuntu 14.04 desktop 64-bit does not have /dev/dsp and subsequently no sound in EL client from https://help.ubuntu....ty/EternalLands

 
#ver = Eternal Lands Version 1.9.3p20140411
 


#2 kapbepucm

kapbepucm

    Skunk

  • Members
  • 113 posts
  • Gender:Male
  • Location:Latvia, Eastern Europe

Posted 16 May 2014 - 06:25 AM

print here output of commands:

sudo lsmod|grep 'snd'

sudo ls -l /dev/snd/

#3 r0wan

r0wan

    Rat

  • Members
  • 60 posts
  • Gender:Male
  • Location:Southern California, US

Posted 16 May 2014 - 02:56 PM

snd_seq_dummy          12798  0 
snd_seq_midi           13324  0 
snd_seq_midi_event     14899  1 snd_seq_midi
snd_rawmidi            30144  1 snd_seq_midi
snd_seq                61560  3 snd_seq_midi_event,snd_seq_dummy,snd_seq_midi
snd_seq_device         14497  4 snd_seq,snd_rawmidi,snd_seq_dummy,snd_seq_midi
snd_hda_codec_realtek    61438  1 
snd_hda_codec_hdmi     46207  2 
snd_hda_intel          52355  13 
snd_hda_codec         192906  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep              13602  1 snd_hda_codec
snd_pcm               102099  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc         18710  2 snd_pcm,snd_hda_intel
snd_timer              29482  2 snd_pcm,snd_seq
snd                    69238  37 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_dummy,snd_seq_midi
soundcore              12680  1 snd
 
total 0
drwxr-xr-x  2 root root      100 May 10 21:30 by-path
crw-rw----+ 1 root audio 116,  6 May 10 21:30 controlC0
crw-rw----+ 1 root audio 116, 13 May 10 21:30 controlC1
crw-rw----+ 1 root audio 116, 18 May 10 21:30 controlC2
crw-rw----+ 1 root audio 116,  5 May 10 21:30 hwC0D0
crw-rw----+ 1 root audio 116, 12 May 10 21:30 hwC1D2
crw-rw----+ 1 root audio 116, 17 May 10 21:30 hwC2D0
crw-rw----+ 1 root audio 116,  4 May 15 08:35 pcmC0D3p
crw-rw----+ 1 root audio 116,  3 May 15 08:35 pcmC0D7p
crw-rw----+ 1 root audio 116,  2 May 15 08:35 pcmC0D8p
crw-rw----+ 1 root audio 116, 11 May 10 21:30 pcmC1D0c
crw-rw----+ 1 root audio 116, 10 May 16 07:51 pcmC1D0p
crw-rw----+ 1 root audio 116,  9 May 15 08:22 pcmC1D1c
crw-rw----+ 1 root audio 116,  8 May 10 21:30 pcmC1D1p
crw-rw----+ 1 root audio 116,  7 May 10 21:30 pcmC1D2c
crw-rw----+ 1 root audio 116, 16 May 15 08:35 pcmC2D3p
crw-rw----+ 1 root audio 116, 15 May 15 08:35 pcmC2D7p
crw-rw----+ 1 root audio 116, 14 May 15 08:35 pcmC2D8p
crw-rw----+ 1 root audio 116,  1 May 15 14:40 seq
crw-rw----+ 1 root audio 116, 33 May 14 07:37 timer
 
I should mention sound works otherwise.  System sound test works with left and right speaker and with Steam (for Linux) + 2 games and the following in PlayOnLinux+Wine: Arc Games client + 2 games, Steam client + 1 game, Origin client (though the free ZvsP doesn't download), and PoE.

Edited by r0wan, 16 May 2014 - 03:06 PM.


#4 kapbepucm

kapbepucm

    Skunk

  • Members
  • 113 posts
  • Gender:Male
  • Location:Latvia, Eastern Europe

Posted 17 May 2014 - 06:05 AM

hmm...
looks like your system sound system is OK

try this way:
in EL ctrl+o -> "audio"
make sure you have:
[ ] Disable Sound and Music System
Sound Device -> make blank
[x] Enable Sound Effects
volumes numbers make greater
[x] Enable music

Check if you have folders "music" and "sounds" in your Eternal lands binary folder

#5 r0wan

r0wan

    Rat

  • Members
  • 60 posts
  • Gender:Male
  • Location:Southern California, US

Posted 18 May 2014 - 11:27 PM

[ ] Disable Sound & Music System is unchecked.

Sound Device is blank.

[ ] Enable Sound Effects is unchecked.  Checking it produces no sounds and will clear on restart of EL client.

Sound Gain 1.00



#6 revi

revi

    Skeleton

  • Moderators
  • 1018 posts
  • Gender:Not Telling

Posted 19 May 2014 - 04:25 AM

have a look here about missing /dev/dsp on ubuntu 14.04:

http://ubuntuforums....d.php?t=2173702

(first google hit, btw)



#7 r0wan

r0wan

    Rat

  • Members
  • 60 posts
  • Gender:Male
  • Location:Southern California, US

Posted 20 May 2014 - 02:04 AM

Running 'padsp eternallands' clears out Sound Device so it does not say /dev/dsp but remains blank.

[ ] Enable Sound Effects is also cleared.

 

Fill the two in, restart EL, the two are cleared again.

 

My method to get /dev/dsp back:

sudo apt-get install osspd-alsa
sudo alsa force-reload
It did not allow EL sound to work either.  /dev/dsp is still empty in Sound Device and [ ] Enable Sound Effects remains cleared.
 
No, I will not be uninstalling alsa+pulseaudio and replacing it with OSS because all other programs' sounds work.
 
Compiling el client from git gives the same results as "Eternal Lands Version 1.9.3p20140411"; although, #ver reports 1.9.3 without the ".pYYYYMMDD" patch level.  I don't know why the git build does not have the patch level.
 
Has anyone got EL sound working in a clean installation of Ubuntu 14.04 desktop 64-bit (not upgraded)?
 
 
$ sudo apt-get install eternallands eternallands-data eternallands-music
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package eternallands-music is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source


E: Package 'eternallands-music' has no installation candidate
 
/usr/share/games/EternalLands has maps/ directory but no sounds/ or music/:
/usr/share/games/EternalLands$ ls -F
2dobjects/                  languages/
3dobjects/                  license.txt
3dobjects.txt               main_icon_window.xml
actor_defs/                 mapinfo.lst
animations/                 maplist.lst
browser.lst                 maps/
commands.lst                material_metadata.xml
custom_mirrors.lst          meshes/
elc.ico                     mines.xml
el_icon.png                 mirrors.lst
el.ini                      named_colours.xml
emotes.xml                  new_character_icon_window.xml
entrable.lst                particles/
eternallands-data.dirlist   servers.lst
eternallands-data.filelist  shaders/
extentions.xml              skeletons/
global_filters.txt          skybox/
harvestable.lst             sound_warnings.txt
icon.bmp                    spells.xml
item_info.txt               textures/
key.ini                     weather.xml
knowledge.xml

 

Synaptic shows only eternallands and eternallands-data packages.  No sound and no music packages.  I'm going to try a manual download of the zip files and unzip into /usr/share/games/EternalLands/.

 

 

SOLVED:

 

Sound and music must be downloaded from the links provided at http://www.eternal-l...ge/download.php.  They are not in the repository as of 2014-05-19.

 

http://www.gm.fh-koe...L_sound_191.zip includes the sound files in a sound/ directory.  Unzip and move sound/ to /usr/share/games/EternalLands/.

 

http://www.gm.fh-koe..._music_full.zip has all the music files without any directory, so create a new directory music/ and unzip in there then move music/ to /usr/share/games/EternalLands/.

 

chown -R root:root /usr/share/games/EternalLands/{sound,music} to make all the new files owned by root user and group.

 

If you really need a shell script to automate this, ask and I'll write one.  I'll probably forget this again when Ubuntu 128-bit rolls around. ;)

 

 

Thanks to everyone that helped with this issue, especially kapbepucm's "Check if you have folders "music" and "sounds" in your Eternal lands binary folder".


Edited by r0wan, 20 May 2014 - 04:23 AM.


#8 bluap

bluap

    Feran

  • Moderators
  • 2218 posts
  • Gender:Male
  • Location:UK

Posted 20 May 2014 - 09:04 PM

The 3p20140411 patch level is added by me to the source when I build the packages.  The eternallands-sound and eternallands-music packages are available and work just fine.  I suspect that you have not added the two repositories needed.  The help page you stated set out the process.  Add the release repository "sudo add-apt-repository ppa:pjbroad/ppa" to get the current official release version which included sound and music.  If you want the latest development client and data packages, you need to add the additional testing repository "sudo add-apt-repository ppa:pjbroad/testing".  The music and sound packages have not changed since release and so are not included in the testing repository.  You need both of you want to use the latest client build.



#9 r0wan

r0wan

    Rat

  • Members
  • 60 posts
  • Gender:Male
  • Location:Southern California, US

Posted 21 May 2014 - 01:38 AM

bluap:

 

You are correct.  I had only added the testing repository and then installed eternallands and eternallands-data.  Since eternallands-sound and eternallands-music did not exist, I assumed they were included in the eternallands-data package.  Once I added the release PPA, eternallands-sound and eternallands-music packages were available.  Removing the /usr/share/games/EternalLands/{sound,music} directories I created from the .ZIPs and installing the respective packages from the release PPA still allows EL client to provide sound and music.  Thank you.

 

May I suggest that you add your clarification in your wiki page?  I tried to register to edit, but Ubuntu One seems to intercept my login to edit https://help.ubuntu....ty/EternalLands.

 

Thanks again.



#10 bluap

bluap

    Feran

  • Moderators
  • 2218 posts
  • Gender:Male
  • Location:UK

Posted 21 May 2014 - 06:39 AM

Glad that is resolved.  The wiki page does state: "The development version is available from a different package repository that needs to be added in addition to the standard one." at the end of the paragraph describing the development version.  What other clarification do you suggest?



#11 r0wan

r0wan

    Rat

  • Members
  • 60 posts
  • Gender:Male
  • Location:Southern California, US

Posted 21 May 2014 - 07:05 AM

Sorry, I meant about the -sound and -music packages only being in the release repository and not in testing.



#12 bluap

bluap

    Feran

  • Moderators
  • 2218 posts
  • Gender:Male
  • Location:UK

Posted 21 May 2014 - 08:45 PM

OK, I'll see what I can do. Most of the time, the testing repository only contains the client package and not the data package  That's why there is a need for both.



#13 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 13 August 2015 - 09:20 PM

For me it worked, just following the suggestion, above:

sudo apt-get install osspd-alsa





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users