Jump to content


Photo

The Missing Alt Key

12.04 Ubuntu Precise Alt key

7 replies to this topic

#1 ZootNerper

ZootNerper

    Skunk

  • Members
  • 128 posts

Posted 29 April 2012 - 07:25 AM

If you have upgraded to Ubuntu 12.04 Precise, you will notice the Alt key does not work in EL. This is because it has been hijacked by Unity's HUD. To disable the HUD, I used Ubuntu Tweak. You can get it from the ppa at:

https://launchpad.ne...ix/ archive/ppa

(with instructions there as to what to do)

Or you can download from their website:

http://ubuntu-tweak.com/

Then in Ubuntu Tweaks go to: Tweaks->Unity. You will see the option to turn off the HUD at the top of the page.

As an aside, you can also turn off the Ubuntu log on sound in the Sound option on the Tweaks page.

#2 extrapolation

extrapolation

    Spider

  • Members
  • 623 posts

Posted 30 April 2012 - 12:33 PM

Thanks for the tip. Is there any other keyboard shortcut that can bring up the unity launcher? It's annoying having to use the mouse for this...

#3 ZootNerper

ZootNerper

    Skunk

  • Members
  • 128 posts

Posted 30 April 2012 - 11:35 PM

The Unity launcher (I think that is the name of the bar on the left that pops up or is permanently visible depending on settings) is just a tap of the Super (or Windows) key.

The HUD is a tap or press of the left Alt Key.

(N.B. I am no expert on these matters. I may be wrong with what I think the launcher and HUD are :} )

If you look in System Settings->Keyboard Layout, the third option down is "Alt/Win Key Behaviour". The fourth option down of this (first being default) you might be able to use with a full keyboard.

My laptop/netbooks don't have a full keyboard so I have no alternative for the Alt (pun intended) key atm :}

#4 extrapolation

extrapolation

    Spider

  • Members
  • 623 posts

Posted 01 May 2012 - 04:33 AM

By 'unity launcher' I was referring (probably wrongly) to the box that pops up when you click the ubuntu symbol on the HUD, or, with the update, when you press left alt. A key (or combo) to open this so I can immediately type would be nice, but I'll do without if I have to. I prefer the convenience of switching between Russian and English keyboards with my 2 windows keys.

Edited by extrapolation, 01 May 2012 - 04:34 AM.


#5 bluap

bluap

    Feran

  • Moderators
  • 2218 posts
  • Gender:Male
  • Location:UK

Posted 12 May 2012 - 10:43 AM

You can also use super+alt to get normal alt behaviour.

#6 r0wan

r0wan

    Rat

  • Members
  • 60 posts
  • Gender:Male
  • Location:Southern California, US

Posted 10 May 2014 - 04:49 PM

I recently installed Ubuntu 14.04 (Trusty Tahr) onto a different HDD to replace Ubuntu 12.04 (Precise Pangolin).  I was going from 32-bit to 64-bit so it had to be a full install and not an upgrade.  Once again the Alt-# keyboard keys were stolen from the EL client.

 

I used the second answer from

http://askubuntu.com...-of-the-alt-key

sudo apt-get install compizconfig-settings-manager

Run "CompbizConfig Settings Manager"

"Desktop" group -> Ubuntu Unity Plugin -> General tab ->

"Key to show the menu bar while pressed" click the button just to the right of the text.

It will bring up a dialog box where you can select the key combination you want to bring up the HUD.

I chose <Alt><Super>.

 

Now EL client gets Alt-# for magic spells and Alt-D for closing/opening all the dialog boxes.

 

r0wan

 

PS: The "System Settings" -> "Hardware" group -> Keyboard -> "Shortcuts" tab -> Launchers category -> Key to show the HUD [Disabled] failed to pass through the Alt-# keys to the EL client.

 


Edited by r0wan, 15 May 2014 - 03:45 PM.


#7 Guest_blar32_*

Guest_blar32_*
  • Guests

Posted 15 July 2014 - 01:20 AM

Thanks! This was helpful and fixed my problem.

 

--blar32



#8 Bandhar

Bandhar

    White Rabbit

  • Members
  • 47 posts
  • Gender:Male
  • Location:Barra Mansa, Rio de Janeiro
  • Interests:Computation, Aikido and Music.

Posted 08 May 2017 - 11:56 AM

Even after some years, solved my problem too. Thanks!





Reply to this topic



  



Also tagged with one or more of these keywords: 12.04, Ubuntu, Precise, Alt key

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users