Jump to content
Eternal Lands Official Forums
Gnome

Openal Problems

Recommended Posts

I've recently switched to linux (mandrake 10.1) and when I execute EL I get this: ./el.x86.linux.bin: error while loading shared libraries: libopenal.so.0: cannot open shared object file: No such file or directory

I then downloaded openal from CVS and installed it and got the same error. Please help :D Thanks

Share this post


Link to post
Share on other sites

You could try to use the statically linked version of EL instead.

If you want to really fix this, you need to:

* Check out where the libopenal.* files are installed

* Make sure the necessary symlink (libopenal.so.0) exists.

 

If you need help, start by running:

find / -name 'libopenal.so.*'

which should show you where the files are installed.

Then cd to that directory and do:

ls -l libopenal*

and post the output here.

 

http://www.eternal-lands.com/forum/index.php?showtopic=8422

Share this post


Link to post
Share on other sites

[root@localhost lib]# ls -l libopenal*

-rwxr-xr-x 1 root root 830462 Oct 25 03:13 libopenal.a*

lrwxrwxrwx 1 root root 33 Oct 25 03:13 libopenal.so -> /usr/local/lib/libopenal.so.0.0.7*

lrwxrwxrwx 1 root root 33 Oct 25 03:13 libopenal.so.0 -> /usr/local/lib/libopenal.so.0.0.7*

-rwxr-xr-x 1 root root 543858 Oct 25 03:13 libopenal.so.0.0.7*

At least I know it exists now :D Would I just move these to /lib then?

 

[EDIT]

 

Moved it to /lib and it works now B):D

0 fps though...I'm going to get a driver for my vid card (read chatters post and glad I have an NVIDIA)

Share this post


Link to post
Share on other sites

Well, you could move them (/usr/lib would be a better choice than /lib, though.) But let's make it work with /usr/local/lib, shall we?

Open up /etc/ld.so.conf with a text editor. Make a backup of this file so that you can revert to the old version if anything goes wrong.

Add a line that says:

/usr/local/lib

Save the file and then run

ldconfig

Your programs should now look in /usr/local/lib, as well as /lib and /usr/lib and any other paths specified in ld.so.conf, for libraries.

 

Feel free to read up on how ldconfig works

man ldconfig

It's a while since I had to do this by hand, so I might have made some mistake above. :D

 

Now, in case you haven't done so already, create an 'normal' user for everyday use - you should only run as root when you really need to!

Share this post


Link to post
Share on other sites

what do you mean?

 

 

have you managed to move this back to the original directory.

 

I'd do that if possible, and go thorough umrion's instructions, as they're correct.

 

If you cant move it, leave it, its doing no harm where it is. just neater the other way.

Share this post


Link to post
Share on other sites

Yes, I moved it back. The file ld.so.conf says its read only when I open it in a text editor though...

Share this post


Link to post
Share on other sites

hmmm....this could confuse you :)

 

open a console/shell.

 

type:

 

cd /path/to/ld.so.conf

 

vi ld.so.conf

 

The editor 'vi' should open up.

 

Does it say its read-only anywhere?

 

press 'i'

 

and then make your changes.

 

then press escape, then

 

:x

 

Thats a colon, then an x, as one word.

 

Press enter.

 

You should be back at the prompt

 

[Edited]

Share this post


Link to post
Share on other sites

O shit..I got into that editor, tried to type something and half of it vanished :)

 

edit: forgot to press i

Share this post


Link to post
Share on other sites

Well in my panic when this happened I closed the terminal..now I'm getting this when I try to edit it

E325: ATTENTION

Found a swap file by the name ".ld.so.conf.swp"

owned by: root dated: Mon Oct 25 06:25:06 2004

file name: /etc/ld.so.conf

modified: YES

user name: root host name: localhost

process ID: 4514

While opening file "ld.so.conf"

dated: Sat Oct 23 21:49:41 2004

 

(1) Another program may be editing the same file.

If this is the case, be careful not to end up with two

different instances of the same file when making changes.

Quit, or continue with caution.

 

(2) An edit session for this file crashed.

If this is the case, use ":recover" or "vim -r ld.so.conf"

to recover the changes (see ":help recovery").

If you did this already, delete the swap file ".ld.so.conf.swp"

to avoid this message.

 

Swap file ".ld.so.conf.swp" already exists!

Share this post


Link to post
Share on other sites

Press 'd'. That will delete the swap file, this is created when you edit a file without saving and then abruptly closing vi. (This was caused by you quitting the shell).

 

Once the swap file is deleted, you should go to the original ld.so.conf.

 

 

Be careful!! :)

 

Use 'u' if you want to undo anything, or just :q! to quit without making changes.

Share this post


Link to post
Share on other sites

Ok i used the recover thing and got it back..edited and pressed esc then enter then :x and now I have this

 

include ld.so.conf.d/*.conf

/usr/X11R6/lib

/usr/lib/qt3/lib

/usr/local/lib

~

~

~

~

~

~

~

~

~

~

~

~

~

~

~

~

~

~

~

E45: 'readonly' option is set (add ! to override) 4,14 All

Share this post


Link to post
Share on other sites

Heh, i hope you have backup this file, and you should press :x THEN enter.

 

just type :x!

 

(colon,x,exclamation)

 

This will overide the read-only attribute and save the file with the new changes.

 

 

Any luck?

Share this post


Link to post
Share on other sites

Getting this...

 

"ld.so.conf"

"ld.so.conf" E212: Can't open file for writing

Hit ENTER or type command to continue

Share this post


Link to post
Share on other sites

Ok so this is read-only and your not root, by the looks of it.

 

At the console, type:

 

su

enter your password

 

(The su command logs you in as root)

 

then open in the file and do the edits again.

 

If that still doesnt work, while logged in as root, do this:

 

chmod a+w ld.so.conf (allows all users to write to the file)

 

make your changes, save, then do this:

 

chmod a-w ld.so.conf (stops all users from writing to the file)

Share this post


Link to post
Share on other sites

Great it works. Thanks guys. I think I'm going to like linux, at least I know what my computer is doing. :) Now to get the driver for my gcard...I'm at 0 fps

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×