Jump to content
Eternal Lands Official Forums
spellbyte

Linux Help

Recommended Posts

I have been playing the windows version for about a week and i love the game, so i decided to have a go with it on my linux machine, and as i am a bit new to linux i am having some problems, i have de-compressed the zip file into a folder and when i click on the game file (el.x86.linux.bin) i get a window pop up that asks what program i would like to use to open the file, any help would be greatly appreciated.

Share this post


Link to post
Share on other sites
Guest Zeplin

which window manager are you useing?

 

Might be best to make a link for the el.x86.linux.bin on the desktop and click that instead.

Share this post


Link to post
Share on other sites

Open a shell (or 'konsole').

 

type:

 

cd /the/path/to/eternal/lands

 

when your in the eternal lands directory, type:

chmod 755 el.x86.linux.bin

 

then type:

./el.x86.linux.bin

Share this post


Link to post
Share on other sites

when i try that last command it comes back with this

 

./el.x86.linux.bin: error while loading shared libraries: libopenal.so.0: cannot open shared object file: No such file or directory

Share this post


Link to post
Share on other sites

You need the openal software (sound).

 

What distribution are you using?

 

You need to download the openAl drivers (try a google. might be openal.org)

Download either the source or the rpm.

 

If you get the rpm, do this:

 

Open a shell (or 'konsole') and goto the directory where you downloaded the rpm (cd /path/to/rpm )

 

once there, type:

su (this will change you to root)

enter your password (if you have one, which you should!! :P)

then type:

 

rpm -ivh name-of-rpm-file.x.x.x.rpm

 

That should install it ok.

 

If you get the source , you need to extract the tar file and do this:

 

At the shell/console type:

 

tar zxvf name-of-tar-file.tar.gz

change to the new directory

cd name-of-dir-created

 

type:

 

./configure

 

Once that has done and there are no errors, type:

 

make

 

when that is done type:

 

make install

 

 

 

Then try EL again

 

good luck :angry:

Share this post


Link to post
Share on other sites

you wont here the sounds anyway, their disabled by default i think.

 

Even if you dont want sound, you still need the libraries.

 

Get the openal source and compile it using the instructions above.

Share this post


Link to post
Share on other sites

well now u've installed it using 'kpackage' you cant install it again, it'll just say its already installed.

 

If you had done it the way i said, you would have got any dependency or installation errors....hmmm

 

Try and remove the openAl rpm, and the re-install it using the method i said above.

 

<_<

Share this post


Link to post
Share on other sites

Check what files were installed and where. You can do this with "rpm -ql openal" (or something like that.) I'm sure there's a way to do it in kpackage too.

I think the problem is that the files where installed, but in such a place that the program can't find them.

Share this post


Link to post
Share on other sites

i tried to install the rpm file the way that you suggested, through the Konsole and it sed that it was already installed, so i tried to run EL once again ony to get this message back up

 

./el.x86.linux.bin: error while loading shared libraries: libopenal.so.0: cannot open shared object file: No such file or directory

 

should i try to unistall openAL as i originally used Kpackage to install it, and once uninstalled, install it the way you suggested?

Share this post


Link to post
Share on other sites

this is what was returned when i entered the following command in Konsole

 

rpm -ivh openal.rpm

 

 

warning: openal.rpm: V3 DSA signature: NOKEY, key ID 9b3c94f4

Preparing... ########################################### [100%]

1:openal ########################################### [100%]

 

I assume that is all ok

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×