Jump to content
Eternal Lands Official Forums
Sign in to follow this  
Guest ZadrraS

Can't Connect.

Recommended Posts

Guest ZadrraS

I think i tried everything that i found in these forums but it still wont connect to the server. It simply saiz: "Can't connect to server :P"

I have windows XP with SP2 and i use SP2's firewall.

I tried pinging "eternal-lands.solexine.fr" and "62.93.225.26". I tried replacing "eternal-lands.solexine.fr" with "62.93.225.26" in "el.ini". I added the port 2000 and Eternal Lands to the firewalls blocking exclusions. None of these helped. My internet seems to work perfectly and i can play all the other games online.

Any ideas what could be wrong?

Thank you!

Share this post


Link to post
Share on other sites

try telnet to eternal-lands.solexine.fr port 2000 or 62.93.225.26 port 2000. And paste output here.

 

Regards.

Share this post


Link to post
Share on other sites
Guest Guest

Pinging the server work and i can go to the players online page.

 

Now, when i telnet "eternal-lands.solexine.fr" or "62.93.225.26" on port 2000 i get:

 

"∟☺ÉOur old server crashed, and we lost all the data,including the player stats (

the last backups were corrupted). So, unfortunately, you will have to start agai

n, and even recreate your character. Sorry for this probelm, from now on we will

back up weekely, and insure their integrity.☺"

Share this post


Link to post
Share on other sites
Guest ZadrraS

(Sorry, forgot my name in the last post)

 

I disabled the firewall and now it work :D

But i don't want to leave it disabled. What could be wrong?

Share this post


Link to post
Share on other sites

That "Our old server crashed" message is the correct one you should see if you're connected properly. Just click on the screen or press Enter or something, and the login screen should appear.

 

-Lyn-

Share this post


Link to post
Share on other sites
Lyn, sorry but: heh!

 

He was telneting to the server to see if he could connect. He wasnt logging in via the client.

 

:D:D

I knew there was a reason why I didn't help out in the Programming Forums... :D:D Haha...ignore whatever I said before.

 

-Lyn-

Share this post


Link to post
Share on other sites
(Sorry, forgot my name in the last post)

 

I disabled the firewall and now it work :P

But i don't want to leave it disabled. What could be wrong?

Open port 2000 in your firewall, and additionally, only allow the EL client to use it.

Share this post


Link to post
Share on other sites
(Sorry, forgot my name in the last post)

 

I disabled the firewall and now it work :P

But i don't want to leave it disabled. What could be wrong?

There's nothing wrong, your firewall is doing what it is supposed to do.

 

Do what fred said, it makes sense.

Share this post


Link to post
Share on other sites
Guest ZadrraS
(Sorry, forgot my name in the last post)

 

I disabled the firewall and now it work  :P

But i don't want to leave it disabled. What could be wrong?

Open port 2000 in your firewall, and additionally, only allow the EL client to use it.

But how do i do that with windows firewall. It can either open a port or let a program through...

 

 

And disabling the firewall doesnt work now ;)

It worked 4 hours ago.

Share this post


Link to post
Share on other sites

I dont know about window's firewall, use ZoneAlarm (www.zonealarm.com) and disable the windows firewall.

 

Let me know when u have ZoneAlarm and what the situation is.

Share this post


Link to post
Share on other sites

If you can telnet and connect to the server, you should be able to connect with the client. And if disabling your firewall doesn't work now, maybe you just have a flaky internet connection or something.

Share this post


Link to post
Share on other sites
Yep, ive posted that i did before.

The reason why i said try telnetting again is because something has obviously changed if you cant connect even after disabling the firewall.

 

 

Try doing that.

 

Like Cicero said, if you can get to the players online you should be able to connect via the client.

Share this post


Link to post
Share on other sites
Guest Guest

Hmmm... I tried it, and telneting doesnt work anymore, even with the firewall disabled, but i can see the players online page and ping.

Share this post


Link to post
Share on other sites
Guest Guest
SO you CANNOT telnet to the server (eternal-lands.solexing.fr 2000) but u can see the players online.

 

That doesnt really make sense....

Yep

 

...

:P

Share this post


Link to post
Share on other sites

Thats bizarre, because if you can visit the players online page, which is the telnet server your trying to connect to, it means dns is working.

 

MAKE SURE YOUR TELNETTING TO PORT TWO THOUSAND:

 

C:\> telnet eternal-lands.solexine.fr 2000

 

Copy the above telnet command WORD FOR WORD into the command prompt.

 

(Without the 'C:\>' of course :P )

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×