Jump to content
Eternal Lands Official Forums
Guest Cody

Cannot open application..

Recommended Posts

Guest Cody

Hi all,

 

I played EL many years ago, for several years. I would love to get back into it, but now have a new MacBook Pro running Mojave. I can give more details if needed, but when I download the client and follow the instructions, the game crashes as I open it. What I mean is that I download it, unzip the file, move the client to the applications folder, then when clicking on it to open, it shows that the game tries to open, then immediately crashes, I don't see any of the EL window.

 

Any help is much appreciated as I miss EL!

codyjdobbs@gmail.com is my email if necessary

Share this post


Link to post
Share on other sites

You probably have the same issue as this thread:

Basically the 'fix' is reboot your computer, try again.

I find that starting EL from the server chooser is often better as well (and you can easily open multiple clients that way). Try using it instead.

 

Share this post


Link to post
Share on other sites
Guest Cody

Thank you for the quick response, unfortunately this is not quite the same problem. I've tried restarting with no results. Also I've tried opening with the server chooser and this is the window I get:5bff5c24ed035_ScreenShot2018-11-28at7_22_26PM.thumb.png.ae9befd21f3bf909d7e0c9cd1a08829d.png

 

(when I click the eternal lands application icon, my whole screen goes black for a second as if it was starting, then it goes away. I thought maybe it was an issue with the resolution so I changed the setting in the file to 0 or 1 (whichever was not full screen), but it didn't help either.

 

 

 

 

Edited by Ben
Removed image duplicates (for readability!)

Share this post


Link to post
Share on other sites

Ouchu... problem is above my paygrade, sorry.

Seems like you're missing a file somewhere (not sure how)... but that file-path seems like gobbledigook so, I'm not sure what to tell you.

Share this post


Link to post
Share on other sites
Guest Cody

Hmm.. Well I've re installed a couple times just to see if it was something I've done and heres what I do; install the file, unzip it to the desktop, move the application to the applications folder, then try to open. Maybe I'm missing something?

Share this post


Link to post
Share on other sites

I moved the entire folder into applications, though I don't see why dragging only the app would make a difference.

You've probably tried already but... Try extracting/unzipping directly into application folder, or not moving it after unzip?

Share this post


Link to post
Share on other sites

Cody, is the error you get when attempting to launch the game directly (EternalLands.app) the same as the error you get when attempting to launch via the server chooser app? If not, could you perhaps post/pastebin it for us? The errors you've posted so far all reference the server chooser app :)

Edited by Ben

Share this post


Link to post
Share on other sites
Guest Cody

Thanks all the replies I hope we can figure out a solution! I'm happily surprised that this is an active forum. 

 

Diealot I just tried downloading and extracting straight from the applications folder, same result.

 

Ben when I attempt to launch the game directly I don't get an error message, my screen goes black as if it's starting then disappears, that's it. It almost seems to me like its a resolution issue that causes a crash?

 

For some reason the image I posted here posted three times but I believe it was just one error message I uploaded, and that is the one I get when trying the server chooser app.5c05503ed242e_ScreenShot2018-12-03at7_47_48AM.png.4bf324ffd87437290f5d341df5ea063e.png5c0550444e2bb_ScreenShot2018-12-03at7_47_54AM.png.d0ffa6bd4d624d91e3e4e8c122bf1d70.png

 

 

Edited by Ben
Removed image duplicates (for readability!)

Share this post


Link to post
Share on other sites

Cody, are you familiar with the terminal? If so, could you please enter the following two commands and post/pastebin the output:

cd /Applications/EternalLands.app/Contents/MacOS/
./EternalLands

Edit: I should probably specify that the first command will change your active directory to the one containing the game executable, and the second one will execute it directly. :)

Edited by Ben

Share this post


Link to post
Share on other sites
Guest Cody

Hi Ben, here is the result from those two:

 

Last login: Mon Dec  3 09:53:37 on ttys000

Codys-MacBook-Pro:~ codydobbs$ cd /Applications/EternalLands.app/Contents/MacOS/

Codys-MacBook-Pro:MacOS codydobbs$ 

Codys-MacBook-Pro:MacOS codydobbs$ ./EternalLands

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'

Codys-MacBook-Pro:MacOS codydobbs$ 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Nothing unexpected there (I have the same output on both of my machines, at least).

 

When you attempt to launch the game directly (either via the method above or by clicking the EternalLands app within launchpad) do you happen to have any "EternalLands quit unexpectedly" messages pop up? If so, could you post or pastebin the accompanying problem report? :)

Edited by Ben

Share this post


Link to post
Share on other sites
Guest Cody

Unfortunately when I attempt to launch the game either way, I don't get any messages, my screen just goes black for a second then it goes away /:

 

 

 

Share this post


Link to post
Share on other sites

Not to worry!

 

Could you please try to start the game once again (using the method I gave above) and then pastebin the contents of the following file:

~/Library/Application Support/Eternal Lands/log/main_<random>.log

The file will have a small number of random characters, but there should only be one starting "main_".

Share this post


Link to post
Share on other sites
Guest Cody

I think I know what you mean, do you mean to open the terminal and paste all three of those? If so here is the result:

 

Last login: Mon Dec  3 09:54:55 on ttys000

Codys-MacBook-Pro:~ codydobbs$ cd /Applications/EternalLands.app/Contents/MacOS/

Codys-MacBook-Pro:MacOS codydobbs$ ./EternalLands

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Common/ChunkCompression.cpp:49: Error: unsupported compressor 8

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.200.3/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'

Codys-MacBook-Pro:MacOS codydobbs$ ~/Library/Application Support/Eternal Lands/log/main_<random>.log

-bash: random: No such file or directory

Codys-MacBook-Pro:MacOS codydobbs$ 

 

If you mean you'd like to see the contents of a certain EL file, im not sure where to find that, when I "show contents" of the application, here is what I can see:5c0588348e3ee_ScreenShot2018-12-03at11_46_09AM.thumb.png.f7aba7ff574012560f8292e3f764037c.png

 

Edited by Ben
Removed image duplicates

Share this post


Link to post
Share on other sites

Looks like we've got this solved, the config had adopted incorrect display settings leading to a OpenGL error on launch:

Error: Couldn't set GL mode: Failed to find display resolution: 1680x1050x32

Solution was to modify el.ini (located in ~/Library/Application Support/Eternal Lands/main/) to manually disable #full_screen and reduce #video_mode to a more reasonable resolution.

#video_mode= 6
#full_screen= 0

 

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×