Jump to content
Eternal Lands Official Forums
Aislinn

F2 Browser Malfunction

Recommended Posts

I have been trying to get F2 to launch chromium.  Nothing happens.  Firefox works fine, both if I type Firefox into the Options Server Browser box directly from in-game, and if I edit el.ini.  However, nothing happens with chromium.  I have tried chromium, chromium-browser, /usr/bin/chromium both entering those ingame and via el.ini.  I run Arch Linux.

 

Also a guildie runs Mac and is also having trouble with his client always launching Safari no matter what other browser he enters in both places.  

 

Also of note, if I run chromium via a terminal as $ chromium, it launches chromium just fine.

 

Is there a trick we're missing or is the Browser function broken?

Share this post


Link to post
Share on other sites
You could try to set the x-www-browser flag.
not sure how to do it in arch linux in Debian based systems its like this.
update-alternatives --config x-www-browser 

at least el understands x-www-browser in the config file

Share this post


Link to post
Share on other sites

I changed the setting from the options window to "chromium-browser" which worked fine and immediately for me.  This is on Ubuntu 18.04.  I'll give my arch install when I have time (I have to change disks on an old laptop).  On Linux at least, If you have x-www-browser set like vinoveritas says, then you can use x-www-browser in the client setting.  You can also use xdg-open to open your default browser.

Edited by bluap

Share this post


Link to post
Share on other sites

I am starting to suspect it's something wrong with my setup and not the client.  xdg-open did not work. I also tried adding export BROWSER=/usr/bin/chromium to my .bashrc and that did nothing.  I don't think Arch has the update-alternatives --config x-www-browser function.

Share this post


Link to post
Share on other sites

I've just tried on Arch and I can switch between the in-client settings of firefox and chromium and both work just fine.  Which build of the client are you using?

Share this post


Link to post
Share on other sites

I compile my own and I just compiled on Sept. 9.  I've had this problem forever, though. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×