Jump to content
Eternal Lands Official Forums
Zenial

Settings won't save

Recommended Posts

Hi guys,

 

PC info:

Windows 10 64 bit

Eternal Lands Version 1.9.4

I had EL working fine for a while, I'm not sure what caused it but my setting changes in View Options and side Spell Bar won't hold when reopening the client on any character.

 

Chat log and quest log are updating to:

C:\Users\citzy990\Documents\Eternal Lands\main

but the other files in there have stopped updating as of 08/01/2017 including el.cfg and el.ini

 

When this first happened my initial effort was to reinstall EL (as animation program is set to be on by default and makes all characters one solid colour (found that setting by fiddling).

 

Thanks in advance for your help.

 

-Zenial

Share this post


Link to post
Share on other sites

I know essentially nothing about Windows, but...

 

Try renaming the el.cfg and el.ini files to something else. When you start the client after that it should force the client to create new files with the default settings. And if it can create them, it can change them.

 

That'll mean changing your settings again, of course.

 

 

(I can't begin to guess why the current files aren't updating though, don't know how Win permissions work.)

Share this post


Link to post
Share on other sites

Something must have changed on your computer, as files that were updated correctly until the 8th, stopped being updated.

That kind of thing doesn't happen spontanously, so you would have to check what changed on your machine: Windows updates, new programs installed, playing with permissions (yours, or El's, if that's possible),...?

 

What makes it very strange is that chat_logs and such are updated. That excludes a change of the directory permissions to 'read-only'.

Any chance you got the el.ini and el.cfg files marked 'readonly'?

Share this post


Link to post
Share on other sites

These might seem obvious, but:

1. Run a scandisk-type utility to make sure that your disk isn't scrogged.

2. Make sure that your disk isn't full.

Share this post


Link to post
Share on other sites

HI all,

 

Thanks for the replies.

 

Removing the old files worked. The client produced new files and are updating normally. Thanks Burn.

 

They weren't read only and the disk wasn't full.

 

The Event Viewer has listed a tone of errors for 08/01/2017 for Service Control Manager and DistributedCOM. I can't find anything directly related to EL...

 

-Zenial

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×