Jump to content
Eternal Lands Official Forums
Guest mkzal

crashed at startup by not found el.ini file

Recommended Posts

Guest mkzal

hi, i've never played EL before, because of this dialogue wen I start:


Oh my, Eternal Lands Crashed - Don't Panic!

A few of things you can try:
1) Make sure your system is up to date, especially your video drivers.
2) If the client crashes repeatedly, try changing some settings. Either by directly modifying the configuration file (e.g. gedit ~/.elc/main/el.ini). Or clicking the settings button window at the login screen.
i) Enable the "Poor Man" option in the "Details" tab of the setting window. Or edit the configuration file and set "#poor_man=1".
ii) Disable the "Use animation program" option in the "Adv Video" tab of the setting window. Or edit the configuration file and set "#use_animation_program=0".

If you continue to have problems check the Eternal Lands forums, especially the "Help Me" and "Bug Report" sections. If you post a message make sure you include information about your system; i.e video driver and version, operating system and version. Make sure you check your error log for clues too and include the contents in any forum report.

This information about your graphic hardware and software may help.
Output from "lspci | grep -i vga":
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Output from "glxinfo | head -5":


The following is your error log contents. Note it is overwritten each time you run the game.

[03:51:47, engine/logging.cpp:310] Log started at: Wed May 14 03:51:47 2014 CLT
[03:51:47, engine/logging.cpp:313] version: 1.9.3
[03:51:47, elconfig.c:2270] Error: Error: Can't open file "el.ini": No such file or directory
[03:51:47, init.c:236] Error: Failure reading el.ini

This was the program output: Note it is overwritten each time you run the game.

Failure reading el.ini

A search through dmesg output:



Share this post


Link to post
Share on other sites
Guest mkzal

oh well, the file el.ini exists in usr/share/game/EternalLands
but when I go to edit, it is not posible

Share this post


Link to post
Share on other sites

Better copy that version of the .ini to your data directory first (.elc/main would be the standard location iirc), then you should be able to edit it

Share this post


Link to post
Share on other sites

 

Strange, you are clealy using the lacher from my Ubuntu/Debian packages which work very hard to make sure you have a valid el.ini file in place. mkzal, are you using Ubuntu 14.04 by chance as that has a broken version of zenity, the application used for laucher GUI. What does the output from "ls -l $HOME/.elc/" produce froma terminal?

 

Share this post


Link to post
Share on other sites
Guest sedrosken

I am running Kubuntu 14.04 and I am having this issue. Here is the output of "ls -l $HOME/.elc/":

 

sedrosken@sedrosken-aspire-5735z:~$ ls -l $HOME/.elc/

total 36
drwxrwx--- 2 sedrosken sedrosken 4096 Jul 23 10:23 log
drwxrwxr-x 2 sedrosken sedrosken 4096 Jul 23 09:26 lrnr-main|lrnr-main
drwxrwx--- 2 sedrosken sedrosken 4096 Jul 23 09:28 main
drwxrwxr-x 2 sedrosken sedrosken 4096 Jul 23 09:28 main|main
drwxrwxr-x 2 sedrosken sedrosken 4096 Jul 23 09:38 official|official
-rw-rw-r-- 1 sedrosken sedrosken 736 Mar 29 2010 servers.lst
-rw-rw-r-- 1 sedrosken sedrosken 4 Jul 23 09:13 showconfigsel
-rw-rw-r-- 1 sedrosken sedrosken 1874 Jul 23 10:23 terminal_log.txt
drwxrwxr-x 2 sedrosken sedrosken 4096 Jul 23 09:30 test|test


 

Share this post


Link to post
Share on other sites

I've added workarounds to the zenity bugs in the development version of the client. Either install that version of the package following the instructions here, or just replace the current launcher with the dev version, it will work fine. Something like this should to it:

wget -O /tmp/eternallands https://raw.githubusercontent.com/raduprv/Eternal-Lands/master/pkgfiles/eternallands
sudo mv /usr/games/eternallands /usr/games/eternallands.orig
sudo mv /tmp/eternallands /usr/games/eternallands
sudo chown root:root /usr/games/eternallands
sudo chmod a+rx /usr/games/eternallands

When you're happy its fixed, you can remove the old version:

sudo rm /usr/games/eternallands.orig

Share this post


Link to post
Share on other sites
Guest DerLinke

after i installed the game with the ppa found on webupd8.org i found a emty el.ini

 

/dev/fd/15/dev/fd/15/dev/fd/21/dev/fd/21/dev/fd/21/dev/fd/21/dev/fd/21/dev/fd/21/dev/fd/21/dev/fd/21/dev/fd/21/dev/fd/21/dev/fd/21/usr/share/games/EternalLands/el.ini

 

thanks bluap, for your help

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×