Jump to content
Eternal Lands Official Forums
Sign in to follow this  
Guest Generic_User

Instal-crash

Recommended Posts

Guest Generic_User

I do:

 

chmod

then try to run 32 bit binary

Installer looks like it goes thru till the end

 

and in terminal i get:

el.x86.linux.bin: textures.c:536: load_texture: Assertion `id != 0' failed.

 

hope someone knows a solution

Share this post


Link to post
Share on other sites

A bit more information about your system might be nice (OS, version, 32 or 64 bit, graphics card and driver)

Also, was the line you posted all you got in console?

Share this post


Link to post
Share on other sites
Guest Generic_User

i tried to give the information (made account ... but cannot post cause admin is too slow ... )

 

System:

 

Linux Mint Debian (for nearly all concerns its debian)

Radeon Driver

Card: R4350

 

and its 32 bit (thats why i tried the 32bit install)

 

 

The line was all i got from console

Share this post


Link to post
Share on other sites

i tried to give the information (made account ... but cannot post cause admin is too slow ... )

 

System:

 

Linux Mint Debian (for nearly all concerns its debian)

Radeon Driver

Card: R4350

 

and its 32 bit (thats why i tried the 32bit install)

 

 

The line was all i got from console

 

OK. Then we'll have to start digging deeper...

There should be a file logging errors in your 'main' directory. It could help if you post the last 10-15 lines of that.

Perhaps Korrode knows the name of the file?

 

Edit: digging through the client source makes me suspect that either your driver claims to support an openGL extension that is not supported, or your graphics driver is not up-to-date (try get one from the card maker's web site, not from your distribution)

 

(See here, for instance: http://support.amd.com/us/gpudownload/Pages/index.aspx )

Edited by revi

Share this post


Link to post
Share on other sites
Guest Generic_User

I cannot find any logging errors and my graphics is up to date (still no ati/amd driver because card is not supportet --> radeon driver)

Share this post


Link to post
Share on other sites

i tried to give the information (made account ... but cannot post cause admin is too slow ...)

Hmm yeah, that account name didn't scream "serious user" to me so I wasn't exactly rushing to approve it. You can still post information here, but I do suggest you make a real account with what might be your ingame name.

Share this post


Link to post
Share on other sites

I cannot find any logging errors and my graphics is up to date (still no ati/amd driver because card is not supportet --> radeon driver)

Try looking in the directory you installed .elc in for your error log (mine happens to be in /home/sb/.elc)

It will look like this: /home/sb/.elc/log/main_xxxxx.log (where xxxxx is a combination of numbers and letters). Post what is in that file.

Share this post


Link to post
Share on other sites

Please check to see if there are files called chat_log.txt and/or errorlog.txt in ~/.elc/main or ~/.elc/log/main. (I'm not sure of the exact names as I'm at work atm)

 

These files may contain clues relating to the problem.

Edited by EaglePrince

Share this post


Link to post
Share on other sites
Guest Generic_User

hier die main_...log :

[19:00:01, engine/logging.cpp:301] Log started at: Sun Sep 25 19:00:01 2011 CEST
[19:00:01, engine/logging.cpp:304] version: 1.9.2
[19:00:01, elconfig.c:1460] Error: Can't find var 'server_address = game.eternal-lands.com

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'server_port = 2001

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_vertex_array = 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_mipmaps = 0

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'text_filter_replace = smeg

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'compass_north = 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'near_plane= 0.1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'transparency_resolution_fix= 0

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'dim_sounds_on_rain= 0

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'anisotropic_filter= 2

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'render_skeleton= 0

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'render_mesh= 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_display_actors= 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_actor_bbox_check= 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_render_mesh_shader= 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_set_transformation_buffers= 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_build_actor_bounding_box= 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_model_attach_and_detach_mesh= 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_render_attached_meshs= 1

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'use_ext_gpu_program_parameters= 0

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'skybox_update_every_frame= 0

', type 2
[19:00:01, elconfig.c:1460] Error: Can't find var 'seconds_between_shadows_updates= 10

', type 2
[19:00:02, io/elfilewrapper.c:294] Error: Can't load zip file /home/orkiel/.elc/custom_clothes.zip
[19:00:02, io/elfilewrapper.c:294] Error: Can't load zip file /home/orkiel/.elc/unofficial_custom_clothes.zip
[19:00:02, sound.c:4789] Error: Warning: Points defined for default boundary. Points will be ignored.
[19:00:03]Last message repeated 14times
[19:00:03, textures.c:291] Error: Can't use s3tc compressed texture format, because GL_EXT_texture_compression_s3tc is not supported.

 

and why cant i choose my own username ?

as you can see here i aḿ a human

and i want to use it ....

 

i have atm no idea what i am going to play... so no name idea

Share this post


Link to post
Share on other sites

Do you have the "non-free" section of the Debian repository enabled?

Check that it is and then ensure you have the firmware-linux-nonfree package installed.

If it wasn't installed, install it, reboot, and try again.

Share this post


Link to post
Share on other sites
Guest Generic_User

non-free is active and firmware too

 

chat_log.txt:

Log started at 2011-09-22 13:08:30 localtime (CEST)

[13:08:30] Window size adjusted to 1014x713
[13:08:30] GL_ARB_multitexture extension found, using it.
[13:08:30] GL_ARB_texture_env_combine extension found, using it.
[13:08:30] GL_EXT_compiled_vertex_array extension found, using it.
[13:08:30] GL_ARB_point_sprite extension found, using it.
[13:08:30] GL_ARB_texture_compression extension found, using it.
[13:08:30] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...
[13:08:30] GL_SGIS_generate_mipmap extension found, using it.
[13:08:30] GL_ARB_shadow extension found, using it.
[13:08:30] GL_ARB_vertex_buffer_object extension found, using it.
[13:08:30] GL_EXT_framebuffer_object extension found, using it.
[13:08:30] GL_EXT_draw_range_elements extension found, using it.
[13:08:30] GL_ARB_texture_non_power_of_two extension found, using it.
[13:08:30] GL_ARB_fragment_program extension found, using it.
[13:08:30] GL_ARB_vertex_program extension found, using it.
[13:08:30] GL_ARB_fragment_shader extension found, using it.
[13:08:30] GL_ARB_vertex_shader extension found, using it.
[13:08:30] GL_ARB_shader_objects extension found, using it.
[13:08:30] GL_ARB_shading_language_100 extension found, using it.
[13:08:30] GL_ARB_texture_mirrored_repeat extension found, NOT using it...
[13:08:30] GL_ARB_texture_rectangle extension found, NOT using it...
[13:08:30] GL_EXT_fog_coord extension found, NOT using it...
[13:08:30] GL_ATI_texture_compression_3dc extension found, using it.
[13:08:30] GL_EXT_texture_compression_latc extension found, using it.
[13:08:30] GL_EXT_texture_filter_anisotropic extension found, using it.
[13:08:30] Not using vertex program for actor animation.
[13:08:31] The location of the data files in use is ./
[13:08:31] Your personal settings and logs will be saved in /home/orkiel/.elc/main/

Share this post


Link to post
Share on other sites

I cannot find any logging errors and my graphics is up to date (still no ati/amd driver because card is not supportet --> radeon driver)

 

Did you check at the link I posted earlier?

From what I could see there was a driver for your card available (if indeed you have a radeon HD 4350 card).

You best bet at this stage is to download and install that driver.

 

(make sure to choose in order:

Desktop graphics

Radeon HD Series

Radeon HD 4xxx Series PCIe

Linux x86

 

Then click next to 'step 5' and download and install the proposed driver)

Share this post


Link to post
Share on other sites
Guest Generic_User
Did you check at the link I posted earlier?
I cannot find any logging errors and my graphics is up to date (still no ati/amd driver because card is not supportet --> radeon driver)

the driver from amd is really not supporting my card (you find all cards listed that get drivers but not all work for linux ....)

Share this post


Link to post
Share on other sites

From what I can see, your ATi chip is not old enough to be one of the legacy ones that AMD doesn't provide drivers for the current Xorg ABI, you should be able to use the proprietary fglrx driver.

 

You do in fact need to take steps to ensure your Xorg.conf is modified, see instructions here:

http://wiki.debian.org/ATIProprietary

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×