Jump to content
Eternal Lands Official Forums
Guest DDDNW

Eternal Lands crashes at startup UBUNTU 10.10

Recommended Posts

Guest DDDNW

Below is the error that i get when launching Eternal Lands

 

 

Oh my, Eternal Lands Crashed - Don't Panic!

 

A few of things you can try:

1) Make sure your system is up to date, especially your video drivers.

2) If the client crashes repeatedly, try changing some settings. Either by directly modifying the configuration file (e.g. gedit ~/.elc/main/el.ini). Or clicking the settings button window at the login screen.

i) Enable the "Poor Man" option in the "Details" tab of the setting window. Or edit the configuration file and set "#poor_man=1".

ii) Disable the "Use animation program" option in the "Adv Video" tab of the setting window. Or edit the configuration file and set "#use_animation_program=0".

iii) Disable the "Custom Looks Updates" option in the "Server" tab of the setting windows. Or edit the configuration file and set "#customupdate=0".

 

If you continue to have problems check the Eternal Lands forums, especially the "Help Me" and "Bug Report" sections. If you post a message make sure you include information about your system; i.e video driver and version, operating system and version. Make sure you check your error log for clues too and include the contents in any forum report.

 

This information about your graphic hardware and software may help.

Output from "lspci | grep -i vga":

01:00.0 VGA compatible controller: nVidia Corporation G84M [Quadro NVS 140M] (rev a1)

Output from "glxinfo | head -5":

name of display: :0.0

display: :0 screen: 0

direct rendering: Yes

server glx vendor string: SGI

server glx version string: 1.4

 

The following is your error log contents. Note it is overwritten each time you run the game.

 

 

 

Log started at 2011-04-21 20:56:30 localtime (EDT)

 

[20:56:30] Using the server profile: main

[20:56:30] Window size adjusted to 1014x713

[20:56:30] GL_ARB_multitexture extension found, using it.

[20:56:30] GL_EXT_compiled_vertex_array extension found, using it.

[20:56:30] GL_ARB_point_sprite extension found, using it.

[20:56:30] GL_ARB_texture_compression extension found, using it.

[20:56:30] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...

[20:56:30] GL_SGIS_generate_mipmap extension found, using it.

[20:56:30] GL_ARB_shadow extension found, using it.

[20:56:30] GL_ARB_vertex_buffer_object extension found, using it.

[20:56:30] GL_EXT_framebuffer_object extension found, using it.

[20:56:30] GL_EXT_draw_range_elements extension found, using it.

[20:56:30] GL_ARB_texture_non_power_of_two extension found, using it.

[20:56:30] GL_ARB_fragment_program extension found, using it.

[20:56:30] GL_ARB_vertex_program extension found, using it.

[20:56:30] GL_ARB_fragment_shader extension found, using it.

[20:56:30] GL_ARB_vertex_shader extension found, using it.

[20:56:30] GL_ARB_shader_objects extension found, using it.

[20:56:30] GL_ARB_shading_language_100 extension found, using it.

[20:56:30] GL_ARB_texture_mirrored_repeat extension found, NOT using it...

[20:56:30] GL_ARB_texture_rectangle extension found, NOT using it...

[20:56:30] GL_EXT_fog_coord extension found, NOT using it...

[20:56:30] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...

[20:56:30] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...

 

This was the program output: Note it is overwritten each time you run the game.

Share this post


Link to post
Share on other sites

A few of things you can try:

1) Make sure your system is up to date, especially your video drivers.

2) If the client crashes repeatedly, try changing some settings. Either by directly modifying the configuration file (e.g. gedit ~/.elc/main/el.ini). Or clicking the settings button window at the login screen.

i) Enable the "Poor Man" option in the "Details" tab of the setting window. Or edit the configuration file and set "#poor_man=1".

ii) Disable the "Use animation program" option in the "Adv Video" tab of the setting window. Or edit the configuration file and set "#use_animation_program=0".

iii) Disable the "Custom Looks Updates" option in the "Server" tab of the setting windows. Or edit the configuration file and set "#customupdate=0".

Did you try the suggestions above?

Share this post


Link to post
Share on other sites
Guest Roland

I'm having the same issue the poster listed, although I am unable to process any of the suggestions due to not being able to find any of the game files. I used the tutorial provided by the Ubuntu site, it did everything automatically pretty much. Here is my feedback:

 

 

-------------------------------------

 

 

 

Oh my, Eternal Lands Crashed - Don't Panic!

 

A few of things you can try:

1) Make sure your system is up to date, especially your video drivers.

2) If the client crashes repeatedly, try changing some settings. Either by directly modifying the configuration file (e.g. gedit ~/.elc/main/el.ini). Or clicking the settings button window at the login screen.

i) Enable the "Poor Man" option in the "Details" tab of the setting window. Or edit the configuration file and set "#poor_man=1".

ii) Disable the "Use animation program" option in the "Adv Video" tab of the setting window. Or edit the configuration file and set "#use_animation_program=0".

iii) Disable the "Custom Looks Updates" option in the "Server" tab of the setting windows. Or edit the configuration file and set "#customupdate=0".

 

If you continue to have problems check the Eternal Lands forums, especially the "Help Me" and "Bug Report" sections. If you post a message make sure you include information about your system; i.e video driver and version, operating system and version. Make sure you check your error log for clues too and include the contents in any forum report.

 

This information about your graphic hardware and software may help.

Output from "lspci | grep -i vga":

01:00.0 VGA compatible controller: ATI Technologies Inc RV530 [Radeon X1600]

Output from "glxinfo | head -5":

name of display: :0.0

display: :0 screen: 0

direct rendering: Yes

server glx vendor string: SGI

server glx version string: 1.4

 

The following is your error log contents. Note it is overwritten each time you run the game.

 

 

 

This was the program output: Note it is overwritten each time you run the game.

Share this post


Link to post
Share on other sites
I am unable to process any of the suggestions due to not being able to find any of the game files.

If the EL client isn't getting to the stage where it creates ~/.elc/main/el.ini, then you want to look for el.ini where the system-wide games files are stored. I don't run Ubuntu so cannot double check exactly where that is, but it's probably /usr/share/eternallands/... or something similar, definitely in /usr/ somewhere ;p

Edited by Korrode

Share this post


Link to post
Share on other sites

The launcher (which you are both clearly using) creates the configuration directory and copies the default el.ini (and a servers file) into the correct places. The file you need to edit is in the place Korrode said "~/.elc/main/el.ini". Either use your file manager to browse to the directory and open the file or open the file directly from a terminal using a command like "gedit ~/.elc/main/el.ini". Any text editor (gedit for example here) can be used.

Edited by bluap

Share this post


Link to post
Share on other sites
Guest Roland

The launcher (which you are both clearly using) creates the configuration directory and copies the default el.ini (and a servers file) into the correct places. The file you need to edit is in the place Korrode said "~/.elc/main/el.ini". Either use your file manager to browse to the directory and open the file or open the file directly from a terminal using a command like "gedit ~/.elc/main/el.ini". Any text editor (gedit for example here) can be used.

 

I finally found the file under /usr/share/games/EternalLands/ and edited the el.ini file as suggested, but still no luck getting the game to launch. It persists with the same crash report. :(

Share this post


Link to post
Share on other sites

As I said, that's not the file to edit. The first time you run the clint launcher, that file is copied into the correct place. You MUST edit the copy located here "~/.elc/main/el.ini". This can be done from a file manager but its easier to explain step using the command line.

 

As your normal user:

1) Open a terminal from the gnome menu using Applications->Accessories->Terminal.

2) Type this command at the terminal prompt "cd ~/.elc/main" without the quotes and then press return/enter.

3) Now edit the file with this command "gedit el.ini", again without the quotes and then press return/enter.

Share this post


Link to post
Share on other sites
Guest Roland

As I said, that's not the file to edit. The first time you run the clint launcher, that file is copied into the correct place. You MUST edit the copy located here "~/.elc/main/el.ini". This can be done from a file manager but its easier to explain step using the command line.

 

As your normal user:

1) Open a terminal from the gnome menu using Applications->Accessories->Terminal.

2) Type this command at the terminal prompt "cd ~/.elc/main" without the quotes and then press return/enter.

3) Now edit the file with this command "gedit el.ini", again without the quotes and then press return/enter.

 

Oh, I'm sorry. I did not read that correctly. I will try that. :)

Share this post


Link to post
Share on other sites
Guest Roland

Okay, I tried that command in terminal and it tells me permission denied. Then, when I switch to root or use the sudo command it tells me "command not found."

 

 

user@user-desktop:~$ cd ~/.elc/main

bash: cd: /home/user/.elc/main: Permission denied

user@user-desktop:~$ sudo cd ~/.elc/main

sudo: cd: command not found

user@user-desktop:~$

 

Any suggestions on what the issue is here? Am I typing it incorrectly?

Share this post


Link to post
Share on other sites

Apart from the initial package install, you should never need to do anything with EL as the root/admin user. If you do not have permissions on the ~/.elc directory then I suspect you have tried to run the client as the root/admin user. You never need to do that!

 

To fix the permissions do this from a terminal prompt:

 

sudo chown -R user:user /home/user/

Share this post


Link to post
Share on other sites
Guest Roland

Apart from the initial package install, you should never need to do anything with EL as the root/admin user. If you do not have permissions on the ~/.elc directory then I suspect you have tried to run the client as the root/admin user. You never need to do that!

 

To fix the permissions do this from a terminal prompt:

 

sudo chown -R user:user /home/user/

 

It says permission is denied. Oh great. :(

Share this post


Link to post
Share on other sites
Guest Roland

Okay, I reinstalled so the permissions are initially set correctly. I edited the .ini file under the correct directory. Now it launches, but the screen is black. And then it freezes. No error prompt, but obviously there's an error somewhere. lol

Share this post


Link to post
Share on other sites
Guest Roland

Okay, I reinstalled so the permissions are initially set correctly. I edited the .ini file under the correct directory. Now it launches, but the screen is black. And then it freezes. No error prompt, but obviously there's an error somewhere. lol

 

 

https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver#Problem:%20%20Need%20to%20fully%20remove%20-fglrx%20and%20reinstall%20-ati%20from%20scratch

 

I went here and installed the software and my video card seems to be running fine now. Thanks everyone!

Share this post


Link to post
Share on other sites
Guest Shiyiya

Also running 10.10, also getting crash on startup. I tried changing all the settings it suggests, no change. (Oddly, gedit said it didn't recognize the character encoding in the file, so I had to use vim to edit.)

 

This information about your graphic hardware and software may help.

Output from "lspci | grep -i vga":

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Output from "glxinfo | head -5":

name of display: :0.0

display: :0 screen: 0

direct rendering: Yes

server glx vendor string: SGI

server glx version string: 1.4

 

The following is your error log contents. Note it is overwritten each time you run the game.

 

 

 

Log started at 2011-04-30 12:45:05 localtime (MST)

 

[12:45:05] Using the server profile: main

[12:45:05] Window size adjusted to 1014x713

[12:45:05] GL_ARB_multitexture extension found, using it.

[12:45:05] GL_EXT_compiled_vertex_array extension found, using it.

[12:45:05] GL_ARB_point_sprite extension found, using it.

[12:45:05] GL_ARB_texture_compression extension found, using it.

[12:45:05] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...

[12:45:05] GL_SGIS_generate_mipmap extension found, using it.

[12:45:05] GL_ARB_shadow extension found, using it.

[12:45:05] GL_ARB_vertex_buffer_object extension found, using it.

[12:45:05] GL_EXT_framebuffer_object extension found, using it.

[12:45:05] GL_EXT_draw_range_elements extension found, using it.

[12:45:05] GL_ARB_texture_non_power_of_two extension found, using it.

[12:45:05] GL_ARB_fragment_program extension found, using it.

[12:45:05] GL_ARB_vertex_program extension found, using it.

[12:45:05] GL_ARB_fragment_shader extension found, using it.

[12:45:05] GL_ARB_vertex_shader extension found, using it.

[12:45:05] GL_ARB_shader_objects extension found, using it.

[12:45:05] GL_ARB_shading_language_100 extension found, using it.

[12:45:05] GL_ARB_texture_mirrored_repeat extension found, NOT using it...

[12:45:05] GL_ARB_texture_rectangle extension found, NOT using it...

[12:45:05] GL_EXT_fog_coord extension found, NOT using it...

[12:45:05] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...

[12:45:05] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...

 

This was the program output: Note it is overwritten each time you run the game.

 

Also, running in terminal, it tells me this:

 

shiyiya@Meliai:~$ eternallands

/usr/games/eternallands: line 170: 28231 Segmentation fault $el_client $config $* &>~/.elc/terminal_log.txt

 

shiyiya@Meliai:~$

Share this post


Link to post
Share on other sites

One more thing to try would be to disable shaders:

sudo mv /usr/share/games/EternalLands/shaders /usr/share/games/EternalLands/shaders.move

To put them back again use:

sudo mv /usr/share/games/EternalLands/shaders.move /usr/share/games/EternalLands/shaders

 

If that does not work and you're up for a bit of code building and further debugging let us know.

Edited by bluap

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×