Jump to content
Eternal Lands Official Forums
Sign in to follow this  
Aislinn

Arch Segmentation fault

Recommended Posts

Ok, I have fussed with this for 2 days.

I am trying to get EL running on Archbang. Apparently, I do get ingame but immediately crash after. I have already tried the shaders fix, poorman, and disabling everything I could think of. Various logs:

 

How I run EL:

[archlette@archbang ~]$ cd /home/archlette/el_linux
[archlette@archbang el_linux]$ ./el.x86.linux.bin
I/O warning : failed to load external entity "sound/sound_config.xml"
Segmentation fault
[archlette@archbang el_linux]$

 

Graphics card:

[archlette@archbang ~]$ lspci | grep "VGA"
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
[archlette@archbang ~]$

 

Drivers: nouveau-drm, nouveau-firmware, and xf86-video-nouveau

xorg.conf:

Section "Device"
    Identifier "n"
    Driver "nouveau"
EndSection

 

Error Log:

Log started at 2011-03-06 19:01:07 localtime (EST)

[19:01:07] Using the server profile: main
[19:01:07] Window size adjusted to 1014x713
[19:01:08] GL_ARB_multitexture extension found, using it.
[19:01:08] GL_EXT_compiled_vertex_array extension found, using it.
[19:01:08] GL_ARB_point_sprite extension found, using it.
[19:01:08] GL_ARB_texture_compression extension found, using it.
[19:01:08] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...
[19:01:08] GL_SGIS_generate_mipmap extension found, using it.
[19:01:08] Couldn't find the GL_ARB_shadow extension, not using it...
[19:01:08] GL_ARB_vertex_buffer_object extension found, using it.
[19:01:08] GL_EXT_framebuffer_object extension found, using it.
[19:01:08] GL_EXT_draw_range_elements extension found, using it.
[19:01:08] Couldn't find the GL_ARB_texture_non_power_of_two extension, not using it...
[19:01:08] Couldn't find the GL_ARB_fragment_program extension, not using it...
[19:01:08] Couldn't find the GL_ARB_vertex_program extension, not using it...
[19:01:08] Couldn't find the GL_ARB_fragment_shader extension, not using it...
[19:01:08] Couldn't find the GL_ARB_vertex_shader extension, not using it...
[19:01:08] Couldn't find the GL_ARB_shader_objects extension, not using it...
[19:01:08] Couldn't find the GL_ARB_shading_language_100 extension, not using it...
[19:01:08] GL_ARB_texture_mirrored_repeat extension found, NOT using it...
[19:01:08] GL_ARB_texture_rectangle extension found, NOT using it...
[19:01:08] GL_EXT_fog_coord extension found, NOT using it...
[19:01:08] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...
[19:01:08] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...
[19:01:08] Error opening sound configuration file
[19:01:13] * server www.eternal-lands.com filename http://www.eternal-lands.com/updates191/files.lst
[19:01:13] Downloading http://www.eternal-lands.com/updates191/files.lst from www.eternal-lands.com
[19:01:13] Error: Can't open file "alias.ini"
[19:01:14] Finished downloading http://www.eternal-lands.com/updates191/files.lst
[19:01:14] * server www.eternal-lands.com filename http://www.eternal-lands.com/updates191/files.lst
[19:01:14] Downloading http://www.eternal-lands.com/updates191/files.lst from www.eternal-lands.com
[19:01:14] Finished downloading http://www.eternal-lands.com/updates191/files.lst
[19:01:15] * server www.eternal-lands.com filename http://www.eternal-lands.com/updates191/files.lst
[19:01:15] Downloading http://www.eternal-lands.com/updates191/files.lst from www.eternal-lands.com
[19:01:15] Finished downloading http://www.eternal-lands.com/updates191/files.lst
[19:01:16] Failed to download (files.lst) 3 times. Giving up.
[19:01:16] Language changed, was [en] now [en]
[19:02:42] load_quickspells() read failed for [spells_aislinn.dat] 
[19:02:42] load_recipes() read failed for file [recipes_aislinn.dat]

 

Chat log from my multiple attempts: You can see my buddylist load up and some chat before I crash.

Log started at 2011-03-06 16:11:29 localtime (EST)

[16:11:29] Window size adjusted to 1014x713
[16:11:29] GL_ARB_multitexture extension found, using it.
[16:11:29] GL_ARB_texture_env_combine extension found, using it.
[16:11:29] GL_EXT_compiled_vertex_array extension found, using it.
[16:11:29] GL_ARB_point_sprite extension found, using it.
[16:11:29] GL_ARB_texture_compression extension found, using it.
[16:11:29] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...
[16:11:29] GL_SGIS_generate_mipmap extension found, using it.
[16:11:29] Couldn't find the GL_ARB_shadow extension, not using it...
[16:11:29] GL_ARB_vertex_buffer_object extension found, using it.
[16:11:29] GL_EXT_framebuffer_object extension found, using it.
[16:11:29] GL_EXT_draw_range_elements extension found, using it.
[16:11:29] Couldn't find the GL_ARB_texture_non_power_of_two extension, not using it...
[16:11:29] Couldn't find the GL_ARB_fragment_program extension, not using it...
[16:11:29] Couldn't find the GL_ARB_vertex_program extension, not using it...
[16:11:29] Couldn't find the GL_ARB_fragment_shader extension, not using it...
[16:11:29] Couldn't find the GL_ARB_vertex_shader extension, not using it...
[16:11:29] Couldn't find the GL_ARB_shader_objects extension, not using it...
[16:11:29] Couldn't find the GL_ARB_shading_language_100 extension, not using it...
[16:11:29] GL_ARB_texture_mirrored_repeat extension found, NOT using it...
[16:11:29] GL_ARB_texture_rectangle extension found, NOT using it...
[16:11:29] GL_EXT_fog_coord extension found, NOT using it...
[16:11:29] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...
[16:11:29] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...
[16:11:30] Shadowmapping disabled (need newer hardware)
[16:11:30] Not using vertex program for actor animation.
[16:11:30] Error opening sound configuration file
[16:11:32] The location of the data files in use is /home/archlette/el_linux/
[16:11:32] Your personal settings and logs will be saved in /home/archlette/.elc/main/
[16:12:11] Connecting to Server...
[16:12:11] Hi, and welcome to Eternal Lands! If you're new to the game and need help, please read the newbie helper guides on the main website. If you would rather learn by doing, talk to the Tutorial NPC, which is at the start point. In addition to that, you can type #help_me and your question to get a live response if there are helpers online. Click on the screen to continue!

[16:14:12] Ika is online.
[16:14:12] Thyralax is online.
[16:14:12] Vanyel is online.


Log started at 2011-03-06 16:27:52 localtime (EST)

[16:27:52] Window size adjusted to 1014x713
[16:27:52] GL_ARB_multitexture extension found, using it.
[16:27:52] GL_ARB_texture_env_combine extension found, using it.
[16:27:52] GL_EXT_compiled_vertex_array extension found, using it.
[16:27:52] GL_ARB_point_sprite extension found, using it.
[16:27:52] GL_ARB_texture_compression extension found, using it.
[16:27:52] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...
[16:27:52] GL_SGIS_generate_mipmap extension found, using it.
[16:27:52] Couldn't find the GL_ARB_shadow extension, not using it...
[16:27:52] GL_ARB_vertex_buffer_object extension found, using it.
[16:27:52] GL_EXT_framebuffer_object extension found, using it.
[16:27:52] GL_EXT_draw_range_elements extension found, using it.
[16:27:52] Couldn't find the GL_ARB_texture_non_power_of_two extension, not using it...
[16:27:52] Couldn't find the GL_ARB_fragment_program extension, not using it...
[16:27:52] Couldn't find the GL_ARB_vertex_program extension, not using it...
[16:27:52] Couldn't find the GL_ARB_fragment_shader extension, not using it...
[16:27:52] Couldn't find the GL_ARB_vertex_shader extension, not using it...
[16:27:52] Couldn't find the GL_ARB_shader_objects extension, not using it...
[16:27:52] Couldn't find the GL_ARB_shading_language_100 extension, not using it...
[16:27:52] GL_ARB_texture_mirrored_repeat extension found, NOT using it...
[16:27:52] GL_ARB_texture_rectangle extension found, NOT using it...
[16:27:52] GL_EXT_fog_coord extension found, NOT using it...
[16:27:52] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...
[16:27:52] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...
[16:27:53] Not using vertex program for actor animation.
[16:27:53] Error opening sound configuration file
[16:27:55] The location of the data files in use is /home/archlette/el_linux/
[16:27:55] Your personal settings and logs will be saved in /home/archlette/.elc/main/
[16:28:21] Connecting to Server...
[16:28:21] Hi, and welcome to Eternal Lands! If you're new to the game and need help, please read the newbie helper guides on the main website. If you would rather learn by doing, talk to the Tutorial NPC, which is at the start point. In addition to that, you can type #help_me and your question to get a live response if there are helpers online. Click on the screen to continue!

[16:28:33] Ika is online.
[16:28:33] Thyralax is online.
[16:28:33] Vanyel is online.
[16:28:40] #Mod Chat from Vanyel: lol: Felkku: nah it's just 3x top 20 and 3x top 100 


Log started at 2011-03-06 17:25:58 localtime (EST)

[17:25:58] Window size adjusted to 1014x713
[17:25:58] GL_ARB_multitexture extension found, using it.
[17:25:58] GL_ARB_texture_env_combine extension found, using it.
[17:25:58] GL_EXT_compiled_vertex_array extension found, using it.
[17:25:58] GL_ARB_point_sprite extension found, using it.
[17:25:58] GL_ARB_texture_compression extension found, using it.
[17:25:58] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...
[17:25:58] GL_SGIS_generate_mipmap extension found, using it.
[17:25:58] Couldn't find the GL_ARB_shadow extension, not using it...
[17:25:58] GL_ARB_vertex_buffer_object extension found, using it.
[17:25:58] GL_EXT_framebuffer_object extension found, using it.
[17:25:58] GL_EXT_draw_range_elements extension found, using it.
[17:25:58] Couldn't find the GL_ARB_texture_non_power_of_two extension, not using it...
[17:25:58] Couldn't find the GL_ARB_fragment_program extension, not using it...
[17:25:58] Couldn't find the GL_ARB_vertex_program extension, not using it...
[17:25:58] Couldn't find the GL_ARB_fragment_shader extension, not using it...
[17:25:58] Couldn't find the GL_ARB_vertex_shader extension, not using it...
[17:25:58] Couldn't find the GL_ARB_shader_objects extension, not using it...
[17:25:58] Couldn't find the GL_ARB_shading_language_100 extension, not using it...
[17:25:58] GL_ARB_texture_mirrored_repeat extension found, NOT using it...
[17:25:58] GL_ARB_texture_rectangle extension found, NOT using it...
[17:25:58] GL_EXT_fog_coord extension found, NOT using it...
[17:25:58] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...
[17:25:58] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...
[17:25:59] Not using vertex program for actor animation.
[17:25:59] Error opening sound configuration file
[17:26:04] The location of the data files in use is /home/archlette/el_linux/
[17:26:04] Your personal settings and logs will be saved in /home/archlette/.elc/main/
[17:26:26] Connecting to Server...
[17:26:26] Hi, and welcome to Eternal Lands! If you're new to the game and need help, please read the newbie helper guides on the main website. If you would rather learn by doing, talk to the Tutorial NPC, which is at the start point. In addition to that, you can type #help_me and your question to get a live response if there are helpers online. Click on the screen to continue!

[17:26:45] Ika is online.
[17:26:45] Thyralax is online.


Log started at 2011-03-06 17:48:58 localtime (EST)

[17:48:58] Window size adjusted to 1014x713
[17:48:59] GL_ARB_multitexture extension found, using it.
[17:48:59] GL_ARB_texture_env_combine extension found, using it.
[17:48:59] GL_EXT_compiled_vertex_array extension found, using it.
[17:48:59] GL_ARB_point_sprite extension found, using it.
[17:48:59] GL_ARB_texture_compression extension found, using it.
[17:48:59] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...
[17:48:59] GL_SGIS_generate_mipmap extension found, using it.
[17:48:59] Couldn't find the GL_ARB_shadow extension, not using it...
[17:48:59] GL_ARB_vertex_buffer_object extension found, using it.
[17:48:59] GL_EXT_framebuffer_object extension found, using it.
[17:48:59] GL_EXT_draw_range_elements extension found, using it.
[17:48:59] Couldn't find the GL_ARB_texture_non_power_of_two extension, not using it...
[17:48:59] Couldn't find the GL_ARB_fragment_program extension, not using it...
[17:48:59] Couldn't find the GL_ARB_vertex_program extension, not using it...
[17:48:59] Couldn't find the GL_ARB_fragment_shader extension, not using it...
[17:48:59] Couldn't find the GL_ARB_vertex_shader extension, not using it...
[17:48:59] Couldn't find the GL_ARB_shader_objects extension, not using it...
[17:48:59] Couldn't find the GL_ARB_shading_language_100 extension, not using it...
[17:48:59] GL_ARB_texture_mirrored_repeat extension found, NOT using it...
[17:48:59] GL_ARB_texture_rectangle extension found, NOT using it...
[17:48:59] GL_EXT_fog_coord extension found, NOT using it...
[17:48:59] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...
[17:48:59] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...
[17:48:59] Not using vertex program for actor animation.
[17:48:59] Error opening sound configuration file
[17:49:01] The location of the data files in use is /home/archlette/el_linux/
[17:49:01] Your personal settings and logs will be saved in /home/archlette/.elc/main/
[17:49:19] Connecting to Server...
[17:49:19] Hi, and welcome to Eternal Lands! If you're new to the game and need help, please read the newbie helper guides on the main website. If you would rather learn by doing, talk to the Tutorial NPC, which is at the start point. In addition to that, you can type #help_me and your question to get a live response if there are helpers online. Click on the screen to continue!

[17:50:55] Ika is online.
[17:50:55] Thyralax is online.


Log started at 2011-03-06 19:01:07 localtime (EST)

[19:01:07] Window size adjusted to 1014x713
[19:01:08] GL_ARB_multitexture extension found, using it.
[19:01:08] GL_ARB_texture_env_combine extension found, using it.
[19:01:08] GL_EXT_compiled_vertex_array extension found, using it.
[19:01:08] GL_ARB_point_sprite extension found, using it.
[19:01:08] GL_ARB_texture_compression extension found, using it.
[19:01:08] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...
[19:01:08] GL_SGIS_generate_mipmap extension found, using it.
[19:01:08] Couldn't find the GL_ARB_shadow extension, not using it...
[19:01:08] GL_ARB_vertex_buffer_object extension found, using it.
[19:01:08] GL_EXT_framebuffer_object extension found, using it.
[19:01:08] GL_EXT_draw_range_elements extension found, using it.
[19:01:08] Couldn't find the GL_ARB_texture_non_power_of_two extension, not using it...
[19:01:08] Couldn't find the GL_ARB_fragment_program extension, not using it...
[19:01:08] Couldn't find the GL_ARB_vertex_program extension, not using it...
[19:01:08] Couldn't find the GL_ARB_fragment_shader extension, not using it...
[19:01:08] Couldn't find the GL_ARB_vertex_shader extension, not using it...
[19:01:08] Couldn't find the GL_ARB_shader_objects extension, not using it...
[19:01:08] Couldn't find the GL_ARB_shading_language_100 extension, not using it...
[19:01:08] GL_ARB_texture_mirrored_repeat extension found, NOT using it...
[19:01:08] GL_ARB_texture_rectangle extension found, NOT using it...
[19:01:08] GL_EXT_fog_coord extension found, NOT using it...
[19:01:08] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...
[19:01:08] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...
[19:01:08] Not using vertex program for actor animation.
[19:01:08] Error opening sound configuration file
[19:01:13] The location of the data files in use is /home/archlette/el_linux/
[19:01:13] Your personal settings and logs will be saved in /home/archlette/.elc/main/
[19:01:33] Connecting to Server...
[19:01:33] Hi, and welcome to Eternal Lands! If you're new to the game and need help, please read the newbie helper guides on the main website. If you would rather learn by doing, talk to the Tutorial NPC, which is at the start point. In addition to that, you can type #help_me and your question to get a live response if there are helpers online. Click on the screen to continue!

[19:02:32] Ika is online.
[19:02:32] Thyralax is online.

Share this post


Link to post
Share on other sites

Two things Aisy...

 

Are you compiling the binary on this system? or trying to run one of the ones that comes with EL?

 

Why are you using the nouveau driver instead of the binary nvidia one?

(I can tell you from recent first hand testing that the nouveau driver doesn't have anywhere near enough hardware acceleration support to run EL at any kind of decent framerate, even on quite powerful nVidia cards)

 

i'd say pacman -S nvidia and change the driver in xorg.conf to 'nvidia' and try again.

 

edit:

also, is this your notebook u replaced the video card in? what video card is in this system?

Edited by Korrode

Share this post


Link to post
Share on other sites

Two things Aisy...

 

Are you compiling the binary on this system? or trying to run one of the ones that comes with EL?

 

Why are you using the nouveau driver instead of the binary nvidia one?

(I can tell you from recent first hand testing that the nouveau driver doesn't have anywhere near enough hardware acceleration support to run EL at any kind of decent framerate, even on quite powerful nVidia cards)

 

i'd say pacman -S nvidia and change the driver in xorg.conf to 'nvidia' and try again.

 

edit:

also, is this your notebook u replaced the video card in? what video card is in this system?

 

This is the generic linux flavor that comes with EL.

Ok, both you and chr0nik had the same advice, so I got rid of nouveau and put in the 96xx nvidia drivers. Not the best but at least I'm ingame.

 

I went with nouveau because both the arch wiki and forums recommended it specifically for my card. I do anticipate eventually replacing it.

 

No this is not my sager that was messing up. That is most likely a $600 card replacement so that is on hold for now.

Share this post


Link to post
Share on other sites
I went with nouveau because both the arch wiki and forums recommended it specifically for my card. I do anticipate eventually replacing it.

What card is it? a GeForce4 series?

Share this post


Link to post
Share on other sites

Graphics card:

[archlette@archbang ~]$ lspci | grep "VGA"
01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
[archlette@archbang ~]$

:P

Share this post


Link to post
Share on other sites

looks like an old card. did you try the "nvidia-96xx" package?

Yep that is what I am using now, and am ingame! :bow_arrow:

 

(It took a lot of uninstalling other nonsense that was there for the nouveau dependencies et al, but it all works now.)

Share this post


Link to post
Share on other sites

And now I'm stuck with nouveau drivers again because I get this message after the most recent kernel update:

"Error: failed to prepare transaction (could not satisfy dependencies):: nvidia-96xx: requires kernel26<2.6.38"

 

So both nvidia96xx and 173xx are gone and nothing to replace them other than nouveau.

Share this post


Link to post
Share on other sites

The 2.6.39 kernel is going to bring significant performance (and probably compatibility) improvements for nouveau.

 

2.6.39 is still at RC stage upstream and is not available in any Arch repos.

 

 

Your most reliable option is to rollback your Xorg to version 1.9.x and then you'll be able to use nvidia-96xx again.

 

Another option is to build yourself a 2.6.39-rc3 kernel and see if nouveau then works.

 

I suggest rolling back Xorg for now and waiting for the .39 kernel and any associated nouveau stuff to come into the Arch official repos... but whichever way you want to go, if you need help let me know. :)

 

 

edit:

If even with 2.6.39 nouveau doesn't work, hopefully nVidia will put out 96xx and 173xx drivers for Xorg 1.10 ...but unlike last time (the 1.7 -> 1.8 debacle) there is more chance they wont now... because nouveau is in fact, apparently, coming along well.

 

edit2:

http://www.nvnews.net/vbulletin/showthread.php?t=160143

There a nVidia official at least didn't say that they won't be putting out a new 173xx ^^

Edited by Korrode

Share this post


Link to post
Share on other sites

I'm also looking into a new graphics card.

Supposedly any AGP card will work. If I find a decent one somewhere between cheap and reasonable, I will probably do that. I guess in the long run it's the better solution anyway.

Share this post


Link to post
Share on other sites

http://www.newegg.com/Product/Product.aspx?Item=N82E16814130452

 

that'll work with 'normal' (non-legacy) nvidia driver ^^

 

ediy: damj tupos

Heh that's the one I liked but:

1. My computer specs say 4x AGP not 8x.

2. This says 64 bit

3. It only has OpenGL 1.5 which I'm not sure is good either.

4. Can't find if the motherboard is 2.0 AGP or not.

 

(Dell Precision 330, obviously very old but I'm in the process of upgrading bit by bit. It's my current pet project, making old discarded computers work. I have a few ;) )

Share this post


Link to post
Share on other sites

New Quadro's never offer the best value VS gaming performance, and it's rare even when buying 2nd hand... however at $10 that is a good deal, just make sure they're not trying to sting you with big postage charges. If the postage is any more than like $15 you could get something better 2nd hand off eBay for the same total cost.

Share this post


Link to post
Share on other sites

My question is, which is better to worry about: The card's memory or the OpenGL and/or DirectX?

Obviously ideally both, but it seems everything I find either has good OpenGL support OR good memory but not both.

Share this post


Link to post
Share on other sites

I know there's all this talk at the minute about new client features and which OpenGL version everyone's cards support, but realistically, it wouldn't be in EL's best interests to become inoperable on OpenGL 2...

Share this post


Link to post
Share on other sites

I know there's all this talk at the minute about new client features and which OpenGL version everyone's cards support, but realistically, it wouldn't be in EL's best interests to become inoperable on OpenGL 2...

 

I don't think there was ever talk about that. There was only some talk about making it REQUIRE 2.0

Share this post


Link to post
Share on other sites

I know there's all this talk at the minute about new client features and which OpenGL version everyone's cards support, but realistically, it wouldn't be in EL's best interests to become inoperable on OpenGL 2...

 

I don't think there was ever talk about that. There was only some talk about making it REQUIRE 2.0

That's what I figured. ;)

 

@Aislinn

173xx drivers for Xorg 1.10 just became available... i think last time the 96xx drivers were out a day or 2 after the 173xx ones... but I'm guessing you've ordered a new card by now and it's all irrelevant. :>

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×