Jump to content
Eternal Lands Official Forums
Sign in to follow this  
Aislar

Unusual problem...with ALT key?

Recommended Posts

Hey, I am posting here for Smurf, just because he felt more comfortable with someone with a better knowledge of computing/software to explain this problem.

 

He has a problem where if he presses a key, the game responds as if he has hit ALT+the key, though he did not press ALT.

This happens randomly. This also happens much, much more often when a second client is open.

For example(s):

-While flee training and hitting home (flee) nothing happens at all. Smurf then check to see if "this problem" is happening. So, he hits 'H' and the health bar toggles on/off as if he had hit ALT+H.

-Also, with maps, when this problem is happening, he will hit tab and nothing happens.

-Similar to the "H" key toggling the health bar, he can press "R" which toggles range lock without pressing the ALT key.

-When this problem occurs, speech bubbles appear as if he turned them on via options menu, even though he hasn't.

 

Any help would be greatly appreciated.

He has Windows 7 64bit, GeForce GTS 240/PCI/SSE2, and his OpenGL Version is 3.2.0.

 

Thank you very much!

Aislar (and Smurf)

Share this post


Link to post
Share on other sites

hmm, interesting, as I experienced it the other way round. I run EL in windowed mode.

If I switch to another program (lets say browser) and switch back to EL via ALT+TAB,

pressing a key combination for lets say restoration (example: ALT+1) won't work

initially. The workaround for me is, pressing ALT once, then every key combination

works normal again.

 

I hope I make any sense, still too early here :)

Share this post


Link to post
Share on other sites

Possible that sticky keys are turned on. Did he press shift 5 times while playing another game, possibly a FPS? Shift is used as jump key.

 

 

If this was the problem,

 

1. Press SHIFT 5 times (this disables sticky keys initially)

1.1. Press shift again 5 times,

2. Click the Settings button,

3. Under Keyboard tab, disable sticky keys and open settings for sticky keys,

4. Disable the Keyboard shortcut.

 

 

[edited and inserted 1.1]

Edited by TuDaeFadda

Share this post


Link to post
Share on other sites

Did you check for so-called hardware sticky-keys? It might not be related to software at all

 

Try another keyboard, sometimes (more like always) stuff gets beneath the buttons and/or sometimes the keyboard just gets tired over time and some of the keys loose the spring n their step and stay down (most often happens with the CTRL and ALT keys)

 

...just say'n - worth a shot

 

 

Share this post


Link to post
Share on other sites

This happens to me all the time - only if you swap using alt+tab.

 

Alt seems to be stuck down - and what you type seems to work as if alt was down - ie #GM gives Grab mode (ALT+G) etc.

Pressing alt twice fixes this - but its a pain if you swap back and try to cast a spell - alt+1 does not work... brick for Radu.

Share this post


Link to post
Share on other sites

I have this problem too, but only since I have a new laptop running Win 7. I am pretty sure it is not a kb issue, but something in the combination EL 1.9.1 and Win 7. Haven't seen it happen on a Vista or XP machine, nor with any other program.

I will try to figure out better when this occurs, but yeah, Lenny got me (brick for radu) thanks to this bug, and it is dangerous in instances too. Since I change windows with alt+tab all the time, I will try to figure out if that has anything to do with it.

Thanks for the suggestion TuDaeFadda, I never seen that window before and disabled it.

Share this post


Link to post
Share on other sites

This happens to me often. I run in windowed style and as I alt-tab b/t windows I can't F1 restore and have to hit the Alt key to release it.

Or if I'm typing to someone I will enable range-lock, turn mini map on/off, health bars, names on/off, hit Enter and suddenly Video changes will take effect next time you restart and you'll be in fullscreen mode. I've come close to dying but never actually have, PHEW!

 

I'm on XP pro fyi.

Share this post


Link to post
Share on other sites

Considering many people appear to be experiencing this on various Windows versions, hardware is an unlikely cause.

I'd think it would be related to focusing or unfocusing the EL window when a modifier (such as alt) is already depressed. Try focusing another window, then hold alt and focus the EL window to see if u can reliably reproduce it. I'd think people alt+tab'ing would be prone to it.

 

My window manager (Fluxbox) does an excellent job of not passing-through key combos that it uses for it's functions.

 

So my suggested solution is install Linux. :sneaky:

 

EDIT:

So I just booted to Windows XP and was able to immediately produce modifier-key related issues.

One of 2 things happens with EL; either the alt modifier is in depressed state, or the first depression of alt doesn't put it in depressed state.

Both would be extremely annoying.

As i expected, alt+tab'ing often reproduces it.

 

The client developers could possibly put in some checks for when the window gets focus (maybe, i don't really know)... but it's a Windows bug, I've seen it many times over the years with a variety of apps.

 

I've never been able to suggest "install Linux" as the solution and have it be less troll-ish than right now :P

 

Anyways in Windows I also have that bug where the flashing cursor doesn't appear in text input boxes in web browsers, scary stuff, so time for me to gtfo and reboot back to my good OS. :D

Edited by Korrode

Share this post


Link to post
Share on other sites

hah, yes was able to reproduce it under linux too (kde 3.5)

 

the same problem in general: if you press the ALT key while EL is not in focus and while still holding down the key focus on el window and hit some key like M the ALT is not counted and the key is just printed out in local chat

 

Never had the problem myself before because KDE changes windows after you release the ALT key - therefor to reproduce the problem I had to focus EL window by clicking on it in taskbar :evilgrin:

Edited by zalic

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×