Jump to content
Eternal Lands Official Forums
Entropy

EL 1.9.1 RC2 Windows installer and Linux data

Recommended Posts

For the Windows people, this is the easy installer that everyone can use, so please download it and install the patch.

Here are the instructions:

1. Download the file at http://www.eternal-lands.com/el_191_RC2_update.exe

2. CLOSE THE GAME (all the instances if you run it multiple times)

3. Run the el_191_RC2_update.exe

4. Select the folder where you installed EL and install it.

5. Start the game again.

6. If it doesn't work, reread the instructions carefully, and make sure the data path points to the place where you installed it.

 

 

Linux/OSX data is here: http://www.eternal-lands.com/el_update_191_rc2.zip

Get the latest CVS and use the same compile options as in the other thread:

FEATURES += MORE_ATTACHED_ACTORS

# Enable more activities on horses

FEATURES += NECK_ITEMS

# Enables medallions/scarves

FEATURES += LARGE_TEXTURES

# Changes player character texture size block to 512x512.

FEATURES += ACHIEVEMENTS

Share this post


Link to post
Share on other sites

Please test the fighting on horses some more especially archery, and post if you notice any out of place graphic bugs with the characters!

Share this post


Link to post
Share on other sites

As always, the latest Linux executables for any distro are available here for 32 bit and 64 bit. The full download page for these files is here. For Ubuntu you can use the eternallands-rc and eternallands-rc-data packages from my personal package archive. If you installed the previous versions then updates will be ready for you to install using your update manager. To install from scratch follow in instructions here.

Share this post


Link to post
Share on other sites

We did some testing in KF on the test server last night and I don't think any graphics problems were noticed. We got lots of resyncs with ranging going on though.

Edited by Quesar

Share this post


Link to post
Share on other sites

Just noticed a couple of things:

 

* range animations for crossbows on horse are missing

* if I enter aim mode and repeatedly click on a target, I get a ton of resynchs. The command queues are flooded with "rotation" and "enter aim mode" commands. I tested both without a horse and without MORE_ATTACHED_ACTORS and the resynchs are still there. Maybe a server issue?

 

EDIT:

Another thing: everytime a "enter aim mode" command is received the horse idle is changed. It's a bit weird because a sequence of neighing can overlap :P . I'll fix the ranging idle for horses tomorrow.

Edited by Fedora

Share this post


Link to post
Share on other sites

Crossbows are not allowed on horses, due to the way they are reloaded.

Does the second issue happen for everyone in the area, or just for you? Also, do you fire multiple shots?

Share this post


Link to post
Share on other sites

Crossbows are not allowed on horses, due to the way they are reloaded.

 

Ok

 

Does the second issue happen for everyone in the area, or just for you? Also, do you fire multiple shots?

 

I was testing alone in the ranging arena. And no, I fire just one shot, for the last click I guess.

These are the queues just before the resynch:

  Actor Fedora queue: -->52|R40|52|R40|52|R40|52|R40|52| 0| 0| 0| 0| 0| 0|
  Horse Fedora queue: -->256|R40|256|R40|256|R40|256|R40|256| 0| 0| 0| 0| 0| 0|

52=enter_aim_mode

R40=turn_e

256=wait

Share this post


Link to post
Share on other sites

Here is an issue I have noticed, although I am not sure how it will affect the game when horses are fully implemented. If I am walking along and do #horse 0ctane, the horse appears, but my actor is not on the horse. Instead, I drift off to the side a bit as we travel. I can post screenies if necessary.

Share this post


Link to post
Share on other sites

I think horses might suffer a little from acrophobia ;-) I.e. there might be a problem with the z-axis when riding on horseback and climbing slopes etc:

 

3166623035346365.jpg

 

3761336263353132.jpg

Share this post


Link to post
Share on other sites

Is that a real horse Gwaew or #horse command? Please don't post any bugs found with the #horse command, but test it with a real horse whistle only.

Share this post


Link to post
Share on other sites

Is that a real horse Gwaew or #horse command? Please don't post any bugs found with the #horse command, but test it with a real horse whistle only.

 

Was #horse command, sorry. Just posted because I thought in this case it wouldn't make a difference.

Can I please get a few free whistles to test on real horse :whistle: ?

Share this post


Link to post
Share on other sites

If me or Radu are over there on the test server we'll give them to you but otherwise unless it's something necessary we're not going to go log on and hand them out to every who asks, just don't have the time.

Share this post


Link to post
Share on other sites

If me or Radu are over there on the test server we'll give them to you but otherwise unless it's something necessary we're not going to go log on and hand them out to every who asks, just don't have the time.

 

 

Ok, I know - didn't expect you to ... wasn't meant too serious either ;)

Share this post


Link to post
Share on other sites

Found small error with Item List I guess.

When I save new list with training arrows, next time I want to grab them from list I get PK arrows.

When I save new list with all my PK (4 :P) and few training arrows, I get training arrows only when there are no PK arrows in my sto - doesn't matter if I chose PK or training arrows.

Here is what I have in my item_lists.txt file:

589 589 
4 20 
65535 65535 

guess the problem is with this 589 number x2

 

I just updated to rc2, noticed it on rc1 though.

Share this post


Link to post
Share on other sites

Found small error with Item List I guess.

When I save new list with training arrows, next time I want to grab them from list I get PK arrows.

When I save new list with all my PK (4 :P) and few training arrows, I get training arrows only when there are no PK arrows in my sto - doesn't matter if I chose PK or training arrows.

Here is what I have in my item_lists.txt file:

589 589 
4 20 
65535 65535 

guess the problem is with this 589 number x2

 

I just updated to rc2, noticed it on rc1 though.

I think this is a case of the same image being use for different items rather than a bug in the item lists. The old and still default way to distinguish one item from the next is to use the ID of the image. When the same ID is shared by multiple items the item list cannot distinguish between them and so uses the first matching item it finds. However, you can enable proper, unique item IDs from the server using the "#item_uid" command. Once you have done this, save a new list and everything will be fine. You'll now notice that the "65535 65535" line in the saved list have unique numbers.

Edited by bluap

Share this post


Link to post
Share on other sites

Yes, it works now :) I have 880 instead 65535 for training arrows.

 

edit: after server hiccup I noticed some errors in my storage:

elscreen075.th.png

after another #item_uid command everything went back to normal.

Edited by krlc

Share this post


Link to post
Share on other sites

I know this has nothing to do with ranging, but I found a map hole. The char completely disappears below the map at You are in Melinis [138,311]. I seen a chim do it, so I tested to see if I would.

 

Awesome job on the new client!

Share this post


Link to post
Share on other sites

Yes, it works now :) I have 880 instead 65535 for training arrows.

 

edit: after server hiccup I noticed some errors in my storage:

elscreen075.th.png

after another #item_uid command everything went back to normal.

I had this immediately after a trade, restart of client fixed it.

Share this post


Link to post
Share on other sites

This post is about new RC2, but not about the ranging tests.

 

I noticed the nice work done about clothes and i appreciate very much new dimension and better quality of the clothes and the flowers.

 

I noticed an odd difference in the file "cape1_medium.cmf" between RC1 and RC2.

 

So i created a new cape just to test the difference.

 

In RC1 the cape was resized in the same way in all the parts.

 

I noticed in RC2 there is a part of the cape that is not resised like the rest of the cape.

 

Here you can find a sample of that i mean:

http://bycortez.altervista.org/new-clothes/rc1vsrc2.htm

 

I don't know if this is wanted or not, so this post is made just to ask if the new file "cape1_medium.cmf" is right.

 

Thanks

Giove

Share this post


Link to post
Share on other sites

As always, the latest Linux executables for any distro are available here for 32 bit and 64 bit. The full download page for these files is here. For Ubuntu you can use the eternallands-rc and eternallands-rc-data packages from my personal package archive. If you installed the previous versions then updates will be ready for you to install using your update manager. To install from scratch follow in instructions here.

 

I am using the el.i686.linux.bin.static from here and the "Drop all" button in the inventory window does not work. Meaning, when i click on it, nothing happens.

 

Piper

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×