Jump to content
Eternal Lands Official Forums
Sign in to follow this  
Guest

Linux newbie problem

Recommended Posts

Guest

Hi guys I m complete linux newbie and not much familiar with bash.

I downloaded the game. How is the correct syntax of chmod?

When I write as root chmod 775 "mypath here"/el.x86.linux.bin

 

It seems comand was executed.

When I write then ./el.x86.linux.bin -it says me "Permission denied."

 

I have Suse 9.0

What is that?

Share this post


Link to post
Share on other sites
Guest

Now I took to run it and i get something like this: Xlib: extension "XFree86-DRI" missing on display ":0.0".

Share this post


Link to post
Share on other sites
Guest

I have nvidia geforce family card. Properly instaled - what does mean in this case, I just downloaded nvidia driver provided by nvidia via Yast and installed it.

Nothing changes.

When I download original nvidia package, I ll get myself to the point where it does say "Unable to determine nvdia kernel module filename."

Share this post


Link to post
Share on other sites
Guest

This is glxinfo:

 

jara@linux:~> glxinfo

name of display: :0.0

Xlib: extension "XFree86-DRI" missing on display ":0.0".

display: :0 screen: 0

direct rendering: No

server glx vendor string: SGI

server glx version string: 1.2

server glx extensions:

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context

client glx vendor string: SGI

client glx version string: 1.2

client glx extensions:

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context

GLX extensions:

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context

OpenGL vendor string: Mesa project: www.mesa3d.org

OpenGL renderer string: Mesa GLX Indirect

OpenGL version string: 1.3 Mesa 4.0.4

OpenGL extensions:

GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,

GL_ARB_texture_cube_map, GL_ARB_texture_env_add,

GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,

GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,

GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,

GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,

GL_EXT_texture_lod_bias

glu version: 1.3

glu extensions:

GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

 

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav

id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

----------------------------------------------------------------------

0x23 16 tc 1 16 0 r y . 5 6 5 0 0 16 0 0 0 0 0 0 0 None

0x24 16 tc 1 16 0 r y . 5 6 5 0 0 16 8 16 16 16 0 0 0 None

0x25 16 tc 1 16 0 r y . 5 6 5 8 0 16 8 16 16 16 16 0 0 None

0x26 16 tc 1 16 0 r . . 5 6 5 8 0 16 8 16 16 16 16 0 0 None

0x27 16 dc 1 16 0 r y . 5 6 5 0 0 16 0 0 0 0 0 0 0 None

0x28 16 dc 1 16 0 r y . 5 6 5 0 0 16 8 16 16 16 0 0 0 None

0x29 16 dc 1 16 0 r y . 5 6 5 8 0 16 8 16 16 16 16 0 0 None

0x2a 16 dc 1 16 0 r . . 5 6 5 8 0 16 8 16 16 16 16 0 0 None

Share this post


Link to post
Share on other sites

The nVidia drivers i remember i saw them on YaST online update feature so u prolly wanna download it from there...

Share this post


Link to post
Share on other sites
Guest

Well I got 3D running, all seems to be O.K. I did compiled kernel. But the game is still not running - the application window openes and there is greena and blue rubish in it.

Error log is empty.

I m geting pretty frustrated.

 

glx log seems to be fine, other 3D games are running.

Share this post


Link to post
Share on other sites
Guest

Hm I got game running, there are some tiles on the screan, but no cursor is seen when I get onto the window and the picture is wicked.

I have duron 1300,256 mb RAM and now WORKING 3d card.

Whats wrog again?

Share this post


Link to post
Share on other sites

Hey! this happened to me! remember. mabey I can help, Im sorry I am a little lost while reading this, what is the current status of your computer and EL. What drivers are you using with your Nvidia card? the ones from the Nvidia website or the ones from the Yast update (BTW dont do Yast update for the drivers, it doesnt really work for EL) Just reiterate what you have right now.

Share this post


Link to post
Share on other sites
Guest

I m using package I have downloaded from nvidia site and compiled myself, since yast drivers didnt worked.

 

 

This is what I have now:

name of display: :0.0

display: :0 screen: 0

direct rendering: Yes

server glx vendor string: NVIDIA Corporation

server glx version string: 1.3

server glx extensions:

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,

GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control

client glx vendor string: NVIDIA Corporation

client glx version string: 1.3

client glx extensions:

GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_visual_info,

GLX_EXT_visual_rating, GLX_EXT_import_context, GLX_SGI_video_sync,

GLX_NV_swap_group, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,

GLX_SGI_swap_control, GLX_NV_float_buffer

GLX extensions:

GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,

GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,

GLX_ARB_get_proc_address

OpenGL vendor string: NVIDIA Corporation

OpenGL renderer string: GeForce4 MX 440/AGP/SSE/3DNOW!

OpenGL version string: 1.4.1 NVIDIA 53.36

OpenGL extensions:

GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_point_parameters,

GL_ARB_point_sprite, GL_ARB_texture_compression, GL_ARB_texture_cube_map,

GL_ARB_texture_env_add, GL_ARB_texture_env_combine,

GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,

GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,

GL_ARB_vertex_program, GL_ARB_window_pos, GL_S3_s3tc,

GL_EXT_texture_env_add, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,

GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,

GL_EXT_compiled_vertex_array, GL_EXT_draw_range_elements,

GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,

GL_EXT_paletted_texture, GL_EXT_point_parameters, GL_EXT_rescale_normal,

GL_EXT_secondary_color, GL_EXT_separate_specular_color,

GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap,

GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,

GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,

GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,

GL_EXT_texture_lod, GL_EXT_texture_lod_bias, GL_EXT_texture_object,

GL_EXT_vertex_array, GL_IBM_rasterpos_clip,

GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square,

GL_NV_fence, GL_NV_fog_distance, GL_NV_light_max_exponent,

GL_NV_packed_depth_stencil, GL_NV_pixel_data_range, GL_NV_point_sprite,

GL_NV_register_combiners, GL_NV_texgen_reflection,

GL_NV_texture_env_combine4, GL_NV_texture_rectangle,

GL_NV_vertex_array_range, GL_NV_vertex_array_range2, GL_NV_vertex_program,

GL_NV_vertex_program1_1, GL_NVX_ycrcb, GL_SGIS_generate_mipmap,

GL_SGIS_multitexture, GL_SGIS_texture_lod, GL_SUN_slice_accum

glu version: 1.3

glu extensions:

GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

 

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav

id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

----------------------------------------------------------------------

0x21 16 tc 0 16 0 r y . 5 6 5 0 0 16 0 16 16 16 16 0 0 None

0x22 16 dc 0 16 0 r y . 5 6 5 0 0 16 0 16 16 16 16 0 0 None

0x23 16 tc 0 16 0 r . . 5 6 5 0 0 16 0 16 16 16 16 0 0 None

0x24 16 tc 0 16 0 r y . 5 6 5 0 0 0 0 16 16 16 16 0 0 None

0x25 16 tc 0 16 0 r . . 5 6 5 0 0 0 0 16 16 16 16 0 0 None

0x26 16 dc 0 16 0 r . . 5 6 5 0 0 16 0 16 16 16 16 0 0 None

0x27 16 dc 0 16 0 r y . 5 6 5 0 0 0 0 16 16 16 16 0 0 None

0x28 16 dc 0 16 0 r . . 5 6 5 0 0 0 0 16 16 16 16 0 0 None

 

With other 3d Games like Armagetron it works. (Havent worked before)

Share this post


Link to post
Share on other sites
Guest

I would try. The binary is somehow strange, because, when I click on it in konqueror, which shall initialise the program, it says" Fle is not program" r executable.

When I run it from bash, I get this one result.

Share this post


Link to post
Share on other sites

You will have to download it from the CVS, and then make

The CVS link is on the main page.

 

Can you please post a screenshot on how the game looks on your computer?

Share this post


Link to post
Share on other sites
Guest

Dont give up. this is not as hard as it seems. If you cant figure out the CVS then go back to the download current version, the guys in this game are experts and can figure it out. dont give up!

Share this post


Link to post
Share on other sites
Guest

My problem is that I dont come along with linux as good as I wanted, even if I like it better than windows, which I abandoned week ago. ;)

 

I downloaded the game a chmod -x the binary. How exactly shall look this line?

Share this post


Link to post
Share on other sites

I think you should have a dual boot, Linux and Windows. Windows should be for games, linux should be for learning it. Changing your OS is not very easy, and you will still need Windows for most of the games.

Share this post


Link to post
Share on other sites

Wait, you chmod -x it? Better make that a +.

 

The exact line should be

 

chmod +x ./el.x86.linux.bin

 

and should be executed in the directory where the file resides. Alternatively, you could right click on the file in Konqueror, choose Properties (i guess), and set the executable flags somewhere in the window that pops up.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×