Jump to content
Eternal Lands Official Forums
SenZon

Can't connect to server

Recommended Posts

Morning all ^^

 

I am a new Linux here, so really bad with it :S. I can't connect to the server here at my job. Downloaded followed the instructions, made the file executable. But after the game opens it simply just doesn't connect to the server =/

 

Window size adjusted to 1014x713

GL_ARB_multitexture extension found, using it.

GL_ARB_texture_env_combine extension found, using it.

GL_EXT_compiled_vertex_array extension found, using it.

GL_ARB_point_sprite extension found, using it.

GL_ARB_texture_compression extension found, using it.

Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...

GL_SGIS_generate_mipmap extension found, using it.

GL_ARB_shadow extension found, using it.

GL_ARB_vertex_buffer_object extension found, using it.

GL_EXT_framebuffer_object extension found, using it.

GL_EXT_draw_range_elements extension found, using it.

GL_ARB_texture_non_power_of_two extension found, using it.

GL_ARB_fragment_program extension found, using it.

GL_ARB_vertex_program extension found, using it.

GL_ARB_fragment_shader extension found, using it.

GL_ARB_vertex_shader extension found, using it.

GL_ARB_shader_objects extension found, using it.

GL_ARB_shading_language_100 extension found, using it.

GL_ARB_texture_mirrored_repeat extension found, NOT using it...

GL_ARB_texture_rectangle extension found, NOT using it...

GL_EXT_fog_coord extension found, NOT using it...

Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...

Couldn't find the GL_EXT_texture_compression_latc extension, not using it...

Not using vertex program for actor animation.

Error opening sound configuration file

The location of the data files in use is ./

Your personal settings and logs will be saved in /home/alunos/emgcl.master/.elc/main/

Connecting to Server...

Can't connect to server :medieval:

Press any key to try again.

Press Alt-x to close the game

 

I would also like some help on how to conect to the PK server using Linux (I think I am using a custom version of Linux called "Libertas GNU/Linux").

 

Computer info is this:

Processor: Intel® Celeron® CPU 430 @ 1.80GHz

Clock: 1.75 GHz

Memory: 512 Mb

IP: 10.90.56.12

 

Thank you ^^

Share this post


Link to post
Share on other sites

I have found that linux can be fussy with program instalation location.

 

I find that installing it in /usr/local/games/el_linux folder works the best. It can be installed else where, but you need to tell el.ini (iirc) that new location.

Share this post


Link to post
Share on other sites
Connecting to Server...

Can't connect to server :medieval:

Press any key to try again.

Press Alt-x to close the game

 

I would also like some help on how to conect to the PK server using Linux (I think I am using a custom version of Linux called "Libertas GNU/Linux").

 

 

Thank you ^^

 

1. This might be network problem, not system. Maybe port 2000 (main) is blocked in your work place? Were you able to connect from work using different PC for example? Try connecting to test server (2001).

2. Check your configuration file. To connect to PK server just change port number to 2002 (if I remember correct).

Share this post


Link to post
Share on other sites

Still didn't work, I'm at home right now, I'll try messing around more tomorow.

 

(You're right Devnul mostlikely it's blocking the ports cause I tried logging in on 3 different computers)

Share this post


Link to post
Share on other sites
Still didn't work, I'm at home right now, I'll try messing around more tomorow.

 

(You're right Devnul mostlikely it's blocking the ports cause I tried logging in on 3 different computers)

 

Hi,

 

If your network is operating on CISCO equipment most likely there is an inspection on that port that allows only Skinny Call Control Protocol (SCCP). I think you should do the following:

- Try to connect to EL test server (port 2001) to check if only port 2000 is blocked.

- Contact your network administrator with a good reason of unblocking port 2000.

 

 

Good luck!

Share this post


Link to post
Share on other sites
Would using Learner´s proxy thing help?

 

 

It is on other port (443) which is used by default by HTTPS so I think it will NOT be blocked. Give it a try and let me know about results.

Share this post


Link to post
Share on other sites
Would using Learner´s proxy thing help?

 

 

It is on other port (443) which is used by default by HTTPS so I think it will NOT be blocked. Give it a try and let me know about results.

 

Wierd, I changed the ports to 2000, 2001, 2002 and now I just did Learner's proxy but still nothing, so I'm thinking when I edit the el.ini file it's not being edited. Did the test and changed the screen size but the screen size didn't change when I opened the game. So lost and I wanna play, nothing to do here lol

Share this post


Link to post
Share on other sites

Maybe this will help you help me:

 

Log started at 2010-07-28 11:36:30 localtime (BRT)

 

[11:36:30] Using the server profile: main

[11:36:30] Warning: Didn't find your data_dir, using the current directory instead. Please correct this in your el.ini . Given data_dir was: "c:\Program Files\Eternal Lands\/". Using "/home/alunos/emgcl.master/Desktop/el_linux".

[11:36:30] Window size adjusted to 790x545

[11:36:30] GL_ARB_multitexture extension found, using it.

[11:36:30] GL_EXT_compiled_vertex_array extension found, using it.

[11:36:30] GL_ARB_point_sprite extension found, using it.

[11:36:30] GL_ARB_texture_compression extension found, using it.

[11:36:30] Couldn't find the GL_EXT_texture_compression_s3tc extension, not using it...

[11:36:30] GL_SGIS_generate_mipmap extension found, using it.

[11:36:30] GL_ARB_shadow extension found, using it.

[11:36:30] GL_ARB_vertex_buffer_object extension found, using it.

[11:36:30] GL_EXT_framebuffer_object extension found, using it.

[11:36:30] GL_EXT_draw_range_elements extension found, using it.

[11:36:30] GL_ARB_texture_non_power_of_two extension found, using it.

[11:36:30] GL_ARB_fragment_program extension found, using it.

[11:36:30] GL_ARB_vertex_program extension found, using it.

[11:36:30] GL_ARB_fragment_shader extension found, using it.

[11:36:30] GL_ARB_vertex_shader extension found, using it.

[11:36:30] GL_ARB_shader_objects extension found, using it.

[11:36:30] GL_ARB_shading_language_100 extension found, using it.

[11:36:30] GL_ARB_texture_mirrored_repeat extension found, NOT using it...

[11:36:30] GL_ARB_texture_rectangle extension found, NOT using it...

[11:36:30] GL_EXT_fog_coord extension found, NOT using it...

[11:36:30] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...

[11:36:30] Couldn't find the GL_EXT_texture_compression_latc extension, not using it...

[11:36:31] load_vertex_programs(): EXTENDED EXCEPTION(5:opengl_error): invalid enumerant in load_vertex_programs at actor_init.cpp (line 542)

[11:36:32] Error opening sound configuration file

[11:36:34] * server www.eternal-lands.com filename http://www.eternal-lands.com/updates190/files.lst

[11:36:34] Downloading http://www.eternal-lands.com/updates190/files.lst from www.eternal-lands.com

[11:36:34] Error: Can't open file "alias.ini"

 

I managed to make the el.ini file work, I was editing the wrong one >.> (but still wont connect with the server)

Share this post


Link to post
Share on other sites
(I think I am using a custom version of Linux called "Libertas GNU/Linux").

I can't find anything about this distro SenZ, u sure thats what it's called?

 

Do you have a command called telnet installed?

If yes, type in a terminal:

telnet game.eternal-lands.com 2000

Do you see the normal welcoming message when u do this?

 

If not, what about:

telnet game.eternal-lands.com 2001

?

 

EDIT:

If you don't have the telnet command, in Debian based distros the package to install to get telnet is called inetutils-telnet, so if u don't have it but u can install packages and it's debian based, install that.

In Archlinux it's just the inetutils package... idk about other distros, but something with "inetutils" in the name prolly.

 

EDIT2:

(Ok found some info on that distro (all in Portuguese but <3 google translate)... looks like the distro is based on Debian)

Edited by Korrode

Share this post


Link to post
Share on other sites

Yea it's Debian, the custom wallpaper has that written on it :)

 

Didn't get the terminal part, I'm a Linux virgin. I don't get any of this :S

Share this post


Link to post
Share on other sites

look in your menu for something called "terminal" or with "term" in the name, like "xterm".

 

It's a command prompt, like 'cmd.exe' on windows... except, way more uber than cmd.

Share this post


Link to post
Share on other sites
Yea it's Debian, the custom wallpaper has that written on it :)

 

Didn't get the terminal part, I'm a Linux virgin. I don't get any of this :S

 

That is why I didn't want to go through telnet tool. Just one question, do you edit correct configuration file at the moment?

 

11:36:30] Using the server profile: main

[11:36:30] Warning: Didn't find your data_dir, using the current directory instead. Please correct this in your el.ini . Given data_dir was: "c:\Program Files\Eternal Lands\/". Using "/home/alunos/emgcl.master/Desktop/el_linux".

 

Because from this log I see you are still trying to connect to main, can you try test server or via proxy?

Share this post


Link to post
Share on other sites
(I think I am using a custom version of Linux called "Libertas GNU/Linux").

I can't find anything about this distro SenZ, u sure thats what it's called?

 

Do you have a command called telnet installed?

If yes, type in a terminal:

telnet game.eternal-lands.com 2000

Do you see the normal welcoming message when u do this?

 

If not, what about:

telnet game.eternal-lands.com 2001

?

 

EDIT:

If you don't have the telnet command, in Debian based distros the package to install to get telnet is called inetutils-telnet, so if u don't have it but u can install packages and it's debian based, install that.

In Archlinux it's just the inetutils package... idk about other distros, but something with "inetutils" in the name prolly.

 

EDIT2:

(Ok found some info on that distro (all in Portuguese but <3 google translate)... looks like the distro is based on Debian)

 

All I get is this:

 

emgcl.master@emgcl11:~$ telnet game.eternal-lands.com 2000

bash: telnet: command not found

emgcl.master@emgcl11:~$ telnet game.eternal-lands.com 2001

bash: telnet: command not found

 

I tried downloading that inetutils-telnet thingy but how do I execute it, it has thousands of zipped files inside the zipped file x.X

 

 

@Devnul I set up learners proxy thing already but still no good and same message :S (Iĺl keep messing around with it)

 

#Edit - I'm pretty sure I'm setting it up right

Login settings:

 

 

 

#server_address = proxy1.other-life.com

 

#server_port = 443

 

 

and . . .

 

Login settings:

 

 

 

#server_address = game.eternal-lands.com

#server_port = 2001

 

#Edit 2 - Korrode if you are on with in the next few hours wanna try and remote access my PC :)?

Edited by SenZon

Share this post


Link to post
Share on other sites
If you have proper repositories set in your system you can install telnet with this command: “sudo apt-get install telnet”

 

emgcl.master@emgcl15:~$ sudo apt-get install telnet

 

We trust you have received the usual lecture from the local System

Administrator. It usually boils down to these three things:

 

#1) Respect the privacy of others.

#2) Think before you type.

#3) With great power comes great responsibility.

 

[sudo] password for emgcl.master:

emgcl.master is not in the sudoers file. This incident will be reported.

 

Maybe it's just not meant to be =/

 

But keep trying thank you for all the efforts :)

Share this post


Link to post
Share on other sites

I understand you do have a account with root privileges on this machine?

 

Ok, so:

 

1. If you know root password then: "su root" or any other administrator account.

- Then edit /etc/sudoers and add your account to group with privileges.

OR

- Do “apt-get” from root account.

Share this post


Link to post
Share on other sites
I understand you do have a account with root privileges on this machine?

 

Ok, so:

 

1. If you know root password then: "su root" or any other administrator account.

- Then edit /etc/sudoers and add your account to group with privileges.

OR

- Do “apt-get” from root account.

 

No I don't have the password and mostlikely can't get it either ;_;

Share this post


Link to post
Share on other sites

Annoying thing is, one doesn't need root access to play EL... but yeah SenZ w/o gaining access to the system not much more can be done... and you'll be behind a firewall and won't be able to get ports forwarded for me to SSH in ;S

Share this post


Link to post
Share on other sites
@Devnul I set up learners proxy thing already but still no good and same message :S (Iĺl keep messing around with it)

 

#Edit - I'm pretty sure I'm setting it up right

Login settings:

 

 

 

#server_address = proxy1.other-life.com

 

#server_port = 443

 

 

and . . .

 

Login settings:

 

 

 

#server_address = game.eternal-lands.com

#server_port = 2001

 

Hmm are you sure servers.lst does not take precedence ?

Have you tried setting learners proxy in servers.lst ?

(Well it should be there after installation, so just try to run el with param: lrnr-main instead of: main)

Share this post


Link to post
Share on other sites

Yay, managed to get EL working. I had to change the server.lst. It wasn't obeying my commands so I changed every server info to port 2002 (so even if it tried to connect to main server it would go to PK/Learners proxy) ^^ Thank you all for your help.

Share this post


Link to post
Share on other sites
Guest arakron

hello

 

i want to play EL but im using ubuntu 10.10, i installed the game like the instructions on the web, and well when i run the game its appears somenthing like this...

http://img641.imageshack.us/i/el1q.png/

 

then i chose main server port 2000 and i get this:

http://img829.imageshack.us/i/el2.png/

 

well im new on ubuntu so tried to type what you said, but in fact i dont know for what is but i show you the result:

http://img819.imageshack.us/i/el3v.png/

 

and after a while i get this

http://img225.imageshack.us/i/el4.png/

 

so im would be very very grateful if someone help me, im using a computer with intel i5 750 i think its 2.6ghz, 2gb ram, enought free space, and a video card of 512mb

 

arakron

Share this post


Link to post
Share on other sites

...

well im new on ubuntu so tried to type what you said, but in fact i dont know for what is but i show you the result:

http://img819.imageshack.us/i/el3v.png/

...

It appears to be showing that you can't connect to the server. It could be that your ISP blocks the required port in which case you either have to get them to open it or you will need to use the proxy server described in this thread. It could be that your internet connection out via that port is blocked at your end too. So if you have a local firewall, check the configuration or ask the person who set it up to check.

 

BTW, this is what a successful connection using telnet looks like:

Trying 213.152.3.5...

Connected to game.eternal-lands.com.

Escape character is '^]'.

u�Hi, and welcome to Eternal Lands! If you're new to the game and need help, please read the newbie helper guides on the main website. If you would rather learn by doing, talk to the Tutorial NPC, which is at the start point. In addition to that, you can type #help_me and your question to get a live response if there are helpers online. Click on the screen to continue!

<Rd

Edited by bluap

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×