Jump to content
Eternal Lands Official Forums
Entropy

1.9.0 RC2

Recommended Posts

SRM Insides seems to be flagged as an outdoor map (sky is visible)

Hash: 8cc33ba2de22dac8a932d4f101c170c7 ./maps/cont2map16_insides.elm

Share this post


Link to post
Share on other sites

On the test server (and main and PK too), the snow IP is back for me:

http://img.photobucket.com/albums/v623/the...stEternalLa.png

Client: CVS client built 15 minutes ago, used the Makefile.linux which comes with the client.

 

Data directory (according to the path in "Misc" "Data directory" is pointing at my EL folder.

 

Error_log.txt

 

Log started at 2010-03-24 20:36:33 localtime (CET)

 

[20:36:33] Using the server profile: test

[20:36:33] Window size adjusted to 790x545

[20:36:34] GL_ARB_multitexture extension found, using it.

[20:36:34] GL_EXT_compiled_vertex_array extension found, using it.

[20:36:34] GL_ARB_point_sprite extension found, using it.

[20:36:34] GL_ARB_texture_compression extension found, using it.

[20:36:34] GL_EXT_texture_compression_s3tc extension found, using it.

[20:36:34] GL_SGIS_generate_mipmap extension found, using it.

[20:36:34] GL_ARB_shadow extension found, using it.

[20:36:34] GL_ARB_vertex_buffer_object extension found, using it.

[20:36:34] GL_EXT_framebuffer_object extension found, using it.

[20:36:34] GL_EXT_draw_range_elements extension found, using it.

[20:36:34] GL_ARB_texture_non_power_of_two extension found, using it.

[20:36:34] GL_ARB_fragment_program extension found, using it.

[20:36:34] GL_ARB_vertex_program extension found, using it.

[20:36:34] GL_ARB_fragment_shader extension found, using it.

[20:36:34] GL_ARB_vertex_shader extension found, using it.

[20:36:34] GL_ARB_shader_objects extension found, using it.

[20:36:34] GL_ARB_shading_language_100 extension found, using it.

[20:36:34] GL_ARB_texture_mirrored_repeat extension found, NOT using it...

[20:36:34] GL_ARB_texture_rectangle extension found, NOT using it...

[20:36:34] GL_EXT_fog_coord extension found, NOT using it...

[20:36:34] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...

[20:36:34] GL_EXT_texture_compression_latc extension found, using it.

[20:36:35] Error opening sound configuration file

[20:36:37] * server www.eternal-lands.com filename http://www.eternal-lands.com/updates180/files.lst

[20:36:37] Downloading http://www.eternal-lands.com/updates180/files.lst from www.eternal-lands.com

[20:36:37] Error: Can't open file "alias.ini"

[20:36:37] Finished downloading http://www.eternal-lands.com/updates180/files.lst

[20:36:38] Error: Can't open file "custom_mirrors.lst"

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile0.bmp in el_file at io/elfile.cpp (line 179)

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile1.bmp in el_file at io/elfile.cpp (line 179)

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile9.bmp in el_file at io/elfile.cpp (line 179)

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile14.bmp in el_file at io/elfile.cpp (line 179)

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile16.bmp in el_file at io/elfile.cpp (line 179)

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile17.bmp in el_file at io/elfile.cpp (line 179)

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile7.bmp in el_file at io/elfile.cpp (line 179)

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile12.bmp in el_file at io/elfile.cpp (line 179)

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile48.bmp in el_file at io/elfile.cpp (line 179)

[20:36:42] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./tiles/tile10.bmp in el_file at io/elfile.cpp (line 179)

[20:36:43] Error: Can't open file "servermarks_the_piper.dat"

[20:38:23] Client closed

 

And, as the error log says, i cant find tile10.bmp in my EternalLands folder, i cannot even find a folder named tiles.

 

Something is missing in the zip file?

 

And the client crashes mostly every time, when i try to take a bag.

 

Bags are not visible, when you kill a creature/drop stuff.

 

Piper

 

Edit: Typos >.<

Edited by The_Piper

Share this post


Link to post
Share on other sites

i just tryed rc2 on my pc

in a empty folder called Eternal lands on drive c program files

when i ran it i got this screen.

 

120351.jpg

 

then it went blank what am i doing wrong?

 

im running windows vista home premium

intel quad2 cpu q8300

4gb ram

 

error log

Log started at 2010-03-24 18:57:16 localtime (GMT Standard Time)

 

[18:57:16] Error: Server profile not found in servers.lst for server: 2\el.exe". Failover to server: main.

[18:57:16] Using the server profile: main

[18:57:16] Window size adjusted to 1274x774

[18:57:16] Could not read console.xml

[18:57:16] Could not read errors.xml

[18:57:16] Could not read help.xml

[18:57:16] Could not read options.xml

[18:57:16] Could not read spells.xml

[18:57:16] Could not read stats.xml

[18:57:16] Could not read titles.xml

[18:57:16] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./textures/font.bmp in el_file at io/elfile.cpp (line 179)

[18:57:16] Error: Can't open file "mapinfo.lst"

[18:57:16] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./textures/login_back.bmp in el_file at io/elfile.cpp (line 179)

[18:57:16] GL_ARB_multitexture extension found, using it.

[18:57:16] GL_EXT_compiled_vertex_array extension found, using it.

[18:57:16] GL_ARB_point_sprite extension found, using it.

[18:57:16] GL_ARB_texture_compression extension found, using it.

[18:57:16] GL_EXT_texture_compression_s3tc extension found, using it.

[18:57:16] GL_SGIS_generate_mipmap extension found, using it.

[18:57:16] GL_ARB_shadow extension found, using it.

[18:57:16] GL_ARB_vertex_buffer_object extension found, using it.

[18:57:16] GL_EXT_framebuffer_object extension found, using it.

[18:57:16] GL_EXT_draw_range_elements extension found, using it.

[18:57:16] GL_ARB_texture_non_power_of_two extension found, using it.

[18:57:16] GL_ARB_fragment_program extension found, using it.

[18:57:16] GL_ARB_vertex_program extension found, using it.

[18:57:16] GL_ARB_fragment_shader extension found, using it.

[18:57:16] GL_ARB_vertex_shader extension found, using it.

[18:57:16] GL_ARB_shader_objects extension found, using it.

[18:57:16] GL_ARB_shading_language_100 extension found, using it.

[18:57:16] GL_ARB_texture_mirrored_repeat extension found, NOT using it...

[18:57:16] GL_ARB_texture_rectangle extension found, NOT using it...

[18:57:16] GL_EXT_fog_coord extension found, NOT using it...

[18:57:16] Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...

[18:57:16] GL_EXT_texture_compression_latc extension found, using it.

[18:57:17] el_open(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./shaders/water_fs.glsl in el_file at io/elfile.cpp (line 179)

Last message repeated 3 times

[18:57:17] el_open(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./shaders/reflectiv_water_fs.glsl in el_file at io/elfile.cpp (line 179)

Last message repeated 3 times

[18:57:17] el_open(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./shaders/water_fs.glsl in el_file at io/elfile.cpp (line 179)

Last message repeated 3 times

[18:57:17] Error: Can't open file "mirrors.lst"

[18:57:17] Couldn't open the book: languages/en/books/races/human.xml!

[18:57:17] Couldn't open the book: languages/en/books/races/dwarf.xml!

[18:57:17] Couldn't open the book: languages/en/books/races/elf.xml!

[18:57:17] Couldn't open the book: languages/en/books/races/gnome.xml!

[18:57:17] Couldn't open the book: languages/en/books/races/orchan.xml!

[18:57:17] Couldn't open the book: languages/en/books/races/draegoni.xml!

[18:57:17] Error: Can't open file "commands.lst"

[18:57:17] Error: Can't open file "alias.ini"

[18:57:17] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./textures/thick_clouds.bmp in el_file at io/elfile.cpp (line 179)

[18:57:17] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./textures/thick_clouds_detail.bmp in el_file at io/elfile.cpp (line 179)

[18:57:17] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./textures/moonmap.bmp in el_file at io/elfile.cpp (line 179)

[18:57:17] el_open_custom(): EXTENDED EXCEPTION(1:file_not_found): Can't find file ./textures/BrightSun.bmp in el_file at io/elfile.cpp (line 179)

[18:57:24] Client closed

Edited by bomwan

Share this post


Link to post
Share on other sites

Check the el.ini in 'My documents\Eternal Lands\main' or 'My documents\Eternal Lands\test' (depending on the server you trying to use). Look for the line '#data_dir = ...' and make sure that one points to your NEW eternal lands program folder.

Share this post


Link to post
Share on other sites
Piper, you have to compile it with these options posted in this thread: http://www.eternal-lands.com/forum/index.php?showtopic=52622

 

Thanks Roja, its working now.

 

Going to check some more stuff this evening.

 

It would be nice, if someone would upload a makefile with the actual options to avoid such trouble in the future :inquisitive:

 

Piper

Share this post


Link to post
Share on other sites

Desert Pines Map - Test server

 

Can't enter Store @ 331, 335 - has been fixed

 

Can't enter Cave @ 148, 224 - not fixed

 

EDIT: ADD

 

Portland Map - Test server

 

Can't enter house @ 133, 250 - has been fixed

Edited by marack

Share this post


Link to post
Share on other sites

In Idaloran all the tiles mixes looks rare, i guess it is because the base green grass tile is lower than it should...

Share this post


Link to post
Share on other sites

******

 

nvm...should have tested on TEST server >.<

 

nice work on the opening screen tho :)

Edited by DibClark

Share this post


Link to post
Share on other sites

Isla Prima

[18,55] ./maps/startmap_insides.elm: the door is floating, doesn't touch the wall nor the floor

entering IP tavern, you are sent to [18,13], should be [21,13]

the locked house on Isla Prima, when clicking on the door at [81,112] the char instead walks to [81,118]

the rat house on Isla Prima, when clicking on the door at [82,93] the char instead walks to [90,102]

the rat house on Isla Prima, when exiting the house (door at [82,93]), the char appears at [89,105]

rat cave on IP, entrance at [41,69], when entering/exiting the char goes to [36,69]

 

Desert Pines

[99,165] ./maps/map3_insides.elm: the door to exit Elandria temple is sort of missing (there is a black shape instead) and can be clicked only on the outer side rotating the camera

./maps/cave1.elm: clicking the door at [64,55] makes the char walk to [56,53] before entering

 

White Stone (haven't tested the map yet, just happened to pass by the temple)

./maps/map2.elm: the "entrance" to Aluwen temple is at [640,685], exiting the temple sends the char to [638,635]

Share this post


Link to post
Share on other sites

Valley of the Dwarves

[119,18] ./maps/map5nf.elm: there is a triangular patch of grass tile visible between the soil area and the rocks

[132,96] ./maps/map5nf.elm: little triangular hole in the ground

[27,47] ./maps/map5nf.elm: triangular hole in the ground

[28,21] ./maps/map5nf.elm: can stand inside the rock

[175,174] ./maps/map5nf_insides.elm: the central section of the counter flickers when rotating the camera

[57,90] ./maps/map5nf_insides.elm: dirt flickering through a fur rug

[258,28] ./maps/mine1_sub.elm: door cursor doesn't appear when hovering the door or the house (the house can be entered clicking with the pointy finger though) - exiting works fine

[337,141] ./maps/mine1_sub.elm: same as previous one

[225,86] ./maps/mine1_sub.elm: same as above

 

The following are not-working doors and 1 cave entrance inside the Hidden Gold Mine: I suspect they are not supposed to be accessible, but can't be sure so I'm listing them anyway

[166,27] ./maps/mine1_sub.elm: door can't be entered

[354,141] ./maps/mine1_sub.elm: door can't be entered

[148,227] ./maps/mine1_sub.elm: door can't be entered

[306,172] ./maps/mine1_sub.elm: cave entrance, can't be entered

 

EDIT

checked Nordcarn too:

[44,28] ./maps/cave3.elm: the big rock is far below the others, which results in an opening in the side of the cave

Edited by Theryndan

Share this post


Link to post
Share on other sites

the new client is great,

 

i have just been playing today and ive found 2 falts:

 

You are in Isla Prima - The docks [24,26]

 

at this location i go under the map

 

also reflections do not work.

 

other than those its really good :)

Share this post


Link to post
Share on other sites
You are in Isla Prima - The docks [24,26]

 

at this location i go under the map

Map "bugs" like these need to be tested on the test server, not main. Those coords are invalid on test.

Share this post


Link to post
Share on other sites

hello, first of all i want to thank all of you

real good work, the new textures are great :)

 

so far i have found some graphic errors :

 

You are in Bethel [162,124]

flickering texture on the pathway (overlapping textures)

 

You are in Lothalith Fortress. [63,157]

the door is inside the wall

 

You are in Lothalith Fortress. [148,51]

can walk through closed door (maybe a server issue don't know )

 

hope it helps a bit

 

edit:

You are in Aeth Aelfan, the Elven Homeland [199,367]

flickering water,ground texture

 

wuffzel

Edited by wuffzel

Share this post


Link to post
Share on other sites

Minor graphical glitches

 

 

WS 414;758: small white area behind flowers http://tinypic.com/usermedia.php?uo=7vBB%2...C8di4h4l5k2TGxc

TG 147;57: flashing graphics patch on rock wall http://tinypic.com/usermedia.php?uo=7vBB%2...D7qnoh4l5k2TGxc

WS 119,323 : mismatched stairs http://tinypic.com/usermedia.php?uo=7vBB%2...ZIQp4h4l5k2TGxc

WS 696,490: small white patch http://tinypic.com/usermedia.php?uo=7vBB%2...98HmIh4l5k2TGxc

WS 694,515: small white patch http://tinypic.com/usermedia.php?uo=7vBB%2...pxr3oh4l5k2TGxc

Share this post


Link to post
Share on other sites

Please excuse the lack of a snapshot, but the path in TD over the mountains to the south no longer has any dirt on it, so you can't tell there is a path there. It seems rather obvious in the old client, but you can't see a hint of a path in the new one.

Share this post


Link to post
Share on other sites

File icon.bmp is missing in rc2 release - causes X icon instead of EL icon in taskbar for EL window under Linux. Copying it from the previous worked.

 

Shipwreck in evtr missing.

 

Shipwreck in bethel is missing a bunch of pieces that make it up, only about 1/2 of it is there.

 

Shipwreck in glacmor missing.

 

2 problems in secret areas pmed to roja

Edited by Quesar

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×