Jump to content
Eternal Lands Official Forums
Sign in to follow this  

Client Crashes while loading

Recommended Posts



So far I played on an old PC I have at home (by old, I mean something like 8 years), so I would like to use a newer one, but I have problems running EL on the latter.


It's a DELL LATITUDE D610 with a mobility Radeon X300


When I launch EL, it crashes (before reaching the login) while trying to access openGL.

After reading the threads in this section of the forum, I concluded it was probably caused by my graphic card driveers not being up to date.

So I went to the ATI website to download the latest version compatible with the X300, but when trying to install this drivers, it tells me that the driver is not compatible with my PC.

After some more reading, I found out that DELL does not support the ATI Catalyst drivers and supplies its own drivers.

I went to the DELL website to try and find a more recent driver for my card, but even after installing a more recent driver I still have the same problem.


So my questions are the following:

- could someone please confirm that the crash is likely due to the drivers not being up to date?

- did anyone already try to run EL on such a configuration (at least on a PC with the mobility radeon X300) and in this case which driver worked?

- what else could I try to make EL run on this PC?



Share this post

Link to post
Share on other sites

Maybe this helps: http://www.eternal-lands.com/forum/index.php?showtopic=41922


You could also try the 'standard' stuff like enabling poor_man and disabling all other graphics options directly in the el.ini file located in

Documents and Settings\$Username\My Documents\Eternal Lands\main. (use a text editor for that).


Also moving/renaming the shaders folder in the EL directory (where you installed the game) seems to work for lots of older radeon cards.

Share this post

Link to post
Share on other sites

Enabling the poor man option or disabling other options didn't work, but renaming the shader folder did ;)


Thanks alot for your help, Gampa. :)


Now I'll do a clean install to get rid of all the modifications in the ini file...

Share this post

Link to post
Share on other sites
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.