Jump to content
Eternal Lands Official Forums
Sign in to follow this  
snoops

Can't see console text

Recommended Posts

fedora 9, ATI Radeon 9250

 

Has been working fine, until last night I start up client and chat text doesn't appear, just blank lines where the text should be.

 

I checked my chat log, and the text isn't in there either.

 

Things that don't show:

Blue global messages

special day text

the green welcome text

all chat channel text* (apart from lenny)

you started to harvest ...

#research

probably more, i don't know, i can't see it

 

Things that do show:

you stopped harvesting

#calc results

knowledge list

going afk/not afk

hour warnings

[leonard@6] messages

 

 

Chatlog from this morning:

[01:04:07] Connecting to Server...

[01:04:24] Today is the 25th day in the month of Seedar, the year 0017, Age of the Eternals

[01:04:43] You stopped harvesting.

[01:05:21] You stopped harvesting.

[01:09:27] You stopped harvesting.

[01:10:35] Going AFK

[01:14:29] This is your 1 minute warning for the coming hour.

Hourly time-stamp: log continued at 2008-11-06 01:15:30 localtime (CST)

[02:15:01] This is your 1 minute warning for the coming hour.

Hourly time-stamp: log continued at 2008-11-06 02:16:01 localtime (CST)

[03:15:32] This is your 1 minute warning for the coming hour.

Hourly time-stamp: log continued at 2008-11-06 03:16:32 localtime (CST)

[03:45:47] This is your 1 minute warning for the coming sunset.

[04:16:03] This is your 1 minute warning for the coming hour.

Hourly time-stamp: log continued at 2008-11-06 04:17:03 localtime (CST)

[04:33:09] [Leonard @ 6]: Why don't presidents fight the war? Why do they always send jammie?

[05:16:32] This is your 1 minute warning for the coming hour.

Hourly time-stamp: log continued at 2008-11-06 05:17:32 localtime (CST)

[06:14:01] This is your 4 minute warning for the coming day.

[06:17:02] This is your 1 minute warning for the coming hour.

Hourly time-stamp: log continued at 2008-11-06 06:18:02 localtime (CST)

[06:47:22] This is your 1 minute warning for the coming sunrise.

[06:50:18] Not AFK any more

[06:50:18] URL seen while AFK: 6

[06:51:43] You stopped harvesting.

[06:53:58] You stopped harvesting.

 

i'm pretty sure there should be more in there, as i then logged in on my eee, and there's an invasion going on...

 

 

Error log:

Log started at 2008-11-06 08:09:18 localtime (CST)

[08:09:18] Using the server profile: main

[08:09:18] Warning: Didn't find your data_dir, using the current directory instead. Please correct this in your el.ini . Given data_dir was: "/home/snoops/el/el_install/"

[08:09:21] * server www.eternal-lands.com filename http://www.eternal-lands.com/updates170/files.lst

[08:09:21] Downloading http://www.eternal-lands.com/updates170/files.lst from www.eternal-lands.com

[08:09:21] Error: Can't open file "alias.ini"

[08:09:23] Finished downloading http://www.eternal-lands.com/updates170/files.lst

[08:37:00] Client closed

 

The data dir IS defined in el.ini, not sure why it complains.

But I cd into the el_install dir to run it anyway, and it hasn't been a problem so far.

 

 

So far i've tried:

restart client

restart X

restart PC

remove .elc

reinstall client

tried font settings in el options

search forums for 2 hours

 

I'm pretty sure i haven't installed anything since it was working, and the automatic updates are turned off.

Edited by snoops

Share this post


Link to post
Share on other sites

I've no idea about what could cause the problem you describe, so these are just a few random guesses until someone has a better idea:

 

- open the options (ctrl+o) -> Server: what's the option selected for "Log messages"? (iirc, the default is "log server messages")

- only some lines being ignored makes me think of the #ignore command: try deleting the local_ignores.txt file in ~/.elc/ [delete it while the game is not running]

- try deleting (or better, renaming) again the ~/.elc/ folder [while the game is not running]

- about the installation path: linux is case sensitive, maybe that's the problem with your current path?

- if you start the game from a terminal, do you get any error message?

Share this post


Link to post
Share on other sites
- open the options (ctrl+o) -> Server: what's the option selected for "Log messages"? (iirc, the default is "log server messages")

option selected = log server messages

 

- only some lines being ignored makes me think of the #ignore command: try deleting the local_ignores.txt file in ~/.elc/ [delete it while the game is not running]

- try deleting (or better, renaming) again the ~/.elc/ folder [while the game is not running]

I have tried this (in the 'things I have tried" list :whistle:)

 

- about the installation path: linux is case sensitive, maybe that's the problem with your current path?

No, the case is correct, but it's always complained yet never caused any problems before.

 

- if you start the game from a terminal, do you get any error message?

None

 

I was just thinking, it could be something to do with font colour.

Notice how Leonards messages on 6 are a shade lighter than the other chat text? And his message is the only chat text tht comes through..

Share this post


Link to post
Share on other sites

a screenshot, in case i didn't explain well enough:

 

console.jpg

 

 

In those blank spaces should be text saying things like "your leather gloves just broke", "you found a bag of gold", "your harvesting limit has been reached", and "mother nature is being a real b*tch today"

 

More things I have tried:

 

reinstalled mesa

Installed ati driver kmod-fglrx (that left me with no X at all)

Edited by snoops

Share this post


Link to post
Share on other sites
If, as you said, you don't have those lines in your chat log either, then it has nothing to do with graphics drivers or X server.

 

I was working on a hunch that maybe the text was only logged if it was successfully drawn to the screen.

Share this post


Link to post
Share on other sites

Ok, I unzipped a fresh install, but before I ran it, I turned auto updates off in the ini file.

And omg it works!

So I go back into my old install dir and run el, and that works too.

Hmm, so I turned auto updates back on, and my old install still works.

 

The only other thing I did earlier today (and i should have tried el after doing it, but I wasn't thinking that at the time) was to make sure nmbd started properly on startup. All this involved was opening system-config-network, clicking edit, click ok without making any changes, and then save.

(got me buggered how that changed anything :) )

 

So, one of these things has appeared to fix my problem...or perhaps it was that screenie i took this morning...or maybe fedora got scared at my mention of slackware...

Share this post


Link to post
Share on other sites

Automatic updates is currently not functional - the EL server does not have the 1.7.0 update server running.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×