Jump to content
Eternal Lands Official Forums
LabRat

Standardised web address for bots

Recommended Posts

Do you own a bot?

Does that bot have a web frontend?

 

If so, you may be interested in my latest project.

 

I own the domain http://www.elbots.co.uk and intend to use it as a central point for all things bot related in EL - bot sources, bot information etc and will happily host your bot sources so anyone asking "where do I find bot code?" will easily be able to find them.

 

For the current bot owners I offer a redirection service that allows all the bots in EL to have a common domain name, thus making one less thing for the end users to have to remember.

 

The subdomains work in the following manner:

For FRAMES enabled browsers the page loads your existing site inside a single frame with the browser still displaying http://botname.elbots.co.uk

For non-FRAMES enabled browsers the page will just do a simple redirect using a number of means (javascript/headers etc). Unfortunately this means that the browser bar will show your existing web address.

 

I do not wish to make any charge for this service, it is just a service to the community.

 

If you are interested in signing up, just gossip me (gossip emails me) with your botname and the frontend web address.

 

Your existing web address will not be affected in the slightest by any of this.

 

My server will not see any of the information displayed, the browser will be doing all of the work.

 

If your site requires passwords, uses cookies or authenticated sessions etc they will be unaffected as the browser will still be communicating directly with the existing site.

---------------------------------------

The next part of this project is to be able to automatically email the bot owner if the bot is not ingame for more than a set period (for example 10 minutes)

 

After that, who knows? :)

---------------------------------------

Bots currently using this system:

annihilator

agneum botonline-agneum.jpg

bazzy

calliope

crysar botonline-crysar.jpg

merchant_of_zad botonline-merchant_of_zad.jpg

mufo

passion

pepa

portia

raf

titanta botonline-titanta.jpg

bronco

tired_iron

------------------------

cupido

http://treasurer.elbots.co.uk

http://tinkerbelle.elbots.co.uk

http://shedevil.elbots.co.uk

Edited by LabRat

Share this post


Link to post
Share on other sites

It already is Jax :) all the bots I host are linked to it.

Share this post


Link to post
Share on other sites

Perhaps you can list all the bots that are ACTIVE and taking part of your service in the first post. To not only let some know that it is already in place... but also to let others know how many have already participated.

Share this post


Link to post
Share on other sites

This is a brand new service, so far the following bots are accessible using this system:

annihilator

agneum

bazzy

calliope

crysar

mufo

passion

pepa

portia

raf

titanta

bronco

tired_iron

Edited by LabRat

Share this post


Link to post
Share on other sites

Thanks ghrae for the suggestion, amended the first post

Thanks Aislinn for changing the (well it can't be a spelling error I can spell botname) (well it can't be a typing error I always do it) stupid thing I did :)

Share this post


Link to post
Share on other sites

My bot frontend asks for authorization, then sends me a 404.

[edit: when using annihilator.elbots.co.uk]

Using annihilator.labby.co.uk still works though. Any ideas?

Edited by Jaxbot

Share this post


Link to post
Share on other sites

Yes.

It points to your admin interface, your bot does not have a public accessible page.

 

Link amended slightly

Edited by LabRat

Share this post


Link to post
Share on other sites
Yes.

It points to your admin interface, your bot does not have a public accessible page.

 

Link amended slightly

 

Ok, thanks. Sometime I might make a public page about it, but not sure why I'd need one.

Share this post


Link to post
Share on other sites
ummm, i dont know if this is just me, but all those pages go to "Pirates Pizza"...

 

rofl

 

Same for me.

Edited by Rairor

Share this post


Link to post
Share on other sites
ummm, i dont know if this is just me, but all those pages go to "Pirates Pizza"...

 

rofl

 

Same for me.

rofl pr0 redirect, I like it :D

Share this post


Link to post
Share on other sites

eep I'll fix it

 

btw their pizza is one of the best I ever tasted :D

Share this post


Link to post
Share on other sites

fixed

 

It all came down to my 1337 copy and paste abilities - I forgot to set the correct path.

Share this post


Link to post
Share on other sites

not on my site mate.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×