Jump to content
Eternal Lands Official Forums
Entropy

Testing team needed

Recommended Posts

The only "odd" thing I noticed so far was the colors seem a LOT brighter. The before and after images are below in respective order (before and after.) NOTE: my screen's not really this dark, not sure why the images are so dark, but the color contrast (from before to after) is indeed this drastict.

I noticed this too. I wear the white robe and it now looks as bright and stark as though it was lit up from within.

Also when I turn the screen, I get very stark shadow effects, much more stark than before.

Share this post


Link to post
Share on other sites

I've the same result:

XP SP2

930mhz PIII/ 384MB

(will soon be upgrading to IBM 6x86 2gb & will retest)

nvidia gforce 6200

 

Performance wise, no decipherable difference other than the char brightness & contrast:

th_ex_1.jpgth_ex_2.jpg

-----------------------------------------------------------------------------------------------------

[EDIT]

I as well noticed this alteration in the midst of wondering:

ex_3.jpg

The name, hps, heath, appear at a fixed level below the creature.

About the same hight as a ground creature, such as a raccoon.

Falcons have the same oddity.

This effect also makes the targets difficult to engage, since it's actual

positioning is in the correct location (below the tag).

-----------------------------------------------------------------------------------------------------

[EDIT]

Another 'tag' issue:

ex_4.jpg

Tags do not fall when creatures meet their demise.

Edited by DormantSouL

Share this post


Link to post
Share on other sites

I revisited newbie island and the phantons we meet yesterday. Two machines, vertex programs do not work on the first (the one I used yesterday), being switched off due to an error while loading. The file's are opened fine as I checked the size() call and its right. Nothing is written to ~/.elc/test/infos.log but I get an error in error_log.txt:

[11:57:30] EXTENDED EXCEPTION(5:opengl_error): invalid operation in 
load_vertex_program at actor_init.cpp (line 28)

 

Here's and image, and here's the GL info stuff:

GL_ARB_multitexture extension found, using it.
GL_ARB_texture_env_combine extension found, using it.
GL_EXT_compiled_vertex_array extension found, using it.
GL_ARB_point_sprite extension found, using it.
GL_ARB_texture_compression extension found, using it.
GL_EXT_texture_compression_s3tc extension found, using it.
GL_SGIS_generate_mipmap extension found, using it.
GL_ARB_shadow extension found, using it.
GL_ARB_vertex_buffer_object extension found, using it.
Couldn't find the GL_EXT_framebuffer_object extension, not using it...
GL_EXT_draw_range_elements extension found, using it.
Couldn't find the GL_ARB_texture_non_power_of_two extension, not using it...
Couldn't find the GL_ARB_fragment_program extension, not using it...
GL_ARB_vertex_program extension found, using it.
Couldn't find the GL_ARB_fragment_shader extension, not using it...
GL_ARB_vertex_shader extension found, using it.
GL_ARB_shader_objects extension found, using it.
GL_ARB_shading_language_100 extension found, using it.
GL_ARB_texture_mirrored_repeat extension found, NOT using it...
GL_ARB_texture_rectangle extension found, NOT using it...
GL_EXT_fog_coord extension found, NOT using it...
Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...
Couldn't find the GL_EXT_texture_compression_latc extension, not using it...

Video card: GeForce4 Ti 4200 with AGP8X/AGP/SSE2
Vendor ID: NVIDIA Corporation
OpenGL Version: 1.5.6 NVIDIA 87.76
Supported extensions: GL_ARB_depth_texture GL_ARB_imaging GL_ARB_multisample
GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object
GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shader_objects
GL_ARB_shading_language_100 GL_ARB_texture_border_clamp
GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add
GL_ARB_texture_env_combine GL_ARB_texture_env_dot3
GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix
GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader
GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra
GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract
GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements
GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels
GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters
GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color
GL_EXT_shadow_funcs GL_EXT_shared_texture_palette GL_EXT_stencil_wrap
GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map
GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3
GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias
GL_EXT_texture_object GL_EXT_timer_query GL_EXT_vertex_array
GL_HP_occlusion_test GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat
GL_KTX_buffer_region GL_NV_blend_square GL_NV_copy_depth_to_color
GL_NV_depth_clamp GL_NV_fence GL_NV_fog_distance GL_NV_gpu_program_parameters
GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_occlusion_query
GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite
GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_texgen_reflection
GL_NV_texture_compression_vtc GL_NV_texture_env_combine4
GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2
GL_NV_texture_shader3 GL_NV_vertex_array_range GL_NV_vertex_array_range2
GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap
GL_SGIS_multitexture GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow
GL_SUN_slice_accum

 

 

Second machine is new (but not my normal machine) and has a better graphics card. Vertex programs are loaded ok with nothing in the error log and "Using vertex programs for actor animation" in ~/.elc/test/infos.log.

Here's and image, and here's the GL info stuff:

GL_ARB_multitexture extension found, using it.
GL_ARB_texture_env_combine extension found, using it.
GL_EXT_compiled_vertex_array extension found, using it.
GL_ARB_point_sprite extension found, using it.
GL_ARB_texture_compression extension found, using it.
GL_EXT_texture_compression_s3tc extension found, using it.
GL_SGIS_generate_mipmap extension found, using it.
GL_ARB_shadow extension found, using it.
GL_ARB_vertex_buffer_object extension found, using it.
GL_EXT_framebuffer_object extension found, using it.
GL_EXT_draw_range_elements extension found, using it.
GL_ARB_texture_non_power_of_two extension found, using it.
GL_ARB_fragment_program extension found, using it.
GL_ARB_vertex_program extension found, using it.
GL_ARB_fragment_shader extension found, using it.
GL_ARB_vertex_shader extension found, using it.
GL_ARB_shader_objects extension found, using it.
GL_ARB_shading_language_100 extension found, using it.
GL_ARB_texture_mirrored_repeat extension found, NOT using it...
GL_ARB_texture_rectangle extension found, NOT using it...
GL_EXT_fog_coord extension found, NOT using it...
Couldn't find the GL_ATI_texture_compression_3dc extension, not using it...
GL_EXT_texture_compression_latc extension found, using it.

Video card: GeForce 8300 GS/PCI/SSE2
Vendor ID: NVIDIA Corporation
OpenGL Version: 2.1.1 NVIDIA 100.14.19
Supported extensions: GL_ARB_color_buffer_float GL_ARB_depth_texture
GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_program_shadow
GL_ARB_fragment_shader GL_ARB_half_float_pixel GL_ARB_imaging GL_ARB_multisample
GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object
GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shader_objects
GL_ARB_shading_language_100 GL_ARB_texture_border_clamp
GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add
GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_float
GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two
GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object
GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers
GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc
GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color
GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax
GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader
GL_EXT_bindable_uniform GL_EXT_depth_bounds_test GL_EXT_draw_buffers2
GL_EXT_draw_instanced GL_EXT_draw_range_elements GL_EXT_fog_coord
GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object
GL_EXTX_framebuffer_mixed_formats GL_EXT_framebuffer_sRGB
GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4
GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float
GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters
GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color
GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture3D
GL_EXT_texture_array GL_EXT_texture_buffer_object
GL_EXT_texture_compression_latc GL_EXT_texture_compression_rgtc
GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map
GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3
GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod
GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object
GL_EXT_texture_sRGB GL_EXT_texture_shared_exponent GL_EXT_timer_query
GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat
GL_KTX_buffer_region GL_NV_blend_square GL_NV_copy_depth_to_color
GL_NV_depth_buffer_float GL_NV_depth_clamp GL_NV_fence GL_NV_float_buffer
GL_NV_fog_distance GL_NV_fragment_program GL_NV_fragment_program_option
GL_NV_fragment_program2 GL_NV_framebuffer_multisample_coverage
GL_NV_geometry_shader4 GL_NV_gpu_program4 GL_NV_half_float
GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_occlusion_query
GL_NV_packed_depth_stencil GL_NV_parameter_buffer_object GL_NV_pixel_data_range
GL_NV_point_sprite GL_NV_primitive_restart GL_NV_register_combiners
GL_NV_register_combiners2 GL_NV_texgen_reflection GL_NV_texture_compression_vtc
GL_NV_texture_env_combine4 GL_NV_texture_expand_normal GL_NV_texture_rectangle
GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3
GL_NV_transform_feedback GL_NV_vertex_array_range GL_NV_vertex_array_range2
GL_NV_vertex_program GL_NV_vertex_program1_1 GL_NV_vertex_program2
GL_NV_vertex_program2_option GL_NV_vertex_program3 GL_NVX_conditional_render
GL_SGIS_generate_mipmap GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow
GL_SUN_slice_accum

 

For both machines, I used the latest CVS, default options with MISSILES defined. I tried the shaders/* files from both CVS and the download as they are different. On the machine that used the vertex programs, I enabled and disabled use by moving the shader files in and out. I'd say the FPS was slightly increased from (68-70) without, to (70-74) with. This machine is a 2GHz Intel duo. With the vertex programs in use and surrounded by the phantoms, the CPU often scaled down to 1,2GHz and about the half the CPU time was IO bound. When vertex programs were not in use, the CPU was normal full speed and there was little IO usage visible. This later is rather variable and difficult to quantify apparently changing with the number of phantoms around.

 

Others have noted the creature banner height and brightness issues.

Edited by bluap

Share this post


Link to post
Share on other sites

GL Intercept reports that glProgramStringARB generates the GL_INVALID_OPERATION error

 

GL ERROR - Function glProgramStringARB generated error GL_INVALID_OPERATION

 

I added an extended error check with glGetString(GL_PROGRAM_ERROR_STRING_ARB) right after glProgramStringARB. This is the message

 

EXTENDED EXCEPTION(5:opengl_error): invalid operation:Error, line 220: parameter binding limit exceeded (max = 96, used = 119).
Error, line 220: instruction limit exceeded (max = 128, used = 156).
in load_vertex_program at d:\ago\elc-vc\elc\actor_init.cpp (line 38)

 

EDIT: Forgot to say this is with the i915GM

Edited by ago

Share this post


Link to post
Share on other sites

infos.log generated and populated as expected.

 

I noticed around a 20% improvement in frame rate immediately when running el_shaders.exe on my geforce 6600 512MB.

 

I did have a strange issue when running the latest CVS - pictures speak louder than words so here goes:

stretched_thumb.jpg

click the image for the full size version

 

The meshes all seemed to converge in the middle of the character at the feet, very weird indeed :huh:

Edited by LabRat

Share this post


Link to post
Share on other sites

The reflections in water are not correct for animals that are partially underwater. It happens for me only when the frame buffer is turned off.

Take a look: http://www.catz.yoyo.pl/el/elscreen020.png

The rabbit is underwater, but you can still see a reflection as he was walking on the water.

 

Edit: Players reflections are ok.

Edited by Ulrih

Share this post


Link to post
Share on other sites

I've noticed in 3 races so far, an issue with cloaks (all).

This effect does not seem present in the smaller races, dwarf & below.

I have not come across any other tall races yet, to see, but I would assume the same issue.

shold.jpg

Shoulders slightly show through cloaks.

Edited by DormantSouL

Share this post


Link to post
Share on other sites

I've noticed in 3 races so far, an issue with cloaks (all).

This effect does not seem present in the smaller races, dwarf & below.

I have not come across an Ogre yet, to see, but I would assume the same issue.

shold.jpg

Shoulders slightly show through cloaks.

 

 

You mean Orchan? :D:P

Share this post


Link to post
Share on other sites

infos.log shows..

 

Using vertex programs for actor animation

 

I'm using a AMD Samperon 64bit 1.8ghz processor(on a 32bit version of Kubuntu Feisty), 512MB RAM and a ATI Radeon Xpress M200 on board. #glinfo shows

 

Video card: ATI Radeon Xpress Series
Vendor ID: ATI Technologies Inc.
OpenGL Version: 2.1.7170 Release
Supported extensions: GL_AMD_performance_monitor GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_envmap_bumpmap 
GL_ATI_fragment_shader GL_ATI_meminfo GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_vertex_array GL_KTX_buffer_region GL_NV_blend_square GL_NV_texgen_reflection GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_WIN_swap_hint WGL_EXT_swap_control 

 

I haven't noticed much of a speed difference. Maybe ~5-10 FPS faster with CVS.

 

I've had some of the same problems as others where colors are either too bright or dark. Also the same issue with tags. I didn't have the same problem with The Wraith though. He shows up fine. [Edit] all transparent objects in IOTF look fine aswell.

 

I've had an issue similar to what Ulrih described. Here it does affect the player models reflection. I summoned a beaver and I get the exact result as Ulrih The geometry from the water reflection seems to stick up above the surface of the water (ie cloak and legs are sticking up above the water.) As seen here.. It only happens in deep water though (above the knee for me.) The little pond near beam is fine. Enabling/Disabling Frame Buffer Support doesn't seem to make a difference though.

 

[Edit]Rev. 1.2 of anim.vert and anim_shadow.vert made a HUGE difference for lighting. It loks much better now.

Edited by Nintenduh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×