Jump to content
Eternal Lands Official Forums
Roja

Help me compile the client!

Recommended Posts

I've got such errors in Dev-CPP 4.9.9.2 Compiler:

8 F:\Programowanie\Dev-Cpp\include\alu.h:12, from F:\Programowanie\Dev-Cpp\include\alut.h In file included from F:/(...)/mingw32/3.4.2/(...)/include/alu.h:12, from F:/(...)/mingw32/3.4.2/(...)/include/alut.h

84 F:\Programowanie\Dev-Cpp\include\alut.h:8, from platform.h from F:/(...)/mingw32/3.4.2/(...)/include/alut.h:8, from platform.h 

5 F:\Programowanie\elc\elc\platform.h:84, from main.c from platform.h:84, from main.c 

5 F:\Programowanie\elc\elc\main.c from main.c 
57 F:\Programowanie\Dev-Cpp\include\altypes.h conflicting types for 'ALsizei' 
84 F:\Programowanie\Dev-Cpp\include\al.h previous declaration of 'ALsizei' was here 

 

OK, i've managed to get rid of alut.h problems, but now i have this:

 

creating libelc.a 
F:\Programowanie\elc\elc\libelc.a(sound.o)(.text+0x20a3) In function `get_loaded_buffer': 
[Linker error] undefined reference to `_imp__alutLoadMemoryFromFile' 
F:\Programowanie\elc\elc\libelc.a(sound.o)(.text+0x2c30) In function `init_sound': 
[Linker error] undefined reference to `_imp__alutInitWithoutContext' 
F:\Programowanie\elc\elc\libelc.a(sound.o)(.text+0x2c30) ld returned 1 exit status 
F:\Programowanie\elc\elc\Makefile.win [Build Error]  [el.exe] Error 1 

Edited by BloodSucker

Share this post


Link to post
Share on other sites
I've got such errors in Dev-CPP 4.9.9.2 Compiler:

That looks suspiciously like you don't have the OpenAL _and_ Alut libs installed. You need to have both (although Alut will be removed if/when NEW_SOUND becomes standard).

 

Did you follow the instructions for building the client under Windows (see the other thread)? There are a list of DevPak's there, you need to use those versions as most of the other DevPak's around are out of date.

Share this post


Link to post
Share on other sites
I've got such errors in Dev-CPP 4.9.9.2 Compiler:

That looks suspiciously like you don't have the OpenAL _and_ Alut libs installed. You need to have both (although Alut will be removed if/when NEW_SOUND becomes standard).

 

Did you follow the instructions for building the client under Windows (see the other thread)? There are a list of DevPak's there, you need to use those versions as most of the other DevPak's around are out of date.

 

Step-by-step and double checked it. Got all the devpacks too, including:

  • freealut-devel.DevPak
  • OpenAL.DevPak
  • OpenAL-devel.DevPak

From the Placid site: http://el.beplacid.net/dev/win-libs/

Share this post


Link to post
Share on other sites
Step-by-step and double checked it. Got all the devpacks too

Ahhh, you need to copy the make.defaults file to make.conf and uncomment the 2 lines at the bottom which tell DevC++ (or actually gcc) where to find the additional libs.

## These 2 lines should be uncommented if you used Emajekral's Windows compilation how-to (adjust them if required)
#EXTRA_LIBS=-lstdc++
#EXTRA_INCLUDES=-IC:\\Dev-Cpp\\Include\\AL -IC:\\Dev-Cpp\\Include\\SDL

Share this post


Link to post
Share on other sites

I have this issue too, and those lines are definitely uncommented.

 

<load of stuff was here, but I deleted it>

Edit after an hour of messing around, I have fixed it.

 

Remove all the openal devpaks using package manager.

Add freealut-devel.DevPak and OpenAL-devel.DevPak

 

The problem seems to be a conflict between OpenAL.DevPak and OpenAL-devel.DevPak. Maybe OpenAL.DevPak should be removed from the repository.

Share this post


Link to post
Share on other sites

## These 2 lines should be uncommented if you used Emajekral's Windows compilation how-to (adjust them if required)
#EXTRA_LIBS=-lstdc++
#EXTRA_INCLUDES=-IC:\\Dev-Cpp\\Include\\AL -IC:\\Dev-Cpp\\Include\\SDL

 

Of course I've done it too.

 

Labrat solution solved the problem. Client compiles whit no errors (or warnings even). Thanks mate! :rolleyes:

Share this post


Link to post
Share on other sites
The problem seems to be a conflict between OpenAL.DevPak and OpenAL-devel.DevPak.
Of course you can't use 2 different versions of the same library. It doesn't know which one to link too.

 

You can _never_ have a standard lib and the development version installed together.

 

Oh well, its good learning... ;-)

 

Maybe OpenAL.DevPak should be removed from the repository.
From where? There is only one copy of each lib (the devel versions) on the "How to compile" page.

 

/edit: Ahhh, from Placid's site. Yeah, those are there for a reason. Please only use the ones linked in the post. Also if you had the old versions, they need to be completely removed before installing these newer versions. I think maybe that wasn't noted.

Edited by Torg

Share this post


Link to post
Share on other sites

I'm trying to create a gentoo ebuild for the latest update (btw, thanks for tagging 1.5!). During compilation I'm getting some errors that appear to be the result of an unresolved opengl symbol:

 

In file included from 2d_objects.c:9:
load_gl_extensions.h:281: error: expected '=', ',', ';', 'asm' or '__attribute__
' before 'ELglUniformMatrix2x3fv'

 

Here is the relevant portion of load_gl_extensions.h:

 

/*	  GL_VERSION_2_1		  */
extern PFNGLUNIFORMMATRIX2X3FVPROC ELglUniformMatrix2x3fv;
extern PFNGLUNIFORMMATRIX2X4FVPROC ELglUniformMatrix2x4fv;
extern PFNGLUNIFORMMATRIX3X2FVPROC ELglUniformMatrix3x2fv;
extern PFNGLUNIFORMMATRIX3X4FVPROC ELglUniformMatrix3x4fv;
extern PFNGLUNIFORMMATRIX4X2FVPROC ELglUniformMatrix4x2fv;
extern PFNGLUNIFORMMATRIX4X3FVPROC ELglUniformMatrix4x3fv;
/*	  GL_VERSION_2_1		  */

 

I greped some other symbols in that file and found that they are defined in /usr/include/SDL/SDL_opengl.h. I can't find these symbols defined in even the most recent stable release of libsdl (1.2.12). Is there a new dependency for this release? I'll admit to knowing virtually nothing about opengl programming which obviously doesn't help!

 

Anybody who can build elc should be able to look at what their include directories are during compilation, and grep for one of those symbols above (such as "PFNGLUNIFORMMATRIX2X3FVPROC") to find what file it is included in. Then use whatever tool is appropriate on your distro to find out where that file came from.

 

Thanks in advance. Once I get this working I'll submit the ebuild for inclusion in gentoo.

Share this post


Link to post
Share on other sites

/*	  GL_VERSION_2_1		  */
extern PFNGLUNIFORMMATRIX2X3FVPROC ELglUniformMatrix2x3fv;
extern PFNGLUNIFORMMATRIX2X4FVPROC ELglUniformMatrix2x4fv;
extern PFNGLUNIFORMMATRIX3X2FVPROC ELglUniformMatrix3x2fv;
extern PFNGLUNIFORMMATRIX3X4FVPROC ELglUniformMatrix3x4fv;
extern PFNGLUNIFORMMATRIX4X2FVPROC ELglUniformMatrix4x2fv;
extern PFNGLUNIFORMMATRIX4X3FVPROC ELglUniformMatrix4x3fv;
/*	  GL_VERSION_2_1		  */

Those openGL extension require the very latest glext.h which can be downloaded here

http://www.opengl.org/registry/api/glext.h

Share this post


Link to post
Share on other sites

Output from "make -f Makefile.linux"

gcc -march=i686 -Wall -Wdeclaration-after-statement -O0 -ggdb -pipe -DLINUX -DELC  -DAFK_FIX  -DALPHA_ACTORS  -DATI_9200_FIX  -DAUTO_UPDATE  -DCLICKABLE_CONTINENT_MAP  -DCLUSTER_INSIDES  -DCOUNTERS  -DCALCULATOR  -DCUSTOM_LOOK  -DCUSTOM_UPDATE  -DCXX_MISC  -DEYE_CANDY  -DFONTS_FIX  -DFUZZY_PATHS  -DIDLE_FIX  -DMASKING  -DMINES  -DMINIMAP  -DNEW_ACTOR_ANIMATION  -DNEW_ACTOR_SCALE  -DNEW_FILE_IO  -DNEW_SOUND  -DNEW_TEX  -DNOTEPAD  -DOGG_VORBIS  -DOPTIONS_I18N  -DPNG_SCREENSHOT  -DPOPUP  -DSFX  -DSIMPLE_LOD  -DUSE_INLINE  -DUSE_SEND_VIDEO_INFO  -DZLIB -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/libxml2 -fno-strict-aliasing  -c -o 2d_objects.o 2d_objects.c
In file included from 2d_objects.c:9:
load_gl_extensions.h:521: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglProgramEnvParameters4fvEXT’
load_gl_extensions.h:522: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglProgramLocalParameters4fvEXT’
make: *** [2d_objects.o] Error 1

 

What's going on here? All I did was checkout elc from cvs and try to make it...

 

Thanks,

frazierj

Share this post


Link to post
Share on other sites
...

In file included from 2d_objects.c:9:

load_gl_extensions.h:521: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglProgramEnvParameters4fvEXT’

load_gl_extensions.h:522: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglProgramLocalParameters4fvEXT’

make: *** [2d_objects.o] Error 1[/code]

What's going on here? All I did was checkout elc from cvs and try to make it...

You need a newer glext.h file, have a look at this Mantis bug report. There is also a long thread on CVS errors which has covered this recently.

Edited by bluap

Share this post


Link to post
Share on other sites

The latest Linux nVidia drivers install a glext.h which does not include those functions.

 

I wonder if we could mock up some script for makefile which would check for available extensions.

 

Or, as me and some others proposed, we ship our own.

 

Álvaro

Share this post


Link to post
Share on other sites
...

In file included from 2d_objects.c:9:

load_gl_extensions.h:521: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglProgramEnvParameters4fvEXT’

load_gl_extensions.h:522: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglProgramLocalParameters4fvEXT’

make: *** [2d_objects.o] Error 1[/code]

What's going on here? All I did was checkout elc from cvs and try to make it...

You need a newer glext.h file, have a look at this Mantis bug report. There is also a long thread on CVS errors which has covered this recently.

 

I downloaded the file here: http://el.beplacid.net/bugs/view.php?id=42 and placed in it /usr/include/GL (where the only other glext.h file was) and promptly received these error upon make

 

gcc -march=i686 -Wall -Wdeclaration-after-statement -O0 -ggdb -pipe -DLINUX -DELC  -DAFK_FIX  -DALPHA_ACTORS  -DATI_9200_FIX  -DAUTO_UPDATE  -DCLICKABLE_CONTINENT_MAP  -DCLUSTER_INSIDES  -DCOUNTERS  -DCALCULATOR  -DCUSTOM_LOOK  -DCUSTOM_UPDATE  -DCXX_MISC  -DEYE_CANDY  -DFONTS_FIX  -DFUZZY_PATHS  -DIDLE_FIX  -DMASKING  -DMINES  -DMINIMAP  -DNEW_ACTOR_ANIMATION  -DNEW_ACTOR_SCALE  -DNEW_FILE_IO  -DNEW_SOUND  -DNEW_TEX  -DNOTEPAD  -DOGG_VORBIS  -DOPTIONS_I18N  -DPNG_SCREENSHOT  -DPOPUP  -DSFX  -DSIMPLE_LOD  -DUSE_INLINE  -DUSE_SEND_VIDEO_INFO  -DZLIB -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/libxml2 -fno-strict-aliasing  -c -o 2d_objects.o 2d_objects.c
In file included from /usr/include/GL/gl.h:2149,
			 from platform.h:75,
			 from misc.h:10,
			 from vmath.h:13,
			 from 2d_objects.h:9,
			 from 2d_objects.c:4:
/usr/include/GL/glext.h:3742: error: expected declaration specifiers or ‘...’ before ‘GLintptr’
/usr/include/GL/glext.h:3742: error: expected declaration specifiers or ‘...’ before ‘GLsizeiptr’
In file included from load_gl_extensions.h:5,
			 from 2d_objects.c:10:
elglext.h:318: error: expected declaration specifiers or ‘...’ before ‘GLsizeiptr’
elglext.h:321: error: expected declaration specifiers or ‘...’ before ‘GLintptr’elglext.h:321: error: expected declaration specifiers or ‘...’ before ‘GLsizeiptr’
elglext.h:345: error: expected declaration specifiers or ‘...’ before ‘GLintptr’elglext.h:345: error: expected declaration specifiers or ‘...’ before ‘GLsizeiptr’
elglext.h:372: warning: type defaults to ‘int’ in declaration of ‘GLchar’
elglext.h:372: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
elglext.h:405: error: expected declaration specifiers or ‘...’ before ‘GLchar’
elglext.h:408: error: expected declaration specifiers or ‘...’ before ‘GLchar’
elglext.h:414: warning: type defaults to ‘int’ in declaration of ‘GLchar’
elglext.h:414: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
elglext.h:417: error: expected declaration specifiers or ‘...’ before ‘GLchar’
elglext.h:423: error: expected declaration specifiers or ‘...’ before ‘GLchar’
elglext.h:426: error: expected declaration specifiers or ‘...’ before ‘GLchar’
elglext.h:432: warning: type defaults to ‘int’ in declaration of ‘GLchar’
elglext.h:432: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
elglext.h:462: warning: type defaults to ‘int’ in declaration of ‘GLchar’
elglext.h:462: error: expected ‘;’, ‘,’ or ‘)’ before ‘*’ token
In file included from 2d_objects.c:10:
load_gl_extensions.h:189: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglBindAttribLocation’
load_gl_extensions.h:203: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglGetAttribLocation’
load_gl_extensions.h:209: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglGetUniformLocation’
load_gl_extensions.h:219: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglShaderSource’
load_gl_extensions.h:522: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglProgramEnvParameters4fvEXT’
load_gl_extensions.h:523: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘ELglProgramLocalParameters4fvEXT’
make: *** [2d_objects.o] Error 1

 

Do you have any idea this time?

 

Thanks,

frazierj

Share this post


Link to post
Share on other sites

elglext.h:318: error: expected declaration specifiers or ‘...’ before ‘GLsizeiptr’

Not sure why elglext.h is being used. If you replaced /usr/include/GL/glext.h with the newer file, you shouldn't need to modify the code and include elglext.h to get the compile to work. At least on Linux...

Share this post


Link to post
Share on other sites

I decided to have a go at compiling the client from CVS and ran into a few problems. After several cycles of compile-> error -> google, I found it necessary to download and install:-

  • SDL-1.2.13
  • openal-0.0.8
  • freealut-1.1.0

I made a bit more progress each time.

 

However, now I get to this point where I am stuck:

 276 /EL_CVS/elc$ make -f Makefile.linux				 
gcc -march=i686 -Wall -Wdeclaration-after-statement -O0 -ggdb -pipe -DLINUX -DELC  -DAFK_FIX  -DALPHA_ACTORS  -DATI_9200_FIX  -DAUTO_UPDATE  -DCLICKABLE_CONTINENT_MAP 
-DCLUSTER_INSIDES  -DCOUNTERS  -DCALCULATOR  -DCUSTOM_LOOK  -DCUSTOM_UPDATE  -DCXX_MISC
-DEYE_CANDY  -DFONTS_FIX  -DFUZZY_PATHS  -DIDLE_FIX  -DMASKING  -DMINES 
-DMINIMAP  -DNEW_ACTOR_ANIMATION  -DNEW_ACTOR_SCALE  -DNEW_FILE_IO  
-DNEW_SOUND  -DNEW_TEX  -DNOTEPAD  -DOGG_VORBIS  -DOPTIONS_I18N  
-DPNG_SCREENSHOT  -DPOPUP  -DSFX  -DSIMPLE_LOD  -DUSE_INLINE 
-DUSE_SEND_VIDEO_INFO  -DZLIB -I/usr/local/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/libxml2 -fno-strict-aliasing  -c -o 2d_objects.o 2d_objects.c
In file included from 2d_objects.c:10:
load_gl_extensions.h:521: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'ELglProgramEnvParameters4fvEXT'
load_gl_extensions.h:522: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'ELglProgramLocalParameters4fvEXT'
make: *** [2d_objects.o] Error 1

 

My system spec is:

  • Dell Vostro 1700 laptop with 2 Gigs RAM and Intel Core 2 Duo CPU
  • OS: Zenwalk 4.8 (Slackware based)
  • Nvidia 8600M GT graphics card with 512 MB memory

Would appreciate any help :P

 

EP

 

 

Edit: formatting

Edited by EaglePrince

Share this post


Link to post
Share on other sites
In file included from 2d_objects.c:10:

load_gl_extensions.h:521: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'ELglProgramEnvParameters4fvEXT'

load_gl_extensions.h:522: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'ELglProgramLocalParameters4fvEXT'

make: *** [2d_objects.o] Error 1[/code]

This is a known issue with several solutions but none that work for all systems. Have a look at this mantis report and let us know which solution works for you. If you can, try the option with a local glext.h and the GL_GLEXT_LEGACY #define as that's my personal favourite ATM.

Share this post


Link to post
Share on other sites
In file included from 2d_objects.c:10:

load_gl_extensions.h:521: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'ELglProgramEnvParameters4fvEXT'

load_gl_extensions.h:522: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'ELglProgramLocalParameters4fvEXT'

make: *** [2d_objects.o] Error 1[/code]

This is a known issue with several solutions but none that work for all systems. Have a look at this mantis report and let us know which solution works for you. If you can, try the option with a local glext.h and the GL_GLEXT_LEGACY #define as that's my personal favourite ATM.

Please bear with me, but I'm still having trouble.

 

I was trying to follow option 3 as suggested and downloaded glext.h from http://www.opengl.org/registry/api/glext.h and put it in a new folder under elc (i.e. in include/GL). I then added -include include/GL/glext.h to Makefile.linux at line 4.

Now I get

304 /EL_CVS/elc$ make -f Makefile.linux
include/GL/glext.h:5: *** missing separator.  Stop.

Apart from the Makefile.linux which I edited as mentioned, I have not altered the other header files in any way. I probably overlooked something...

Edited by EaglePrince

Share this post


Link to post
Share on other sites
I was trying to follow option 3 as suggested and downloaded glext.h

To use that option you need to add " -Iinclude" to the the compile line. One way would be to append that to the "OPTIONS =" line of the Makefile.linux.

Edited by bluap

Share this post


Link to post
Share on other sites

elglext.h:318: error: expected declaration specifiers or ‘...’ before ‘GLsizeiptr’

Not sure why elglext.h is being used. If you replaced /usr/include/GL/glext.h with the newer file, you shouldn't need to modify the code and include elglext.h to get the compile to work. At least on Linux...

 

*bump* I'm still having this problem, does anyone know why? I really would like to be able to enjoy the features of the cvs version...

Share this post


Link to post
Share on other sites

elglext.h:318: error: expected declaration specifiers or �...� before �GLsizeiptr�

Not sure why elglext.h is being used. If you replaced /usr/include/GL/glext.h with the newer file, you shouldn't need to modify the code and include elglext.h to get the compile to work. At least on Linux...

 

*bump* I'm still having this problem, does anyone know why? I really would like to be able to enjoy the features of the cvs version...

To be including elglext.h you must have modified platform.h, probably using the patch suggested by Florian. That patch was intended for OSX systems not windows or Linux. What platform are you using anyway? To restore your CVS copy, do "cvs update -d" then delete and files marked as modified "prefixed with M". Then "cvs update -d" again. If you are on Linux or windows, download the glext.h file from here and place in your CVS directory. Then modify platform.h like this:

Index: platform.h
===================================================================
RCS file: /cvsroot/elc/elc/platform.h,v
retrieving revision 1.13
diff -a -u -r1.13 platform.h
--- platform.h  9 Jan 2008 21:37:06 -0000	   1.13
+++ platform.h  30 Jan 2008 15:27:25 -0000
@@ -72,9 +72,10 @@
 #include <OpenGL/glu.h>
 #include <OpenGL/glext.h>
#else
+ #define GL_GLEXT_LEGACY
 #include <GL/gl.h>
 #include <GL/glu.h>
- #include <GL/glext.h>
+ #include "glext.h"
#endif

// Inlucde the plaform specific location sound libs

Share this post


Link to post
Share on other sites

Anyone knows why in the fucking world I get this error?

 

gcc -march=i686 -Wall -Wdeclaration-after-statement -O0 -ggdb -pipe -DWINDOWS -DELC -mwindows  -DAFK_FIX  -DALPHA_ACTORS  -DATI_9200_FIX  -DAUTO_UPDATE  -DCLICKABLE_CONTINENT_MAP  -DCLUSTER_INSIDES  -DCOUNTERS  -DCALCULATOR  -DCUSTOM_LOOK  -DCUSTOM_UPDATE  -DCXX_MISC  -DEYE_CANDY  -DFONTS_FIX  -DFUZZY_PATHS  -DIDLE_FIX  -DMASKING  -DMINES  -DMINIMAP  -DNEW_ACTOR_ANIMATION  -DNEW_ACTOR_SCALE  -DNEW_FILE_IO  -DNEW_SOUND  -DNEW_TEX  -DNOTEPAD  -DOGG_VORBIS  -DOPTIONS_I18N  -DPNG_SCREENSHOT  -DPOPUP  -DSFX  -DSIMPLE_LOD  -DUSE_INLINE  -DUSE_SEND_VIDEO_INFO  -DZLIB -fno-strict-aliasing -ID:\\Dev-Cpp\\Include\\AL -ID:\\Dev-Cpp\\Include\\SDL main.o -L. -lelc -lstdc++						-lpng				  -lz		-lvorbisfile -lvorbis -logg	-lpng			-lz -llibxml2 -lSDL_net -lSDL_image -lsdl -lalut -lopenal32 -lglu32 -lopengl32 -liconv -lcal3d -lm -lstdc++ elc_private.o -o el.exe

./libelc.a(actor_scripts.o)(.text+0xdc): In function `cal_actor_set_random_idle':
D:\my game/actor_scripts.c:390: undefined reference to `CalMixer_RemoveAction'
./libelc.a(actor_scripts.o)(.text+0x585e): In function `cal_load_idle':
D:\my game/actor_scripts.c:2429: undefined reference to `CalCoreAnimation_Scale'
./libelc.a(actor_scripts.o)(.text+0x7330): In function `cal_load_mesh':
D:\my game/actor_scripts.c:2913: undefined reference to `CalCoreMesh_Scale'
./libelc.a(actor_scripts.o)(.text+0x7441): In function `cal_load_weapon_mesh':
D:\my game/actor_scripts.c:2950: undefined reference to `CalCoreMesh_Scale'

./libelc.a(actor_scripts.o)(.text+0x806b): In function `parse_actor_script':
D:\my game/actor_scripts.c:3156: undefined reference to `CalCoreSkeleton_Scale'
./libelc.a(cal.o)(.text+0x120): In function `cal_actor_set_anim_delay':
D:\my game/cal.c:76: undefined reference to `CalMixer_RemoveAction'
./libelc.a(cal.o)(.text+0x6d1): In function `cal_load_anim':
D:\my game/cal.c:237: undefined reference to `CalCoreAnimation_Scale'
collect2: ld returned 1 exit status
make.exe: *** [el.exe] Error 1

Execution terminated

 

YES, I do have libcal3d.a in my /lib directory. In fact, I am using the windows make file without modifications... And yes, that libcal3d.a is up to date, and it DOES have those 'missing' functions. I am really frustrated with this whole windows client.

Share this post


Link to post
Share on other sites
I was trying to follow option 3 as suggested and downloaded glext.h

To use that option you need to add " -Iinclude" to the the compile line. One way would be to append that to the "OPTIONS =" line of the Makefile.linux.

Thanks for the tip, but I refreshed from CVS last night and the problem is fixed. I have now successfully compiled the client :( but the models look weird. I look like a disfigured dwarf and I'm draegoni! :huh:

 

I couldn't find several folders in CVS so I took them from the main client zip file...textures, maps, etc. Should I have done that?

 

Also, I will be moving to 64-bit AMD-based hardware over the weekend. I would appreciate it if someone could point me in the direction of what settings I may need to change in the Makefile.

 

Edit/Update:

Ok, I figured out what I was doing wrong. I was trying to run the newly-compiled client in its own folder instead of simply replacing the original client! :omg:

 

So, I now have everything working just right, including sound :D . All I have to do now is repeat the feat when I upgrade my computer tomorrow :)

 

Thanks to the devs for a splendid piece of work, and special thanks to bluap for all your help with all that. :)

Edited by EaglePrince

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×