Jump to content
Eternal Lands Official Forums
firmin-holy

I Need help for playing EL on Mandriva

Recommended Posts

Hello, as you can see, my english is bad and all long and technical information i can find here make me just more lost.

Here is information how to install the game on the dowload page :

 

To play on Linux:

-Download the zip file, and unzip it.

Done, that was easy :icon8:

 

-cd to the directory where you installed it.

Also easy, it's there: /home/underfire/Desktop/Eternal Lands-1.33

 

-chmod to 775 and execute el-133.x86.linux.static

Can someone give me the exact syntax please? I have no idea what you talking about here. When i execute el-133.x86.linux.static, i can logon into the game but i have many error (screenshot here: http://i165.photobucket.com/albums/u42/und...t/wrongpath.jpg ) and i cannot see the text, icons and my character

 

-edit el.ini and change datadir to where you unzip everything

Yes, it was easy but i must be numb because i still have wrong path error when i launch the game

 

Please help a poor n00b to not get back on the dark side :icon4:

Share this post


Link to post
Share on other sites

Make sure you're editing the right el.ini (~/.elc/el.ini); see also here.

Share this post


Link to post
Share on other sites
-edit el.ini and change datadir to where you unzip everything

Yes, it was easy but i must be numb because i still have wrong path error when i launch the game

You probably edit wrong el.ini. Check where the #data_dir in your el.ini (in ~./elc), points at. For your installation should be /home/underfire/Desktop/Eternal Lands-1.33.

Share this post


Link to post
Share on other sites

Thanks guys,

 

I reinstalled windows :lurker: and put FR language instead of EN in my el.ini and got the same wrong path error.

 

But i will reinstall mandriva on another partition and i will try to run this game again...but maybe it's my old video card doesnt work.

 

Thanks for help.

Share this post


Link to post
Share on other sites

I couldnt get the game to install on Ubuntu no matter what. In the end i found an auto-installer package on the Ubuntu forums.That definitely saved my life though you have to get writing rights for every single file that you want to modify,maps,music, updates...

So this time i wanted to try something else, i tried installing the game after EL's "official" instructions, but it keept telling me that the /Eternal Lands-1.33 folder doesnt exist when i tried cd and of course chmod-ing didnt work either.

Here's my solution, i typed in terminal "sudo chmod o+w /usr/local/games" hit refresh then unzipped my EL folder there, which i renamed "el".

Then i put in the command: "chmod 775 /usr/local/games/el/el-133.x86.linux.static"

Added the maps and music with no other problems and so far everything is working well.

If you find any mistakes in my post,please let me know and also excuse me, i did this a few days ago and i'm writing from memory now.

Anyway i hope this method helps and its correct. If not....well dont blame me, i'm still learning this :lipssealed:

Share this post


Link to post
Share on other sites

in the interests of sharing knowledge (not to say anything is wrong)...

if you're the only user of your computer, then file access rights aren't that big a deal, but... giving write access to all the world (o) isn't generally the best idea. better to add your main user to a 'games' group (many distros will already have one... if not, you can make a new group) and make the 'games' group have group ownership of all gaming files (except stuff in, for example, ~/.elc/ of course). you then have all files that users will want to change having group write access (g+rw for files, g+rwx for directories and programs. in octal, (0)664 for files, (0)775 for directories and programs)

using this approach, you can still share write access to a number of people, but with control over which people

 

the other option is if you install it only for yourself (possibly in your home directory. /home/username/games/el would work quite well), have normal user rights for the files, and simply edit el.ini to point to the right folder. you shouldn't have any problems with permissions at all using this approach

Share this post


Link to post
Share on other sites

You're quite right about the danger of giving rights to any user of a computer, but then again, you're just granting rights for that game folder not for your entire system. Now i'm really not sure about this but i think there's a way to lock that folder, once you're done with it.

I guess my way is not the safest, maybe not even correct, but it worked for me,where other methods failed. :lipssealed:

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×