Jump to content
Eternal Lands Official Forums
Roja

Skybox discussion

Recommended Posts

pixelated sky: i get this from time to time, even at night. It lasts a couple of minutes and then goes back to normal.

I've never seen that, maybe I spend too much time in caves... :D

 

Anyway, I think to know from where comes the problem but it's really weird though and I suspect a mac issue. Do you have a rough estimation of the period at which it appears?

Can you try to go in the underworld on test server and see if it happens too? (the clouds have a greater speed there so you might see it faster)

Share this post


Link to post
Share on other sites

With SKY_FPV defined i get this:

 

25322459al3.th.jpg

 

Have the following defines:

ELC

ACTOR_FACE_CULLING

ALPHA_ACTORS

CLUSTER_INSIDES

CALCULATOR

CACHE_ANIMATIONS

CUSTOM_LOOK

CUSTOM_UPDATE

FUZZY_PATHS

MASKING

MISSILES

NEW_ACTOR_ANIMATION

NEW_ACTOR_MOVEMENT

NEW_CAMERA

NEW_SELECTION

NEW_SOUND

NEW_TEX

POPUP

TEXT_ALIASES

USE_INLINE

USE_SHADER

ZLIB

SKY_FPV

Share this post


Link to post
Share on other sites

Try to change your near and far clip planes values in the options and see if it helps.

You should go for a value under 1.0 for the near plane and a value over 50.0 for the far plane.

Share this post


Link to post
Share on other sites
free camera: free camera can go underground. To reproduce this you have to place the camera almost at ground level and then move it with a fast mouse stroke. It also seems impossible to bring it back over the surface...i switch to first person and back.

It should be fixed now. In fact, I've changed the way the up & down keys change the camera angle so now the movement is smoother like when you use the mouse.

If it's a problem, I can adjust the speed of the movement.

 

There seems to be a bug in how SKY_FPV handles ini entries: I get these on my el.ini (last lines):

 

#follow_cam_behind= 0
#ext_cam_auto_zoom= 1
#follow_cam_behind= 0
#follow_cam_behind= 0
#follow_cam_behind= 1
#follow_cam_behind= 0
#follow_cam_behind= 1
#follow_cam_behind= 0
#follow_cam_behind= 0
#follow_cam_behind= 0
#follow_cam_behind= 0

 

Quickly fixable, I suppose.

 

Álvaro

It's fixed.

This one was quite funny. :)

It was caused because there was the 2 following options: follow_cam and follow_cam_behind

When reading the config file, it was reading the second option like if it was the first because of a strncmp using the size of the first option. :P

So now, we know that we should never use an option that start with the complete name of another option... :D

Share this post


Link to post
Share on other sites
free camera: free camera can go underground. To reproduce this you have to place the camera almost at ground level and then move it with a fast mouse stroke. It also seems impossible to bring it back over the surface...i switch to first person and back.

It should be fixed now. In fact, I've changed the way the up & down keys change the camera angle so now the movement is smoother like when you use the mouse.

If it's a problem, I can adjust the speed of the movement.

 

 

I don't think this is fixed as I compiled the client today and it happens to me now.

Although when it happensto me it wasn't from a quick mouse movement, I just keep dragging the camera downwards with the mouse and it went below ground.

I also did get it stuck below ground a couple times and had to alt+f to get out of it..although now I can't seem to reproduce it again, I'll keep trying to see what it is that did it.

 

Also, it seems pageup/down no longer zooms? A bug I guess?

Share this post


Link to post
Share on other sites

Yes the page up/down was a bug and it's fixed.

 

About the camera going under the ground, is it without the auto zoom and can you reproduce it if you enable it?

Share this post


Link to post
Share on other sites

The follow cam behind the actor is great :P

But, when standing around, I'd like to have free camera movement. When the char walks again, then the cam should snap back behind the char.

I think the busy flag in one of the actor structs tells if the char is standing around or doing something.

Share this post


Link to post
Share on other sites
About the camera going under the ground, is it without the auto zoom and can you reproduce it if you enable it?

 

Yes it was without autozoom. With autozoom on at the zoomed out max level it does start to go undergound, but then it zooms in and doesn't show up when zoomed in.

Share this post


Link to post
Share on other sites

I'm not sure, I have to look at it...

In fact, the new cursors were a big hack because they were displayed at the position of the mouse and the real cursor was hidden. So in grab mode, the cursor was displayed at the center of the screen but with normal cursors it seems that you can't do that so it is why it is hidden.

I'll try to see if we can do it anyway but if not, we'll have to do what emajekral was doing which means drawing a fake cursor in the middle of the screen. And maybe we can use the cursors he has defined?

Share this post


Link to post
Share on other sites

The problem with using his cursors was that they were just slow and not as responsive compared to the original cursors. Obviously I'm not talking about grab mode here, but the normal modes. So unless that's taken care of I would not replace the originals at all.

Share this post


Link to post
Share on other sites

I just noticed 2 things:

 

1. In first person view, if you look at the sky you can zoom in/out and only the skybox will zoom in/out.

 

2. In 3rd person view, if you have the camera angled as far down to the ground as it can go, and then you hold the mouse button and drag up really quick, the view will go under the ground for a second-it doesn't stick there.

Share this post


Link to post
Share on other sites

When i turn the frame buffer off, i dont see any clouds/moon/sun/stars until i restart the client.

 

10388454wb4.th.jpg

 

How to reproduce:

1. Set the water shades quality to 2

2. Disable the framebuffer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×